Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • O nome NetBIOS do domínio do Active Directory contém um caractere em um ambiente do Microsoft Exchange Server 2010 "e" comercial (&).

  • Você tenta instalar o Exchange Server 2010 Service Pack 1 (SP1) em um servidor no ambiente.

Nesse cenário, a instalação falhará. Além disso, a seguinte mensagem de erro é exibida:

Ocorreu um erro durante a análise de EntityName. Line7, posicione a 12.

Causa

Esse problema ocorre porque o caractere e comercial é um caractere reservado em XML. Portanto, o caractere faz com que a análise de usuário de logon atual falhar.

Resolução

Para resolver esse problema, siga estes passos.Observação Este problema é resolvido na atualização do pacote cumulativo de atualizações 4 para o Exchange Server 2010 Service Pack 1. Para obter mais informações, clique no número abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft:

2579150 Descrição do pacote cumulativo de atualizações 4 do Exchange Server 2010 Service Pack 1

  1. Copie todos os arquivos de instalação do CD para um disco rígido e, em seguida, abra o arquivo ManageScheduledTask.ps1 na pasta scripts.

  2. Localize as seguintes linhas:

    function Get-CurrentUserName { [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() $id.Name }
  3. Altere as linhas da seguinte maneira:

    function Get-CurrentUserName{ [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() [System.String]$fixedName = $id.Name.Replace('&','`&') return $fixedName }
  4. Salve o arquivo e, em seguida, tente instalar o Exchange Server 2010 SP1 do disco rígido.

  5. Instale a seguinte atualização:

    2579150 Descrição do pacote cumulativo de atualizações 4 do Exchange Server 2010 Service Pack 1

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×