Sintomas
Quando você tenta modificar os dados da empresa na janela Gerenciar Instalação da Empresa, recebe a seguinte mensagem de erro:
A empresa selecionada está sendo modificada por outro usuário
Esse problema ocorre quando você usa o Gerenciamento de Requisitos no Portal de Negócios para o Microsoft Dynamics GP e para o Microsoft Business Solutions - Great Plains.
Quando esse problema ocorre, nenhum outro usuário está acessando os dados da empresa no Portal de Negócios.
Causa
A mensagem de erro é causada por um registro de usuário que não está sendo limpo da tabela MultiUserManager. A tabela MultiUserManager está localizada no banco de dados do Dynamics.
Resolução
Para resolver este problema, execute as seguintes etapas:
-
Execute o script a seguir SQL Analisador de Consultas para ver quais registros de usuário não estão sendo limpos na tabela MultiUserManager.
SELECT * FROM DYNAMICS..MultiUserManager
Observação A tabela MultiUserManager deve ser limpa a cada 20 minutos. No entanto, os registros de usuário às vezes permanecem na tabela.
-
Para excluir o registro do usuário da tabela, execute o seguinte script.
Observação Fazer o back up do banco de dados do Dynamics antes de executar o script.DELETE DYNAMICS..MultiUserManager WHERE UserID = XXX
Observação Substitua XXX pela ID do usuário do registro do usuário que foi retornado na etapa 1.
Informações adicionais
Etapas para reproduzir o problema
-
Iniciar Portal de Negócios.
-
Clique em Sites Configurações, aponte para Aplicativo Configurações, aponte para Requisiçõese clique em Instalação da Empresa.
-
Selecione uma empresa e clique em Modificar.