Iniciar sessão com uma conta Microsoft
Inicie sessão ou crie uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Escolha a conta com a qual pretende iniciar sessão.

O código de campo = (Fórmula) calcula um número utilizando uma fórmula matemática.

Pode utilizar o comando Fórmula no separador Esquema, que aparece quando clica dentro de uma tabela, para adicionar este campo a um documento. Também pode adicioná-lo através da caixa de diálogo Campo.

No Windows, para abrir a caixa de diálogo Campo, selecione o separadorInserir. No grupo Texto, selecione Peças Rápidase, em seguida, Campo. No Mac, selecione o separador Inserire, em seguida, selecione Campo. (Se não vir a opção Campo, poderá ter de selecionar Textoprimeiro.)

O código de campoinforma o Word acerca do que inserir ou fornecer ao documento depois de determinar o valor do código de campo, como a data atual ou o número de páginas. Normalmente, o valor resultante é apresentado como parte do documento. Pode alternar entre ver o resultado ou ver o código de campo ao premir Alt+F9 no Windows ou Fn+Opção+F9 no Mac.

Sugestão: Se tiver uma aplicação de formulário, como o Excel, é frequentemente mais fácil incorporar toda ou parte de uma base de dados num documento do que utilizar o campo = (Fórmula).

Sintaxe

Quando visualiza o código de campo = (Fórmula) no seu documento, a sintaxe tem o seguinte asqueto:

{ = Fórmula [Marcador ] [\#Formato Numérico ] }

Instruções

Uma fórmula é uma expressão que pode conter qualquer combinação de números, marcadores que referenciam números, campos que resultam em números e os operadores e funções disponíveis. A expressão pode referenciar valores numa tabela e valores devolvidos por funções.

Obtenha mais informações sobre:

Operadores

Num campo = (Fórmula), pode utilizar qualquer combinação de valores e os operadores matemáticos e relacionais que se seguem.

+

Adição

Subtração

*

Multiplicação

/

Divisão

%

Percentagem

^

Potências e raízes

=

Igual a

<

Menor que

< =

Menor ou igual a

>

Maior que

> =

Maior ou igual a

< >

Diferente de

Funções

O campo = (Fórmula) pode utilizar valores devolvidos pelas funções que se seguem. As funções com parênteses vazios podem aceitar qualquer número de argumentos. Os argumentos têm de estar separados pelo separador de lista definido nas definições regionais no Painel de Controlo do Microsoft Windows, uma vírgula (,) ou um ponto e vírgula (;). Os argumentos podem ser números, fórmulas ou nomes de marcadores. As funções MÉDIA(), CONTAR(), MÁXIMO(), MÍNIMO(), PRODUTO() e SOMA() também podem aceitar referências a células de tabela como argumentos.

ABS(x)

Devolve o valor positivo de um número ou fórmula, independentemente do valor positivo ou negativo real correspondente.

E(x;y)

Devolve o valor 1 se as expressões lógicas x e y forem ambas verdadeiras ou o valor 0 (zero) se uma das expressões for falsa.

MÉDIA( )

Devolve a média de uma lista de valores.

CONTAR( )

Devolve o número de itens numa lista.

DEFINIDO(x)

Devolve o valor 1 (verdadeiro) se a expressão x for válida ou o valor 0 (falso) se não for possível calcular a expressão.

FALSO

Devolve o valor 0 (zero).

INT(x)

Devolve os números à esquerda da casa decimal no valor ou fórmula x.

MÍN( )

Devolve o valor mais baixo numa lista.

MÁX( )

Devolve o valor mais alto numa lista.

MOD(x;y)

Devolve o resto que resulta da divisão do valor x pelo valor y um número inteiro de vezes.

NÃO(x)

Devolve o valor 0 (zero) (falso) se a expressão lógica x for verdadeira ou o valor 1 (verdadeiro) se a expressão for falsa.

OU(x;y)

Devolve o valor 1 (verdadeiro) se uma ou ambas as expressões lógicas x e y forem verdadeiras ou o valor 0 (zero) (falso) se ambas as expressões forem falsas.

PRODUTO( )

Devolve o resultado da multiplicação de uma lista de valores. Por exemplo, a função { = PRODUTO (1;3;7;9) } devolve o valor 189.

ARRED(x;y)

Devolve o valor de x arredondado para o número de casas decimais y especificado; x pode ser um número ou o resultado de uma fórmula.

SINAL(x)

Devolve o valor 1 se x for um valor positivo ou o valor –1 se x for um valor negativo.

SOMA( )

Devolve a soma de uma lista de valores ou fórmulas.

VERDADEIRO

Devolve o valor 1.

Referências de tabela

Quando efetua cálculos numa tabela, referencia as células de tabela como A2, B1, B2, A1 e assim sucessivamente, em que a letra representa uma coluna e o número representa uma linha. As referências de célula no Microsoft Word, ao contrário do que acontece no Microsoft Excel, são sempre referências absolutas e não são mostradas com cifrões. Por exemplo, a referência a uma célula como A1 no Word é idêntica à referência a uma célula como $A$1 no Excel.

Tabela que ilustra referências de célula

Referenciar células individuais

Para referenciar células em fórmulas, utilize um ponto e vírgula para separar referências a células individuais e dois pontos para separar a primeira e a última células num intervalo designado, conforme mostrado nos exemplos que se seguem.

Para obter a média destas células:

Tabela com intervalo de células selecionado

=média(b:b) ou =média(b1:b3)

Tabela com intervalo de células selecionado

=média(a1:b2)

Tabela com intervalo de células selecionado

=média(a1:c2) ou =média(1:1;2:2)

Tabela com intervalo de células selecionado

=média(a1;a3;c2)

Referenciar uma linha ou coluna completa

Pode referenciar uma linha ou coluna completa num cálculo das seguintes formas:

  • Utilize um intervalo que inclua apenas a letra ou número que o representa (por exemplo, 1:1 para referenciar a primeira linha da tabela). Esta designação permite que o cálculo inclua automaticamente todas as células na linha, se decidir adicionar outras células posteriormente.

  • Utilize um intervalo que inclua células específicas (por exemplo, a1:a3 para referenciar uma coluna com três linhas). Esta designação permite que o cálculo inclua apenas essas células em particular. Se adicionar outras células posteriormente e pretender que o cálculo as inclua, será necessário editar o cálculo.

Referenciar células noutra tabela

Para referenciar células noutra tabela ou para referenciar uma célula fora de uma tabela, identifique a tabela com um marcador. Por exemplo, o campo { =média(Tabela2 b:b) } obtém a média da coluna B na tabela marcada pelo marcador Tabela2.

Marcador

O nome de um marcador que referencia um ou mais valores.

\# Formato Numérico

Especifica a apresentação de um resultado numérico. Este parâmetro denomina-se parâmetro de "formato", uma vez que o utilizador recorre a símbolos para representar o formato do resultado do campo.

Por exemplo, o interruptor \# 0,00 $ em { = SOMA(ACIMA) \# 0,00 $ } apresenta um resultado como "4.455,70$". Se o resultado de um campo não for um número, este parâmetro não tem qualquer efeito.

Nota: Não é necessário incluir aspas em imagens numéricas simples que não incluam espaços , por exemplo , { VendasDe Março \# 0,00 $ }. Para formatos numéricos mais complexos e que incluam texto ou espaços, coloque o formato numérico entre aspas, tal como é apresentado nos seguintes exemplos de itens de formato. O Word adiciona aspas a comutadores de imagem numérica se inserir um campo utilizando o comando Campo no separador Inserir ou o comando Fórmula no menu Esquema (que aparece quando clica numa tabela).

Combine os seguintes itens de formato para construir um parâmetro de formato numérico.

Itens de formato

0 (zero)

Especifica as casas numéricas necessárias a apresentar no resultado. Se o resultado não incluir um dígito nessa casa, o Word apresenta um 0 (zero). Por exemplo, { = 4 + 5 \# 00,00 } apresenta "09,00".

#

Especifica as casas numéricas necessárias a apresentar no resultado. Se o resultado não incluir um dígito nessa casa, o Word apresenta um espaço. Por exemplo, { = 9 + 6 \# ###€ } apresenta " 15€".

x

Ignora os dígitos à esquerda do marcador de posição "x". Se o marcador de posição estiver à direita da vírgula decimal, o Word arredonda o resultado para essa casa. Por exemplo:
{ = 111053 + 111439 \# x## } apresenta "492".
{ = 1/8 \# 0,00x } apresenta "0,125".
{ = 3/4 \# ,x } apresenta ",8".

. (ponto decimal)

Determina a posição da vírgula decimal. Por exemplo, { = SOMA(ACIMA) \# ###,00€ } apresenta "495,47€".

Nota: No Windows, utilize o símbolo decimal especificado como parte das definições regionais no Painel de Controlo.

. (símbolo de agrupamento de dígitos)

Separa uma série de três dígitos. Por exemplo, { = LucroLíquido \# #.###.###€ } apresenta "2.456.800€".

Nota: No Windows, utilize o símbolo de agrupamento de dígitos especificado pelas definições regionais Painel de Controlo.

- (sinal de subtração)

Adiciona um sinal de subtração a um resultado negativo ou adiciona um espaço se o resultado for positivo ou 0 (zero). Por exemplo, { = 10 - 90 \# -## } apresenta "-80".

+ (sinal de adição)

Adiciona um sinal de adição a um resultado positivo, um sinal de subtração a um resultado negativo ou um espaço se o resultado for 0 (zero). Por exemplo, { = 100 - 90 \# +## } apresenta "+10" e { = 90 - 100 \# +## } apresenta "-10".

%, $, *, etc.

Inclui o caráter especificado no resultado. Por exemplo, { = lucrolíquido \# "##%" } apresenta "33%".

"positivo; negativo"

Especifica formatos de número diferentes para resultados positivos e negativos. Por exemplo, se o marcador Vendas95 for um valor positivo, o campo { Vendas95 \# "#.##0,00€;-#.##0,00€" } apresenta o valor com formatação normal, por exemplo, "1.245,65€". Será apresentado um valor negativo com formatação a negrito e um sinal de subtração, por exemplo, "- 345,56€".

"positivo; negativo; zero"

Especifica formatos de número diferentes para um resultado positivo, para um resultado negativo e para um resultado 0 (zero). Por exemplo, de acordo com o valor do marcador Vendas95, { Vendas95 \# "#.##0,00€;(#.##0,00€);0€" } apresenta valores positivos, negativos e valores 0 (zero) tal como se segue: 1.245,65€, ( 345,56€), 0€

'texto'

Adiciona texto ao resultado. Coloque o texto entre plicas. Por exemplo, { = { Preço } *8,1% \# "##0,00€ 'de imposto sobre vendas' " } apresenta "347,44€ de imposto sobre vendas".

`itemnumerado`

Apresenta o número do item anterior que numerou com o comando Inserir Legenda ou ao inserir um campo SEQ.

Coloque o identificador do item, tal como "tabela" ou "figura", entre acentos graves (`). O número sequencial é apresentado em números Árabes. Por exemplo, { = Soma(A1:D4) \# "##0,00 'é o total da Tabela' `table`" } apresenta "456,34 é o total da Tabela 2".

Para adicionar uma legenda a um objeto, no Windows, clique com o botão direito do rato no objeto ou, no Mac, prima Controlo+Clique no objeto e, em seguida, selecionar Inserir Legenda.

Exemplos

Exemplo 1

O campo seguinte subtrai um valor representado pelo marcadorGrossSales. O comutador de imagem numérico apresenta os resultados com um sinal de moeda, por exemplo, 14.786,17 $:

{ = VendasBrutas-29.897,62 \# "#.##0,00€" }

Exemplo 2

O campo = (Fórmula) seguinte conta o número total de páginas num documento cuja numeração de páginas começa em 47; apresenta um resultado como "Página 51 de 92":

Página { PAGE } de { = (47 - 1) + { NUMPAGES } }

Exemplo 3

Os exemplos que se seguem referenciam valores numa tabela. As referências de célula nos exemplos referenciam células na tabela que contêm o campo = (Fórmula). Se o campo não constar da tabela referenciada, marque a tabela com um marcador e especifique o marcador, seguido das referências de célula.

{ = SOMA(ACIMA) } (inserido numa célula de tabela)

A soma das células, desde a célula acima do campo até à parte superior da coluna ou até à primeira célula em branco ou valor ilegal.

{ = SOMA(Table3 C3) }

O conteúdo da célula na terceira coluna da terceira linha da tabela marcada pelo marcador "Table3".

{ = MÍN(Table3 A3:D3) }

O valor mais baixo nas primeiras quatro células na terceira linha da tabela marcada pelo marcador "Table3".

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft Office insiders

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×