O Microsoft Excel mostra o erro #DIV/0! quando um número é dividido por zero (0). Ocorre quando introduz uma fórmula simples como =5/0 ou quando uma fórmula faz referência a uma célula com 0 ou em branco, como apresentado nesta imagem.

Exemplos de fórmulas que causam #DIV/0! existentes.

Para corrigir o erro, efetue um dos seguintes procedimentos:

  • Certifique-se de que o divisor da função ou fórmula não é zero ou uma célula em branco.

  • Altere a referência de célula na fórmula para outra célula que não tenha um valor de zero (0) ou em branco.

  • Introduza #N/D na célula referenciada como divisor na fórmula, isto irá alterar o resultado da fórmula para #N/D para indicar que o valor do divisor não está disponível.

Muitas vezes, o #DIV/0! não pode ser evitado porque as suas fórmulas estão a aguardar a entrada de si ou de outra pessoa. Nesse caso, não quer que a mensagem de erro seja apresentada, por isso existem alguns métodos de manuseamento de erros que pode utilizar para suprimir o erro enquanto aguarda pela entrada.

Avaliar o denominador para zero ou nenhum valor

A forma mais simples de suprimir o erro #DIV/0! é utilizar a função SE para avaliar a existência do denominador. Se for um zero ou nenhum valor, apresente um zero ou nenhum valor como o resultado da fórmula em vez do valor de erro #DIV/0!. Caso contrário, calcule a fórmula.

Por exemplo, se a fórmula que devolve o erro for =A2/A3, utilize =SE(A3;A2/A3;0) para devolver 0 ou =SE(A3;A2/A3;"") para devolver uma cadeia em branco. Também pode apresentar uma mensagem personalizada, por exemplo: =SE(A3;A2/A3;"Introdução Obrigatória"). Com a função QUOCIENTE do primeiro exemplo, utilizaria =SE(A3;QUOCIENTE(A2;A3);0). Esta função indica ao Excel SE(A3 existir, então devolver o resultado da fórmula, caso contrário ignorar).

Exemplos de resolução #DIV/0! existentes.

Utilize SE.S para suprimir as #DIV/0! #BUSY!

Também pode suprimir este erro ao aninhar a operação de divisão dentro da função SE.ERRO. Mais uma vez, com A2/A3, pode utilizar =SE.ERRO(A2/A3;0). Isto diz ao Excel para devolver 0 se a sua fórmula for avaliada como erro e, caso contrário, para devolver o resultado da fórmula.

Para versões do Excel anteriores ao Excel 2007, pode utilizar o método SE(É.ERRO()): =SE(É.ERRO(A2/A3);0;A2/A3) (Consulte Funções É).

Nota: os métodos SE.ERRO e SE(É.ERRO()) são alças de erro em cobertor, uma vez que irão suprimir todos os erros e não apenas #DIV/0!. Tem de se certificar de que a sua fórmula funciona corretamente antes de aplicar qualquer manuseamento de erros, caso contrário poderá não se aperceber que a sua fórmula não está a funcionar como esperado.

Sugestão: Se a verificação de erros estiver ativada no Excel, pode clicar em Imagem de Botão junto à célula que mostra o erro. Clique em Mostrar Passos do Cálculo, se for apresentado, e escolha a solução adequada para os dados em questão.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Função SE

Função SE.ERRO

Funções É

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft Office insiders

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×