Como corrigir um #REF! #BUSY!

O erro #REF! é apresentado quando uma fórmula faz referência a uma célula que não é válida. Isto acontece com mais frequência quando as células que foram referenciadas por fórmulas são eliminadas ou algo é colado nas mesmas.

Exemplo: erro #REF! causado pela eliminação de uma coluna

O seguinte exemplo utiliza a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula a utilizar referências explícitas a células como =SOMA(B2;C2;D2) pode causar um erro #REF! se uma coluna for eliminada.

Se eliminasse a coluna B, C ou D, a ação causaria um #REF! #CAMPO!. Neste caso, vamos eliminar a coluna C (Vendas de 2007) e a fórmula agora lê =SOMA(B2;#REF!;C2). Quando utiliza referências explícitas a células como esta (onde referencia cada célula individualmente, separadas por uma rgula) e elimina uma linha ou coluna referenciada, o Excel não consegue resolvê-lo, pelo que devolve a #REF! #CAMPO!. Esta é a razão principal pela qual não é recomendada a utilização de referências explícitas a células em funções.

Exemplo do erro #REF! causado pela eliminação de uma coluna.

Solução

  • Se tiver eliminado acidentalmente linhas ou colunas, pode clicar imediatamente no botão Anular na Barra de Ferramentas de Acesso Rápido (ou premir Ctrl+Z) para restaurá-las.

  • Ajuste a fórmula para que utilize uma referência de intervalo em vez de células individuais, como =SOMA(B2:D2). Agora pode eliminar qualquer coluna no intervalo de soma e o Excel ajusta automaticamente a fórmula. Também pode utilizar =SOMA(B2:B5) para uma soma de linhas.

Exemplo: PROCV com referências de intervalo incorretas

No seguinte exemplo, =PROCV(A8;A2:D5;5;FALSO) devolve um erro #REF! pois está a procurar um valor para devolver da coluna 5, mas o intervalo de referência é A:D, que engloba apenas 4 colunas.

Exemplo de uma fórmula DAV COM um intervalo incorreto.  A fórmula é =A8;A2:D5;5;FALSO).  Não existe uma quinta coluna no intervalo DAV, pelo que 5 causa um #REF! #CAMPO!.

Solução

Aumente o intervalo ou reduza o valor de pesquisa da coluna para corresponder ao intervalo de referência. =PROCV(A8;A2:E5;5;FALSO) seria um intervalo de referência válido, tal como =PROCV(A8;A2:D5;4;FALSO).

Exemplo: ÍNDICE com uma referência de linha ou coluna incorreta

Neste exemplo, a fórmula =ÍNDICE(B2:E5;5;5) devolve um erro #REF! porque o intervalo de ÍNDICE engloba 4 linhas e 4 colunas, mas a fórmula pede para devolver os conteúdos da quinta linha e da quinta coluna.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo engloba apenas 4 linhas e 4 colunas.

Solução

Ajuste as referências de linha ou coluna para incluí-las no intervalo de pesquisa de ÍNDICE. =ÍNDICE(B2:E5;4;4) devolve um resultado válido.

Exemplo: fazer referência a um livro fechado com a função INDIRETO

No exemplo seguinte, uma função INDIRETO está a tentar referenciar um livro que está fechado, causando um #REF! #CAMPO!.

Exemplo de um erro #REF! causado pela função INDIRETO a fazer referência a um livro fechado.

Solução

Abra o livro referenciado. Irá deparar-se com o mesmo erro se referenciar um livro fechado com uma função de matriz dinâmica.

Problemas OLE

Se tiver utilizado uma ligação OLE (Ligação e Incorporação de Objetos) que está a devolver uma #REF! e, em seguida, inicie o programa para oção em que a ligação está a ligar.

Nota: OLE é uma tecnologia que pode utilizar para partilhar informações entre programas.

Problemas de DDE

Se tiver utilizado um tópico de Exchange Dinâmico (DDE) que está a devolver uma #REF! , primeiro certifique-se de que está a referenciar o tópico correto. Se ainda estiver a receber uma #REF! , verifique se o seu Definições de Confiança contém conteúdo externo conforme sublinhado em Bloquear ou desbloquear conteúdos externos em Office documentos.

Nota: O Dynamic Data Exchange (DDE)é um protocolo estabelecido para a troca de dados entre programas baseados Windows Microsoft.

Problemas Macro

Se uma macro introduzir na mesma uma função que se refira a uma célula acima da função e a célula que contém a função estiver na linha 1, a função devolverá #REF! porque não existem células acima da linha 1. Verifique a função para ver se um argumento se refere a uma célula ou intervalo de células que não seja válido. Esta ação poderá implicar a edição da macro Visual Basic Editor de Macros (VBE) para ter essa situação em conta.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Quão satisfeito está com a qualidade da tradução?

O que afetou a sua experiência?

Comentários adicionais? (Opcional)

Obrigado pelos seus comentários!

×