Como corrigir uma #REF! #BUSY!

Como corrigir uma #REF! #BUSY!

O erro #REF! é apresentado quando uma fórmula faz referência a uma célula que não é válida. Isto acontece com mais frequência quando as células que foram referenciadas por fórmulas são eliminadas ou algo é colado nas mesmas.

Exemplo: erro #REF! causado pela eliminação de uma coluna

O seguinte exemplo utiliza a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula a utilizar referências explícitas a células como =SOMA(B2;C2;D2) pode causar um erro #REF! se uma coluna for eliminada.

Se apagar as colunas B, C ou D, causaria uma #REF! #CAMPO!. Neste caso, eliminaremos a coluna C (Vendas de 2007), e a fórmula agora lê =SUM(B2,#REF!,C2). Quando utiliza referências celulares explícitas como esta (onde se refere cada célula individualmente, separada por uma vírgula) e apaga uma linha ou coluna referenciada, o Excel não consegue resolvê-la, por isso devolve o #REF! #CAMPO!. Esta é a principal razão pela qual não é recomendada a utilização de referências celulares explícitas em funções.

Exemplo do erro #REF! causado pela eliminação de uma coluna.

Solução

  • Se tiver eliminado acidentalmente linhas ou colunas, pode clicar imediatamente no botão Anular na Barra de Ferramentas de Acesso Rápido (ou premir Ctrl+Z) para restaurá-las.

  • Ajuste a fórmula para que utilize uma referência de intervalo em vez de células individuais, como =SOMA(B2:D2). Agora pode eliminar qualquer coluna no intervalo de soma e o Excel ajusta automaticamente a fórmula. Também pode utilizar =SOMA(B2:B5) para uma soma de linhas.

Exemplo: PROCV com referências de intervalo incorretas

No seguinte exemplo, =PROCV(A8;A2:D5;5;FALSO) devolve um erro #REF! pois está a procurar um valor para devolver da coluna 5, mas o intervalo de referência é A:D, que engloba apenas 4 colunas.

Exemplo de uma fórmula VLOOKUP com um alcance incorreto.  A fórmula é =VLOOKU (A8,A2:D5,5,FALSE).  Não há uma quinta coluna na gama VLOOKUP, por isso 5 causa uma #REF! #CAMPO!.

Solução

Aumente o intervalo ou reduza o valor de pesquisa da coluna para corresponder ao intervalo de referência. =PROCV(A8;A2:E5;5;FALSO) seria um intervalo de referência válido, tal como =PROCV(A8;A2:D5;4;FALSO).

Exemplo: ÍNDICE com uma referência de linha ou coluna incorreta

Neste exemplo, a fórmula =ÍNDICE(B2:E5;5;5) devolve um erro #REF! porque o intervalo de ÍNDICE engloba 4 linhas e 4 colunas, mas a fórmula pede para devolver os conteúdos da quinta linha e da quinta coluna.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo engloba apenas 4 linhas e 4 colunas.

Solução

Ajuste as referências de linha ou coluna para incluí-las no intervalo de pesquisa de ÍNDICE. =ÍNDICE(B2:E5;4;4) devolve um resultado válido.

Exemplo: fazer referência a um livro fechado com a função INDIRETO

No exemplo seguinte, uma função INDIRECT está a tentar fazer referência a um livro que está fechado, causando uma #REF! #CAMPO!.

Exemplo de um erro #REF! causado pela função INDIRETO a fazer referência a um livro fechado.

Solução

Abra o livro de referência. Encontrará o mesmo erro se referenciar um livro fechado com uma função dinâmica de matriz.

Problemas OLE

Se tiver usado uma ligação de linking e incorporação de objetos (OLE) que está a devolver uma #REF! erro, em seguida, iniciar o programa que o link está chamando.

Nota: OLE é uma tecnologia que pode utilizar para partilhar informações entre programas.

Problemas de DDE

Se utilizou um tópico dynamic data exchange (DDE) que está a devolver uma #REF! erro, verifique primeiro para se certificar de que está a referir o tópico correto. Se ainda está a receber uma #REF! erro, verifique as definições do Trust Center para obter conteúdo externo, tal como descrito no Bloco ou desbloqueie o conteúdo externo nos documentos do Office.

Nota: O Dynamic Data Exchange (DDE)é um protocolo estabelecido para a troca de dados entre programas baseados no Microsoft Windows.

Problemas Macro

Se um macro introduzir uma função na folha de cálculo que se refere a uma célula acima da função, e a célula que contém a função estiver na linha 1, a função voltará #REF! porque não há células acima da linha 1. Verifique a função para ver se um argumento se refere a uma célula ou alcance de células que não são válidas. Isto pode exigir a edição do macro no Editor De Base Visual (VBE) para ter em conta esta situação.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte Também

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×