Iniciar sessão com uma conta Microsoft
Inicie sessão ou crie uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Escolha a conta com a qual pretende iniciar sessão.
Criar, carregar ou editar uma consulta no Excel (Power Query)

O Power Query oferece várias formas de criar e carregar consultas Power para o seu livro. Também pode definir predefinições de carregamento de consultas na janela Opções de Consulta.   

Sugestão      Para saber se os dados numa ficha estão formatados pelo Power Query, selecione uma célula de dados e se o separador do separador contexto Consulta é apresentado, os dados foram carregados a partir do Power Query.  

Selecionar uma célula numa consulta para revelar o separador Consulta

Saiba em que ambiente se desativou O Power Query está bem integrado na interface de utilizador do Excel, especialmente quando importa dados, trabalha com ligações e edita Tabelas Dinâmicas, Excel e intervalos com nome. Para evitar confusões, é importante saber em que ambiente se encontra( por Excel ou Power Query) a qualquer altura.

A forma Excel de trabalho, o ribbon e a grelha

O fita e a pré-visualização de dados do Editor do Power Query 

Uma seta Excel de trabalho Uma vista típica do Editor do Power Query

Por exemplo, manipular dados numa Excel de dados é bastante diferente do Power Query. Além disso, os dados ligados que vê numa Excel de base de dados podem ou não ter o Power Query a trabalhar nos bastidores para moldar os dados. Isto só ocorre quando carrega os dados para uma ficha ou Modelo de Dados a partir do Power Query.

Rename worksheet tabs    É uma boa ideia voltar a dar um nome aos separadores da mesma de uma forma significativa, especialmente se tiver muitos. É particularmente importante clarificar a diferença entre uma ficha de dados e uma ficha carregada a partir do Editor do Power Query. Mesmo que tenha apenas duas folhas, uma com uma tabela do Excel, denominada Folha1e outra seja uma consulta criada ao importar essa tabela Excel, denominada Tabela1,é fácil confundir. Recomendamos que altere os nomes predefinido dos separadores da mesma para nomes que façam mais sentido para si. Por exemplo, renove a Folha1 para Tabela de Dados e Tabela1 para Tabela de Consulta. Agora já está claro qual o separador que tem os dados e qual o separador que tem a consulta.

Pode criar uma consulta a partir de dados importados ou criar uma consulta em branco.

Criar uma consulta a partir de dados importados

Esta é a forma mais comum de criar uma consulta.

  1. Importar alguns dados. Para obter mais informações, consulte Importar dados a partir de origens de dados externas.

  2. Selecione uma célula nos dados e, em seguida, selecione Consulta > Editar.

Criar uma consulta em branco

Pode querer começar do zero. Existem dois modos de o fazer.

  • Selecione Data> Get Data > From Other Sources > Blank Query.

  • Selecione Data> Get Data > Launch Power Query Editor.

Nesta fase, pode adicionar manualmente passos e fórmulas se conhecer bem a linguagem de fórmulas do Power Query M.

Em seguida, pode selecionar Home e, em seguida, selecionar um comando no grupo Nova Consulta. Efetue um dos seguintes procedimentos.

  • Selecione Nova Origem para adicionar uma origem de dados. Este comando é como o comando Data> Obter Dados no Excel dados.

  • Selecione Origens Recentes para selecionar a partir de uma origem de dados com que tem trabalhado. Este comando é como o comando Dados>Origens Recentes no Excel de Dados.

  • Selecione Introduzir Dados para introduzir dados manualmente. Pode escolher este comando para experimentar o Editor do Power Query independentemente de uma origem de dados externa.

Partindo do princípio de que a sua consulta é válida e não tem erros, pode carregá-la novamente para uma ficha ou Modelo de Dados.

Carregar uma consulta a partir do Editor do Power Query

No Editor do Power Query, eis um dos seguintes procedimentos:

  • Para carregar para umaheta de trabalho, selecione Home> Close & Load > Close & Load (Fechar a Carga).

  • Para carregar para um Modelo de Dados, selecione Base> Fechar & Carregar > Fechar & Carregar Para.

    Na caixa de diálogo Importar Dados, selecione Adicionar estes dados ao Modelo deDados.

Sugestão   Por vezes, o comando Carregar Para fica desativado ou desativado. Isto pode ocorrer da primeira vez que criar uma consulta num livro. Se tal acontecer &,selecione Fechar e Carregar , na nova livro, selecione Dados > Consultas & Ligações >, clique com o botão direito do rato na consulta e, em seguida, selecione Carregar Para. Em alternativa, no botão editor do Power Query, selecione Consulta para > Carregar Para.

Carregar uma consulta a partir do painel Consultas e Ligações 

No Excel, poderá pretender carregar uma consulta para outra ficha ou Modelo de Dados.

  1. No Excel, selecione Dados> Consultas & Ligaçõese, em seguida, selecione o separador Consultas.

  2. Na lista de consultas, localize a consulta, clique com o botão direito do rato na consulta e, em seguida, selecione Carregar Para. A caixa de diálogo Importar Dados é exibida.

  3. Decida como pretende importar os dados e, em seguida, selecione OK. Para obter mais informações sobre como utilizar esta caixa de diálogo, selecione o ponto de interrogação (?).

Existem várias formas de editar uma consulta carregada para uma página de trabalho.

Editar uma consulta a partir de dados na Excel de dados

  • Para editar uma consulta, localize uma previamente carregada a partir do Editor do Power Query, selecione uma célula nos dados e, em seguida, selecione Consulta > Editar.

Editar uma consulta a partir do painel Consultas & Ligações

Pode achar que o painel & Ligações é mais conveniente de utilizar quando tem muitas consultas num livro e pretende encontrar rapidamente uma.

  1. No Excel, selecione Dados> Consultas & Ligaçõese, em seguida, selecione o separador Consultas.

  2. Na lista de consultas, localize a consulta, clique com o botão direito do rato na consulta e, em seguida, selecione Editar.

Editar uma consulta a partir da caixa de diálogo Propriedades da Consulta

  • No Excel, selecione Data> Data & Connections > Queries, clique com o botão direito do rato na consulta e selecione Propriedades, selecione o separador Definição na caixa de diálogo Propriedades e, em seguida, selecione Editar Consulta.

Sugestão    Se estiver numa ficha de uma consulta, selecione Propriedades do > Dados ,selecione o separador Definição na caixa de diálogo Propriedades e, em seguida, selecione Editar Consulta

Normalmente, um Modelo de Dados contém várias tabelas dispostas numa relação. Para carregar uma consulta para um Modelo de Dados, utilize o comando Carregar Para para apresentar a caixa de diálogo Importar Dados e, em seguida, selecione a caixa de verificação Adicionar estes dados ao Modo de Dados l. Para obter mais informações sobre Modelos de Dados, consulte Saber que origens de dados são utilizadas num modelo de dados de livro,Criar um Modelo de Dados no Excele Utilizar várias tabelaspara criar uma tabela dinâmica.

  1. Para abrir o Modelo de Dados, selecione Power Pivot > Gerir.

  2. Na parte inferior da janela do Power Pivot, selecione o separador da tabela que pretende.

    Confirme que a tabela correta é apresentada. Um Modelo de Dados pode ter muitas tabelas.

  3. Repare no nome da tabela.

  4. Para fechar a janela do Power Pivot, selecione Ficheiro> Fechar. Pode demorar alguns segundos para recuperar a memória.

  5. Selecione Data> Connections & Properties > separador Queries, clique com o botão direito do rato na consulta e, em seguida, selecione Editar.

  6. Quando terminar de fazer alterações no Editor do Power Query, selecione Ficheiro> Fechar & Carregar.

Resultado

A consulta na mesma e a tabela no Modelo de Dados são atualizadas.

Se reparar que carregar uma consulta para um Modelo de Dados demora muito mais tempo do que a carregar para uma mesma, verifique os passos do Power Query para ver se está a filtrar uma coluna de texto ou uma coluna estruturada lista ao utilizar um operador Contém. Esta ação faz Excel enumerar novamente ao longo de todo o conjunto de dados de cada linha. Além disso, Excel pode utilizar a execução de multithreaded de forma eficaz. Como forma de resolver o problema, experimente utilizar um operador diferente, como É Igual a ou Começa Com.

A Microsoft tem conhecimento deste problema e está a ser investigada.

Pode carregar um Power Query:

  • Para uma vedação. No Editor do Power Query, selecione Home> Close & Load > Close & Load (Fechar a Carga).

  • Para um Modelo de Dados. No Editor do Power Query, selecione Home> Close & Load > Close & LoadTo (Carregar Para). 

    Por predefinição, o Power Query carrega consultas para uma nova livro ao carregar uma única consulta e carrega várias consultas ao mesmo tempo para o Modelo de Dados.  Pode alterar o comportamento predefinido de todos os seus livros ou apenas do livro atual. Ao definir estas opções, o Power Query não altera os resultados da consulta na mesma nem nos dados e anotações do Modelo de Dados.

    Também pode anular dinamicamente as predefinições de uma consulta ao utilizar a caixa de diálogo Importar, que é apresentada após selecionar Fechar e & CarregarPara. 

Definições globais que se aplicam a todos os seus livros

  1. No Editor do Power Query, selecione Opções> Ficheiro e > Opções da Consulta.

  2. Na caixa de diálogo Opções de Consulta, no lado esquerdo, na secção GLOBAL,  selecione Carregamento de Dados.

  3. Na secção Secção Carregamento de Consultas Definições Predefinido, faça o seguinte:

    • Selecione Utilizar definições de carregamento padrão. 

    • Selecione Especificar predefinições decarregamento personalizadas e, em seguida,  selecione ou desloque a opção Carregar para a sua ficha ou Carregar para Modelo de Dados.

Sugestão    Na parte inferior da caixa de diálogo, pode selecionar Restaurar Predefinições para regressar convenientemente às predefinições.

Definições do livro que só se aplicam ao livro atual

  1. Na caixa de diálogo Opções de Consulta, no lado esquerdo, na secção LIVRO ATUAL, selecione Carregamento de Dados.

  2. Siga um ou mais dos seguintes procedimentos:

    • Em Deteção de Tipo, selecione ou desloque Detetar tipos de coluna e cabeçalhos para fontes não estruturadas.

      O comportamento predefinido é detetar os dois. Limpe esta opção se preferir moldar os dados por si próprio.

    • Em Relações, selecione ou desmarque Criar relações entre tabelas ao adicionar ao Modelo de Dados pela primeira vez.

      Antes de carregar para o Modelo de Dados, o comportamento predefinido é encontrar relações existentes entre tabelas, como chaves externas numa base de dados relacional e importá-las com os dados. Limpe esta opção se preferir fazê-lo sozinho.

    • Em Relações , selecioneou desleque Atualizar relações ao atualizar consultas carregadas para o Modelo de Dados.

      O comportamento predefinido é não atualizar as relações. Ao atualizar consultas que já foram carregadas para o Modelo de Dados, o Power Query encontra relações existentes entre tabelas, como chaves externas numa base de dados relacional, e atualiza-as. Esta ação poderá remover relações criadas manualmente após os dados ter sido importados ou introduzir novas relações. No entanto, se quiser fazê-lo, selecione a opção.

    • Em Dados de Fundo, selecione ou deslecione Permitir transferência em segundo plano das pré-visualizações de dados.

      O comportamento predefinido é transferir pré-visualizações de dados em segundo plano. Limpe esta opção se quiser ver todos os dados imediatamente.

Consulte Também

Ajuda do Power Query para Excel

Gerir consultas no Excel

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft Office insiders

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×