Criar um diagrama de classe UML

Pode criar um diagrama de classe UML para mostrar uma visão estática das classes de um sistema, dos seus atributos e métodos, e das relações entre objetos. Dá uma visão geral de uma aplicação.

(As edições Profissionais de Visio incluem apoio para o diagrama e stencil da Classe UML, mas as edições Standard não.)

Uma amostra de um diagrama de classe UML mostrando os sistemas de contas de um banco para clientes pessoais.

Quando inicia um novo diagrama de classe, aparece o stencil classe UML, juntamente com formas que se conformam com a norma UML 2.5.

  1. Inicie o Visio. Ou se já tiver um ficheiro aberto, clique em 'Arquivo > Novo'.

  2. Na caixa de Busca, tipo UML.

  3. Selecione o diagrama da classe UML.

  4. Na caixa de diálogo, selecione o modelo em branco ou um dos três diagramas de arranque. (Uma descrição de cada um é mostrada à direita quando a seleciona.) Em seguida, selecione Unidades Métricas ou Unidades AMERICANAs.

  5. Selecione Criar.

  6. O diagrama abre. Devia ver a janela Shapes ao lado do diagrama. Se não o vir, vá ao Ver > Task Panes e certifique-se de que os Shapes estão selecionados. Se ainda não o vir, clique no botão de janela Expandir as Formas à esquerda.

  7. No separador Ver, certifique-se de que a caixa de verificação ao lado dos Pontos de Ligação está selecionada. Esta opção faz com que os pontos de ligação apareçam quando começa a ligar formas.

  8. Agora, arraste as formas que pretende incluir no seu diagrama da janela Shapes para a página. Para mudar o nome das etiquetas de texto, clique duas vezes nas etiquetas.

  9. Para adicionar mais membros à forma de classe, enumeração ou interface, arraste a forma do membro do painel de forma para a forma respetiva. Também pode adicionar um novo membro clicando à direita num membro existente e escolhendo a opção de inserir um membro.

    Adicione um novo membro clicando à direita num membro existente e escolhendo a opção de inserir um membro.

  10.  Ligue duas formas com conectores UML para representar as relações entre as formas. Para alterar os tipos de relacionamento, clique com o botão direito no conector. Escolha a relação desejada no menu set Connector Type.

    Clique com o botão direito num conector e selecione o tipo de conector para ver as opções para os tipos de conector.

  11.  Redimensione uma forma de classe, enumeração ou interface clicando no cabeçalho de forma para selecioná-lo e, em seguida, movendo o ponto de controlo amarelo (na extremidade direita da forma) para diminuir ou aumentar a largura da forma.

  12.  Adicione campos de parâmetros e estereótipos às suas formas de classe selecionando a forma, clicando à direita e escolhendo a opção correspondente a partir do menu pop-up.

    Adicione campos de parâmetros e estereótipos às suas formas de classe clicando com uma forma.

Primeiro, cria-se um diagrama e adiciona-se um stencil de classe UML que tem formas que se conformam com a norma UML 2.5.

  1. Abra visio para a web.

  2. Na Galeria, desça até à fila da Classe UML, a meio da página.

    O primeiro item da linha representa um modelo em branco mais o stencil companheiro. Os outros itens na linha são diagramas de amostra que têm algumas formas já desenhadas para ajudá-lo a começar rapidamente.

  3. Clique em qualquer item para ver uma pré-visualização maior.

  4. Quando encontrar o diagrama que pretende utilizar, clique no botão Criar.

    O novo diagrama, com o stencil relacionado, abre no seu navegador. Está pronto para começar a desenhar o seu diagrama.

  5. Agora, arraste as formas que pretende incluir no seu diagrama da janela Shapes para a página. Para mudar o nome das etiquetas de texto, clique duas vezes nas etiquetas.

  6. Para adicionar mais membros à forma de classe, enumeração ou interface, arraste a forma do membro do painel de forma para a forma respetiva. Também pode adicionar um novo membro clicando à direita num membro existente e escolhendo a opção de inserir um membro.

    Adicione um novo membro clicando à direita num membro existente e escolhendo a opção de inserir um membro.

  7.  Ligue duas formas com conectores UML para representar as relações entre as formas. Para alterar os tipos de relacionamento, clique com o botão direito no conector. Escolha a relação desejada no menu set Connector Type.

    Clique com o botão direito num conector e selecione o tipo de conector para ver as opções para os tipos de conector.

  8.  Redimensione uma forma de classe, enumeração ou interface clicando no cabeçalho de forma para selecioná-lo e, em seguida, movendo o ponto de controlo amarelo (na extremidade direita da forma) para diminuir ou aumentar a largura da forma.

  9.  Adicione campos de parâmetros e estereótipos às suas formas de classe selecionando a forma, clicando à direita e escolhendo a opção correspondente a partir do menu pop-up.

    Adicione campos de parâmetros e estereótipos às suas formas de classe clicando com uma forma.

Em primeiro lugar, selecione o diagrama da classe UML, que vem com um stencil de classe contendo formas que estão em conformidade com a especificação UML 2.0.

  1. Inicie o Visio. Ou se já tiver um ficheiro aberto, clique em 'Arquivo > Novo'.

  2. Na caixa de Busca, tipo UML.

  3. Selecione o diagrama da classe UML.

  4. Na caixa de diálogo, selecione Unidades Métricas ou Unidades AMERICANAs.

  5. Selecione Criar.

  6. O diagrama abre. Deve ver o stencil da classe UML na janela Formas ao lado do diagrama. Se não o vir, vá ao Ver > Task Panes e certifique-se de que os Shapes estão selecionados. Se ainda não o vir, selecione o chevron na margem esquerda da janela Expanda o botão da janela Shapes.

  7. No separador Ver, certifique-se de que a caixa de verificação ao lado dos Pontos de Ligação está selecionada. Esta opção faz com que os pontos de ligação apareçam quando começa a ligar formas.

  8. Agora, arraste as formas que pretende incluir no seu diagrama da janela Shapes para a página. Para mudar o nome das etiquetas de texto, clique duas vezes nas etiquetas.

Em Visio 2010, a forma de criar um diagrama de classe UML é utilizando um diagrama de estrutura estática. Consulte Criar um diagrama de estrutura estática UML para mais detalhes.

Dicas para criar um diagrama de classe

  • Identifique cada elemento e as suas relações.

  • Identifique claramente o responsável por cada classe.

  • Não inclua propriedades desnecessárias no diagrama que podem torná-lo muito complicado.

Notação de classe

Símbolo

Significado

-

O atributo ou operação é privado.

+

O atributo ou operação é público.

Consulte Também

Diagramas UML no Visio

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×