Os operadores especificam o tipo de cálculo que pretende efetuar em elementos numa fórmula, como a adição, subtração, multiplicação ou divisão. Neste artigo, irá aprender a ordem predefinida pela qual os operadores atuam sobre os elementos de um cálculo. Também irá aprender a alterar esta ordem com parênteses.

Tipos de operadores

Existem quatro tipos de operadores de cálculo diferentes: aritméticos, de comparação, de concatenação de texto e de referência.

Para executar operações matemáticas básicas como adição, subtração ou multiplicação (ou para combinar números) e produzir resultados numéricos, utilize os operadores aritméticos nesta tabela.

Operador aritmético

Significado

Exemplo

+ (sinal de adição)

Adição

=3+3

- (sinal de subtração)

Subtração
Negação

=3–1
=–1

* (asterisco)

Multiplicação

=3*3

/ (barra)

Divisão

=3/3

% (símbolo de percentagem)

Percentagem

=20%

^ (acento circunflexo)

Potência

=

Com os operadores na tabela abaixo, pode comparar dois valores. Quando dois valores são comparados com estes operadores, o resultado é um valor lógico VERDADEIRO ou FALSO.

Operador de comparação

Significado

Exemplo

= (sinal de igual)

Igual a

=A1=B1

> (sinal de maior)

Maior que

=A1>B1

< (sinal de menor)

Menor que

=A1<B1

>= (sinal de maior ou igual)

Maior ou igual a

=A1>=B1

<= (sinal de menor ou igual)

Menor ou igual a

=A1<=B1

<> (sinal de diferente)

Diferente de

=A1<>B1

Utilize o E"E" (&) para juntar ou concatenar uma ou mais cadeias de texto para produzir uma única parte do texto.

Operador de texto

Significado

Exemplo

& ("E" comercial)

Liga ou concatena dois valores para produzir um valor de texto contínuo.

="Norte"&"vento"

Combine intervalos de células para cálculos com estes operadores.

Operador de referência

Significado

Exemplo

: (dois pontos)

Operador de intervalo, que produz uma referência a todas as células entre duas referências, incluindo as duas referências.

=SOMA(B5:B15)

, (vírgula)

Operador de união, que combina várias referências numa só referência.

=SOMA(B5:B15;D5:D15)

(espaço)

Operador de interseção, que produz uma referência a células comuns às duas referências.

=SOMA(B7:D7 C6:C8)

N.º (libra)

O símbolo # é utilizado em vários contextos:

  • Utilizado como parte de um nome de erro.

  • Utilizado para indicar espaço insuficiente para composições. Na maioria dos casos, pode alargar a coluna até os conteúdos apresentarem corretamente.

  • Operador de intervalo transbordo, utilizado para referenciar um intervalo inteiro numa fórmula de matriz dinâmica.

  • Obtém o erro #VALOR!

  • #####

  • =SOMA(A2#)

@ (a)

Operador de referência, que é utilizado para indicar interseção implícita numa fórmula. 

=@A1:A10

=SOMA(Tabela1[@[Janeiro]:[Dezembro]])

Ordem de execução de operações de fórmulas no Excel

Em alguns casos, a ordem pela qual o cálculo é efetuado pode afetar o valor devolto da fórmula, pelo que é importante compreender a ordem e como pode alterar a ordem para obter os resultados que espera ver.

As fórmulas calculam valores numa ordem específica. Uma fórmula no Excel começa sempre com um sinal de igual (=). O sinal de igual Excel que os carateres seguintes constituem uma fórmula. Após este sinal de igual, pode haver uma série de elementos a calcular (os operandos), que são separados por operadores de cálculo. O Excel calcula a fórmula da esquerda para a direita, de acordo com uma ordem específica para cada operador da fórmula.

Se combinar vários operadores numa única fórmula, o Excel executará as operações pela ordem apresentada na tabela que se segue. Se uma fórmula contiver operadores com a mesma precedência , por exemplo, se uma fórmula possuir um operador de multiplicação e outro de divisão , o Excel avaliará os operadores da esquerda para a direita.

Operador

Descrição

: (dois pontos)

(espaço simples)

, (vírgula)

Operadores de referência

Negação (como –1)

%

Percentagem

^

Potência

* e /

Multiplicação e divisão

+ e -

Adição e subtração

&

Liga duas cadeias de texto (concatenação)

=
< >
<=
>=
<>

Comparação

Para alterar a ordem de avaliação, escreva entre parênteses a parte da fórmula que pretende calcular primeiro. Por exemplo, a fórmula seguinte resulta no valor de 11, porque o Excel calcula a multiplicação antes da adição. A fórmula multiplica primeiro 2 por 3 e, em seguida, adiciona 5 ao resultado.

=5+2*3

Por outro lado, se utilizar parênteses para alterar a sintaxe, o Excel soma 5 e 2 e, em seguida, multiplica o resultado por 3 para produzir 21.

=(5+2)*3

No exemplo abaixo, os parênteses que insere a primeira parte da fórmula forçam o Excel a calcular B4+25 primeiro e, em seguida, a dividir o resultado pela soma dos valores nas células D5, E5 e F5.

=(B4+25)/SOMA(D5:F5)

Veja este vídeo sobre a Ordem dos operadores Excel mais informações.

Como Excel converte valores em fórmulas

Ao introduzir uma fórmula, o Excel espera tipos específicos de valores para cada operador. Se introduzir um tipo de valor diferente do esperado, Excel converter o valor.

A fórmula

Produtos

Explicação

= "1"+"2"

3

Quando utiliza um sinal de a mais (+), Excel espera números na fórmula. Embora as aspas significam que "1" e "2" são valores de texto, Excel converte automaticamente os valores de texto em números.

= 1+"4,00$"

5

Quando uma fórmula espera um número, Excel converte texto num formato que normalmente seria aceite para um número.

= "1/6/2001"-"1/5/2001"

31

Excel interpreta o texto como uma data no formato mm/dd/a, converte as datas em números de série e, em seguida, calcula a diferença entre as mesmas.

=RTQ ("8+1")

Obtém o erro #VALOR!

Excel converter o texto num número porque o texto "8+1" não pode ser convertido num número. Pode utilizar "9" ou "8"+"1" em vez de "8+1" para converter o texto num número e devolver o resultado de 3.

= "A"&VERDADEIRO

ATRUE

Quando o texto é esperado, Excel converte números e valores lógicos como VERDADEIRO e FALSO em texto.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Quão satisfeito está com a qualidade da tradução?
O que afetou a sua experiência?

Obrigado pelos seus comentários!

×