SOMA.SE (função SOMA.SE)

SOMA.SE (função SOMA.SE)

A função SOMA.SE é utilizada para somar os valores num intervalo que correspondem aos critérios que o utilizador especifica. Por exemplo, suponhamos que, numa coluna que contém números, quer somar apenas os valores superiores a 5. Pode utilizar a seguinte fórmula: =SOMA.SE(B2:B25;">5")

Consiga um grande impacto com os Anúncios

Este vídeo faz parte de um curso de formação chamado Adicionar números no Excel.

Sugestões: 

  • Se quiser, pode aplicar os critérios a um intervalo e somar os valores correspondentes noutro intervalo. Por exemplo, a fórmula =SOMA.SE(B2:B5; "João"; C2:C5) soma apenas os valores no intervalo C2:C5, em que as células correspondentes no intervalo B2:B5 são iguais a "João".

  • Para somar células com base em múltiplos critérios, consulte o artigo Função SOMA.SE.S.

Importante: A função SUMIF devolve resultados incorretos quando o utiliza para combinar cordas superiores a 255 caracteres ou com a cadeia #VALUE!

Sintaxe

SOMA.SE(intervalo; critérios; [intervalo_soma])

A sintaxe da função SOMA.SE tem os seguintes argumentos:

  • intervalo   Obrigatório. O leque de células que pretende ser avaliado por critérios. As células de cada gama devem ser números ou nomes, matrizes ou referências que contenham números. Os valores de texto e em branco são ignorados. A gama selecionada pode conter datas no formato Excel padrão (exemplos abaixo).

  • critérios   Obrigatório. Os critérios sob a forma de um número, expressão, referência celular, texto ou uma função que define quais as células serão adicionadas. Os caracteres wildcard podem ser incluídos - um ponto de interrogação (?) para combinar com qualquer personagem, um asterisco (*) para combinar com qualquer sequência de caracteres. Se pretender localizar um ponto de interrogação ou asterisco, escreva um til (~) antes do caráter.

    Por exemplo, os critérios podem ser expressos como 32, ">32", B5, "3?", "maçã*", "*~?", ou HOJE().

    Importante: Qualquer critério de texto ou que inclua símbolos lógicos ou matemáticos tem de ser escrito entre aspas ("). Se os critérios forem numéricos, não é necessário utilizar aspas.

  • sum_range   Opcional. As células reais a adicionar, se quiser adicionar células diferentes das especificadas no argumento de alcance. Se o argumento sum_range for omitido, o Excel adiciona as células especificadas no argumento de gama (as mesmas células às quais os critérios são aplicados).

    Sum_range devem ter o mesmo tamanho e forma que o alcance. Se não for, o desempenho pode sofrer, e a fórmula irá resumir uma gama de células que começa com a primeira célula em sum_range mas tem as mesmas dimensões que o alcance. Por exemplo:

    intervalo

    sum_range

    Células resumidas reais

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1:K5

    B1:B5

Exemplos

Exemplo 1

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter. Se quiser, pode ajustar as larguras das colunas para ver todos os dados.

Valor de Propriedade

Comissão

Dados

€ 100.000

€ 7.000

€ 250.000

€ 200.000

€ 14.000

€ 300.000

21.000 €

€ 400.000

€ 28.000

Fórmula

Descrição

Resultado

=SOMA.SE(A2:A5,">160000",B2:B5)

Soma das comissões dos valores de propriedade superiores a € 160.000.

€ 63.000

=SOMA.SE(A2:A5,">160000")

Soma dos valores de propriedade superiores a € 160.000

€ 900.000

=SOMA.SE(A2:A5,300000,B2:B5)

Soma das comissões de valores de propriedade iguais a € 300.000.

€ 21.000

=SOMA.SE(A2:A5,">" & C2,B2:B5)

Soma das comissões dos valores de propriedade maiores que o valor em C2.

€ 49.000

Exemplo 2

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter. Caso seja necessário, pode ajustar as larguras das colunas para ver todos os dados.

Categoria

Alimentos

Vendas

Vegetais

Tomates

€ 2.300

Vegetais

Aipo

€ 5.500

Fruta

Laranjas

€ 800

Manteiga

€ 400

Vegetais

Cenouras

€ 4.200

Fruta

Maçãs

€ 1.200

Fórmula

Descrição

Resultado

=SOMA.SE(A2:A7,"Fruta",C2:C7)

Soma das vendas de todos os alimentos na categoria "Fruta".

€ 2.000

=SOMA.SE(A2:A7,"Vegetais",C2:C7)

Soma das vendas de todos os alimentos na categoria "Vegetais".

€ 12.000

=SOMA.SE(B2:B7,"*as",C2:C7)

Soma das vendas de todos os alimentos terminados em "as" (Laranjas, Cenouras).

€ 4.300

=SOMA.SE(A2:A7,"",C2:C7)

Soma das vendas de todos os alimentos sem uma categoria especificada.

€ 400

Início da Página

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte também

A função SOMA.SE.S soma todos os argumentos que correspondem a múltiplos critérios

A função SOMARQUAD soma múltiplos valores após executar uma operação matemática em cada um deles

A função CONTAR.SE conta apenas os valores que correspondem a um único critério

A função CONTAR.SE.S conta apenas os valores que correspondem a múltiplos critérios

Função SE.S (Office 365, Excel 2016 e posterior)

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções de Matemática e Trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por Categoria)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×