Quando precisar de encontrar dados que cumprem mais do que uma condição, como unidades vendidas entre abril e janeiro, ou unidades vendidas pela Emíbrada, pode utilizar as funções E e OU em conjunto. Eis um exemplo:

Utilizar as funções E e OU na mesma fórmula

Esta fórmula aninha a função E dentro da função OU para procurar unidades vendidas entre 1 de abril de 2011 e 1 de janeiro de 2012 ou quaisquer unidades vendidas pela Emínha. Pode ver que a devolução é devolvê-la True for units sold by Nancy, and also for units sold by Tim and Ed during the dates specified in the formula.

Eis a fórmula num formulário que pode copiar e colar. Se quiser reproduzi-la num livro de exemplo, consulte a parte final deste artigo.

=OU(E(C2>DATA(2011;4;30);C2<DATA(2012;1;1));B2="Emajá-la")

Vamos aprofundar um pouco mais a fórmula. A função OU requer um conjunto de argumentos (conjuntos de dados) que pode testar para ver se são verdadeiros ou falsos. Nesta fórmula, o primeiro argumento é a função E e a função DATA aninhada dentro da mesma, o segundo é "Emídia". Pode ler a fórmula da seguinte forma: Teste para ver se uma venda foi feita depois de 30 de abril de 2011 e antes de 1 de janeiro de 2012 ou se foi feita pela Emília.

A função E também devolve Verdadeiro ou Falso. Na maioria das vezes, utiliza E para expandir as capacidades de outra função, como OU e SE. Neste exemplo, a função OU não encontraria as datas corretas sem a função E.

Utilizar as condições E e OU com a se

Também pode utilizar as funções Ee OU com a função SE.

A função E e OU aninhada numa função SE

Neste exemplo, as pessoas não ganham bónus até venderem, pelo menos, 125.000 $ de bens, a menos que trabalhem na região sul onde o mercado é mais pequeno. Nesse caso, são qualificados para um bónus após $ 100.000 nas vendas.

=SE(OU(C4>=125000;E(B4="Sul";C4>=100000))=VERDADEIRO;C4*0,12;"Sem bónus")

Vamos aprofundar um pouco mais. A função SE requer que três dados (argumentos) sejam executados corretamente. O primeiro é um teste lógico, o segundo é o valor que pretende ver se o teste devolve Verdadeiro e o terceiro é o valor que pretende ver se o teste devolve Falso. Neste exemplo, a função OU e tudo o que está aninhado fornece o teste lógico. Pode lê-lo como: Procure valores maiores ou iguais a 125 000, exceto se o valor na coluna C for "Sul", então procure um valor maior do que 100 000 e sempre que ambas as condições são verdadeiras, multiplida o valor por 0,12, o montante da comissão. Caso contrário, apresenta as palavras "Sem bónus".

Início da Página

Dados de exemplo

Se quiser trabalhar com os exemplos neste artigo, copie a seguinte tabela para a célula A1 na sua própria livro. Certifique-se de que seleciona toda a tabela, incluindo a linha de título.


Vendedor

Região

Vendas

Fórmula/resultado

Teixeira

Este

87925

=SE(OU(C2>=125000;E(B2="Sul";C2>=100000))=VERDADEIRO;C2*0,12;"Sem bónus")

Macedo

Norte

100000

=SE(OU(C3>=125000;E(B3="Sul";C3>=100000))=VERDADEIRO;C3*0,12;"Sem bónus")

Ferreira

Oeste

145000

=SE(OU(C4>=125000;E(B4="Sul";C4>=100000))=VERDADEIRO;C4*0,12;"Sem bónus")

Barbosa

Sul

200750

=SE(OU(C5>=125000;E(B5="Sul";C5>=100000))=VERDADEIRO;C5*0,12;"Sem bónus")

Cardoso

Sul

178650

=SE(OU(C6>=125000;E(B6="Sul";C6>=100000))=VERDADEIRO;C6*0,12;"Sem bónus")

Thomas

Norte

99555

=SE(OU(C7>=125000;E(B7="Sul";C7>=100000))=VERDADEIRO;C7*0,12;"Sem bónus")

Keever

Este

147000

=SE(OU(C8>=125000;E(B8="Sul";C8>=100000))=VERDADEIRO;C8*0,12;"Sem bónus")

Cassazza

Norte

213450

=SE(OU(C9>=125000;E(B9="Sul";C9>=100000))=VERDADEIRO;C9*0,12;"Sem bónus")

Brownlee

Sul

122680

=SE(OU(C10>=125000;E(B10="Sul";C10>=100000))=VERDADEIRO;C10*0,12;"Sem bónus")

Smithberg

Oeste

92500

=SE(OU(C11>=125000;E(B11="Sul";C11>=100000))=VERDADEIRO;C11*0,12;"Sem bónus")

Benson

Este

88350

=SE(OU(C12>=125000;E(B12="Sul";C12>=100000))=VERDADEIRO;C12*0,12;"Sem bónus")

Leitura

Oeste

102500

=SE(OU(C13>=125000;E(B13="Sul";C13>=100000))=VERDADEIRO;C13*0,12;"Sem bónus")

Início da Página

Precisa de mais ajuda?

Aumente os seus conhecimentos

Explore as formações >

Seja o primeiro a obter novas funcionalidades

Aderir ao Microsoft insiders >

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×