Como minimizar metadados no Word 2003

Para obter uma versão do Microsoft Word 2002 deste artigo, consulte 290945.

NESTA TAREFA

Sumário

Este artigo descreve vários métodos que pode utilizar para minimizar metadados em documentos do Word.

Quando criar, abrir ou guardar um documento no Microsoft Office Word 2003, o documento pode conter conteúdo que não pretende partilhar com outros utilizadores ao distribuir o documento electronicamente. Esta informação é conhecida como metadados. Os metadados são utilizados para uma variedade de finalidades para melhorar a edição, visualização, arquivo e a obtenção de documentos do Office.

Alguns metadados são facilmente acessíveis através da interface de utilizador do Word. Outros metadados só são acessíveis através de meios extraordinários, tais como abrindo um documento num editor de ficheiros binários de baixo nível. Seguem-se alguns exemplos de metadados que poderão ser armazenados nos documentos:

  • O nome

  • As suas iniciais

  • O nome da empresa ou organização

  • O nome do computador

  • O nome do servidor de rede ou disco rígido onde guardou o documento

  • Outras informações de propriedades e resumo de ficheiro

  • Partes não visíveis de objectos OLE incorporados

  • Revisões de documentos

  • Versões de documentos

  • Informações do modelo

  • Texto oculto

  • Comentários

Os metadados são criados de várias formas nos documentos do Word. Como resultado, não existe nenhum método único para remover todo o conteúdo dos documentos. As secções seguintes descrevem as áreas onde os metadados podem ser guardados em documentos do Word.

Este artigo descreve vários métodos que pode utilizar para minimizar metadados em documentos do Word.

Microsoft fornece exemplos de programação apenas, a título sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação que está a ser demonstrada e com as ferramentas que são utilizadas para criar e depurar procedimentos. Técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador. Para mais informações sobre como utilizar o código de exemplo neste artigo, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:

290140 como executar o código de exemplo para programas do Office XP a partir de artigos da Base de dados de conhecimento

regressar ao início

Como remover automaticamente as informações pessoais ao guardar

Pode agora automaticamente remover informações pessoais de um documento do Word quando guardar o documento. Para activar esta opção, siga estes passos:

  1. No menu Ferramentas , clique em
    Opções.

  2. No separador segurança , clique para seleccionar o
    Caixa de verificação Remover informações pessoais do ficheiro ao guardar em Opções de privacidadee, em seguida, clique
    OK.

Nota Este é o método preferencial para remover informações pessoais quando guarda um documento do Word.

regressar ao início

Como remover manualmente o nome de utilizador dos documentos

Para ver ou alterar o nome de utilizador, siga estes passos:

  1. No menu Ferramentas , clique em
    Opçõese, em seguida, clique no separador Informações de utilizador.

    São apresentadas as seguintes caixas de edição:

    Nome
    Iniciais
    Endereço de correio

  2. Se não pretender que nenhuma destas informações apareça nos documentos, introduza cadeias não identificadoras ou espaços nas caixas de edição e, em seguida, clique em OK para aceitar as alterações.

Nota Quaisquer novos documentos que criar irão conter esta informação em vez dos valores predefinidos introduzidos quando instalou o Office. No entanto, documentos existentes já podem conter esta informação.

regressar ao início

Como remover manualmente as informações de resumo pessoais

Quando cria ou guarda um documento no Word, informações de resumo poderão ser guardadas no documento. Existem vários métodos que pode utilizar para aceder a estas informações:

  • Abra o documento. No menu ficheiro , clique em
    Propriedades. O Resumo,
    Estatísticas, conteúdo, e
    Personalizar separadores podem conter várias propriedades como o nome, o nome do gestor e o nome da empresa.

  • No Microsoft Windows Explorer, com o botão direito do documento e, em seguida, clique em Propriedades. Os separadores do
    Caixa de diálogo Propriedades poderão conter informações.

  • Pode utilizar um Microsoft Visual Basic for Applications (VBA) macro ou um código de outro programa para ler as propriedades apresentadas no
    Caixa de diálogo de Propriedades .

Para limpar informações de resumo de um documento ou modelo existente, siga estes passos:

  1. Abra o documento ou modelo.

  2. No menu ficheiro , clique em
    Propriedades.

  3. No separador Resumo , clique para desmarcar a
    Autor, Gestor, empresae outras caixas de edição que não pretende distribuir.

  4. No separador personalizado , elimine quaisquer propriedades que contêm informações que não pretende distribuir.

  5. Clique em OK.

    Sobre o
    Menu ficheiro , clique em Guardare, em seguida, clique em
    Fechar.

Depois de concluir estes passos, o documento não conterá propriedades de resumo.

regressar ao início

Como remover manualmente as informações de resumo pessoais quando ligado a uma rede

Se tiver iniciado sessão a uma rede, o nome de utilizador de rede poderá aparecer na caixa de autor no separador Resumo e no campo guardado pela última vez do
Separador Estatísticas quando guarda um documento. Este problema poderá ocorrer mesmo se tiver removido todas as outras informações pessoais do computador.

Para remover informações de resumo de um documento quando estiver ligado a uma rede, siga estes passos:

  1. Se o documento estiver armazenado num servidor de rede, copie-o para o disco rígido local.

  2. Iniciar o computador, mas não inicie sessão na rede. Quando vir a caixa de diálogo de início de sessão de rede, clique em Cancelar ou prima ESC.

    Nota Se não conseguir iniciar o Windows premindo a tecla ESCAPE (por exemplo, se o computador tiver o Microsoft Windows NT), não é possível continuar estes passos.

  3. Abra o documento.

  4. No menu ficheiro , clique em
    Propriedades.

  5. No separador Resumo , clique para desmarcar a
    Autor, Gestor, empresae outras caixas de edição que contenham informações que não pretende distribuir.

  6. No separador personalizado , elimine quaisquer propriedades que contêm informações que não pretende distribuir.

  7. Clique em OK.

    Sobre o
    Menu ficheiro , clique em Guardare, em seguida, clique em
    Fechar.

Quando inicia sessão na rede, Abra o ficheiro . Se o fizer, o nome de utilizador de rede poderá ser escrito no ficheiro. No entanto, pode utilizar o Explorador do Windows para copiar o ficheiro para um servidor de rede ou uma disquete.

regressar ao início

Como remover manualmente os comentários em documentos

O Word oferece a capacidade de adicionar comentários a documentos. Normalmente, os comentários contêm o nome da pessoa que criou, de modo a que possa saber quem os escreveu.

Os comentários aparecem normalmente como uma secção realçada de texto; Pode botão direito do rato no comentário e, em seguida, clique em Eliminar comentário.

Quaisquer novos comentários criados não irão conter o nome de utilizador porque o removeu da caixa de diálogo Opções tal como descrito na secção "Como manualmente remover o utilizador nome do seu documentos" deste artigo.

regressar ao início

Como remover manualmente os cabeçalhos e rodapés de documentos

Os cabeçalhos e rodapés dos documentos poderão conter informações de identificação. Para remover informações de cabeçalhos e rodapés, siga estes passos:

  1. No menu Ver , clique em cabeçalho e rodapé.

  2. O cabeçalho e rodapé aparecem na parte superior e inferior de cada página no documento.

    Altere-os conforme pretender.

  3. Clique em Fechar na barra de ferramentas cabeçalho e rodapé .

regressar ao início

Como remover manualmente as marcas de revisão

Os documentos podem conter marcas de revisão. Com marcas de revisão pode determinar quem efectua alterações específicas a um documento. Quando aceita ou rejeita marcas de revisão, o texto revisto é guardado no documento e as marcas de revisão são removidas.

Para aceitar ou rejeitar revisões, siga estes passos:

  1. No menu Ferramentas , clique em Registo de alterações para activá-lo.

  2. Na barra de ferramentas Revisão , clique em anterior ou seguinte para localizar e seleccionar revisões específicas. Em seguida, clique em Aceitar alteração ou Rejeitar comentário para alterar/eliminar para aceitar ou rejeitar a revisão está seleccionada.

  3. Quando tiver terminado, clique em
    Fechar.

Nota Se alterar as definições de 'Mostrar' na barra de ferramentas Revisão, informações de revisão não são removidas. regressar ao início

Como desactivar a gravação rápida de ficheiros

A funcionalidade de gravação rápida acelera o processo de guardar um documento, guardando apenas as alterações efectuadas a um documento.

Devido à concepção da funcionalidade de gravação rápida, o texto que eliminou de um documento pode permanecer no documento mesmo depois de guardar o documento. Se estiver preocupado com texto eliminado permanecer nos documentos, siga estes passos:

  1. No menu Ferramentas , clique em
    Opções.

  2. Seleccione o separador Guardar .

  3. Clique para desmarcar a caixa de verificação Guardar os ficheiros rapidamente e, em seguida, clique em OK.

Para mais informações sobre a funcionalidade de gravação rápida, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:

291181 perguntas mais frequentes sobre "Allow Fast Saves" no Word 2002

regressar ao início

Como procurar e remover texto formatado como oculto

Em documentos do Word, pode formatar texto como oculto. Uma vez que o texto oculto pode conter informações que não pretende distribuir, poderá pretender mostrá-lo e removê-lo. Para remover todo o texto num documento que está formatado como oculta, siga estes passos:

  1. No menu Ferramentas , clique em
    Opçõese, em seguida, clique no separador Ver.

  2. Clique para seleccionar a caixa de verificação texto oculto e, em seguida, clique em OK.

  3. No menu Editar , clique em
    A Substituir.

  4. Clique em mais para expandir a caixa de diálogo.

  5. Clique em qualquer local na caixa junto a Localizar.

  6. Clique no botão formato e, em seguida, clique em
    Tipo de letra.

    Clique para seleccionar a caixa de verificação ocultoe, em seguida, clique em OK.

  7. Clique em Substituir tudo.

Todo o texto oculto é removido do documento. Para desactivar a apresentação de texto oculto, siga estes passos:

  1. No menu Ferramentas , clique em
    Opçõese, em seguida, clique no separador Ver.

  2. Clique para desmarcar a caixa de verificação texto oculto e, em seguida, clique em OK.

regressar ao início

Como remover hiperligações de documentos

Documentos poderão conter hiperligações para outros documentos ou páginas Web numa intranet ou na Internet. As hiperligações são normalmente apresentados como cadeias de texto sublinhado a azul.

Para eliminar manualmente uma única hiperligação de um documento, faça duplo clique na hiperligação, aponte para a hiperligaçãoe, em seguida, clique em
Remover hiperligação.

Se pretender eliminar todas as hiperligações num documento, pode utilizar uma macro VBA para o fazer. A seguinte macro de VBA de exemplo remove todas as hiperligações num documento.

Nota No seguinte exemplo de macro apenas a ligação é removida. O texto da hiperligação permanece no documento.

Importante Antes de utilizar o seguinte exemplo de macro, reveja a exclusão de responsabilidade neste artigo.

Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Delete
Next
Next

End Sub

Para remover todos os vestígios da hiperligação e o texto da hiperligação do documento, pode utilizar a seguinte macro de exemplo.

Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Range.Delete
Next
Next

End Sub

regressar ao início

Como remover estilos de documentos

Os documentos podem incluir estilos que contenham metadados. Pode remover estes estilos ou mudar os respectivos nomes. Para tal, siga estes passos:

  1. Abra o documento que contém os estilos.

  2. No menu Formatar , clique em
    Estilo.

  3. Seleccione o estilo que pretende eliminar ou mudar o nome.


    Clique em Eliminar para eliminar o estilo ou clique em
    Modificar para mudar o nome.

regressar ao início

Como remover versões de ficheiros antigas de documentos

O Word inclui uma funcionalidade de versão do ficheiro que permite guardar várias versões do mesmo documento no mesmo ficheiro. Poderá pretender eliminar versões mais antigas do documento antes de o partilhar com outros utilizadores.

Para eliminar uma ou mais versões de um documento, siga estes passos:

  1. No menu ficheiro , clique em
    Versões.

  2. Seleccione a versão do documento que pretende eliminar.

    Pode seleccionar mais de uma versão premindo a tecla CTRL enquanto selecciona as versões.

  3. Clique em Eliminar.

  4. Quando tiver terminado de eliminação das versões antigas do documento, clique em Guardar no menu ficheiro.

regressar ao início

Como remover ligações de códigos de campo

Imagens ligadas e outros objectos em documentos do Word poderão conter informações da ligação, tal como o caminho do objecto ou imagem ligada. Pode remover informações de ligação do documento editando os códigos de campo.

Para apresentar códigos de campo, siga estes passos:

  1. No menu Ferramentas , clique em
    Opçõese, em seguida, clique no separador Ver.

  2. Clique para seleccionar a caixa de verificação de códigos de campo e, em seguida, clique em OK.

Depois de códigos de campo estiverem visíveis, pode verificar para ver se algum contém informações de identificação.

Para remover as informações de ligação de uma imagem ligada ou outro objecto, siga estes passos:

  1. Seleccione a imagem ou objecto ligados, ou seleccione o código de campo para a imagem ou objecto, se os códigos de campo estiverem visíveis.

  2. Prima CTRL + SHIFT + F9.

A imagem ou objecto é agora não ligados. Quando uma imagem ou objecto está desligado, não é possível editá-lo.

regressar ao início

Como remover o nome do modelo e a localização

Todos os documentos criados no Word são baseados num modelo. Por predefinição, este é o ficheiro de modelo normal. dot, localizado na pasta Modelos. No entanto, pode criar um documento baseado num modelo diferente noutra localização. O caminho e o nome deste modelo são armazenados nas propriedades do documento.

Para ver o nome do modelo e a localização, clique em Propriedades no menu ficheiro e, em seguida, clique no separador Resumo .

Mesmo se não enviar o modelo com o documento, o documento retém o nome e localização do modelo. Para alterar o nome do modelo e a localização para não identificação valores, siga estes passos:

  1. No menu Ferramentas , clique em modelos e suplementos.

  2. Clique em anexar.

  3. Seleccione um modelo que tenha um nome e localização que não sejam sensíveis nem únicos.

    Por exemplo, uma vez que cada computador que tenha instalado o Word inclui normal. dot, poderá seleccionar normal. dot.

  4. Clique em Abrire, em seguida, clique em
    OK.

Nota O modelo poderá conter macros, entradas de texto automático, estilos personalizados e barras de ferramentas personalizadas. Ao alterar os modelos, poderá tornar alguns destes itens disponíveis para o seu documento.

regressar ao início

Como remover informações da lista de encaminhamento

Se enviar um documento através de correio electrónico utilizando uma lista de distribuição, informações de encaminhamento poderão ser anexadas ao documento. Para remover estas informações do documento, tem de guardar o documento num formato que não retenha as informações da lista de distribuição.

No Word, guarde o documento em formato Rich Text Format (RTF) ou HTML. Feche o documento e, em seguida, reabra o novo ficheiro. Uma vez que as informações de encaminhamento guia de remessa já não estiverem presentes, pode então guardar o documento no formato do Word.

Pode também seguir estes passos:

  1. Desactive a opção Guardar os ficheiros rapidamente utilizando as instruções neste artigo.

  2. No menu ficheiro , aponte para Enviar parae, em seguida, clique em Outro destinatário da distribuição.

  3. Clique em Limpar para remover a lista de distribuição e, em seguida, clique em OK.

  4. No menu ficheiro , clique em
    A Guardar.

O documento é guardado sem quaisquer informações da lista de encaminhamento.

regressar ao início

Como remover o nome de código do Visual Basic

Importante Antes de utilizar o seguinte exemplo de macro, reveja a exclusão de responsabilidade neste artigo.

Quando grava uma macro do VBA no Word, a macro gravada é iniciada com um cabeçalho semelhante ao seguinte:

' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>

Para remover o nome de quaisquer macros gravadas, siga estes passos:

  1. Abra o documento que contém as macros.

  2. No menu Ferramentas , aponte para
    Macroe, em seguida, clique em Editor do Visual Basic. Ou prima ALT + F11.

  3. Na janela do projecto, faça duplo clique sobre o módulo que contém as macros.

  4. Remova o nome a partir do código de macro gravada.

Quando tiver terminado de remover o nome, prima ALT + Q para regressar ao programa e, em seguida, clique em Guardar do
Menu ficheiro .

regressar ao início

Como remover referências do Visual Basic a outros ficheiros

No Editor do Visual Basic, pode criar uma referência a outro ficheiro. Se um utilizador abre um documento que contém referências a outros ficheiros, o utilizador pode ver os nomes dos ficheiros referenciados.

Para remover estas referências, siga estes passos:

  1. Abra o documento que contém referências.

  2. No menu Ferramentas , aponte para
    Macroe, em seguida, clique em Editor do Visual Basic ou prima ALT + F11.

  3. No menu Ferramentas , clique em
    As referências.

  4. Clique para desmarcar a caixa de verificação junto do ficheiro ou ficheiros referenciados.

    Quando tiver terminado, clique em OK.

  5. Prima ALT + Q.

  6. No menu ficheiro , clique em
    A Guardar.

Nota Se remover referências a outros ficheiros, isto pode afectar negativamente a capacidade de macros no documento para funcionar correctamente.

regressar ao início

Como remover informações de disco rígido ou rede

Quando guarda um documento para o disco rígido local ou para um servidor de rede, as informações que identificam o disco rígido local ou servidor de rede poderão ser escritas no documento.

Para remover estas informações do documento, siga estes passos:

  1. Abra o documento.

  2. No menu ficheiro , clique em Guardar como.

    Guarde o documento para a unidade de disquetes (normalmente a unidade A).

  3. No menu ficheiro , clique em
    Fechar.

  4. Remova a disquete da unidade de disquetes.

Pode agora utilizar o Explorador do Windows para copiar o documento a partir da disquete para qualquer disco rígido ou servidor de rede.

Nota Devido à limitação de espaço de uma disquete (normalmente 1,44 megabytes [MB]), este método não pode ser utilizado se o tamanho do ficheiro de documento exceder o espaço livre na disquete.

regressar ao início

Objectos incorporados em documentos poderão conter metadados

Se incorporar um objecto num documento, o objecto mantém as respectivas propriedades, independentemente do que faça ao documento. Por exemplo, se incorporar um livro do Microsoft Excel numa palavra documento, o documento e o livro cada tem as suas próprias propriedades.

Para remover metadados de um objecto incorporado, activar o objecto, remova quaisquer metadados conforme descrito nas secções anteriores, reactive o documento contentor e, em seguida, guarde o documento contentor.

Nota Quando activa um objecto incorporado num documento, apenas parte do objecto incorporado é apresentada no documento; o objecto pode conter informações adicionais que não aparecem. Se pretender que um documento contenha apenas uma representação do objecto incorporado e não o conteúdo real, utilize a
Cortar o comando no menu Editar para eliminar o objecto e, em seguida, utilize o comando Colar especial para colar o objecto no documento utilizando um formato de metaficheiro. Depois de efectuar este procedimento, já não pode editar o objecto incorporado; No entanto não conterá quaisquer metadados.

regressar ao início

Variáveis de documentos poderão conter metadados

Importante Antes de utilizar a macro de exemplo seguinte, reveja a exclusão de responsabilidade neste artigo.

Para eliminar variáveis de documento que estão contidas no documento do Word, utilize a seguinte macro de exemplo:

Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

For Each myVar In ActiveDocument.Variables
Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
"Value: " & myVar.Value & vbCr & vbCr & _
"Do you want to delete the variable from this document?", vbYesNo)

If Response = "6" Then
' Delete the variable.
myVar.Delete
Else
End
End If
Next myVar

MsgBox "There are no variables in the document."

End Sub

Para mais informações sobre variáveis, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic , no menu Ajuda , escreva a Propriedade Variables no Assistente do Office ou o Assistente de respostas e, em seguida, clique em Procurar para visualizar o tópico.


regressar ao início

Sugestões gerais sobre segurança

Eis algumas sugestões gerais que pode utilizar para ajudar a aumentar o nível de segurança no seu ambiente informático:

  • Quando não estiver a utilizar o computador, ajuda a protegê-lo utilizando uma protecção de ecrã protegida por palavra-passe, energia palavra-passe ou a funcionalidade de bloqueio do Windows NT.

  • Se o computador tiver pastas partilhadas, certifique-se de que que lhes são aplicáveis as palavras-passe para que apenas utilizadores autorizados possam aceder as partilhas. Para maior segurança, utilize o controlo de acesso de nível de utilizador para que possam controlar exactamente quem pode aceder às partilhas do computador.

  • Quando elimina um ficheiro, esvazie a Reciclagem imediatamente. Poderá pretender considerar um utilitário que elimine por completo ou substitua os ficheiros quando estes são eliminados.

  • Quando tiver efectuado cópia de segurança de dados, armazene as cópias de segurança numa localização segura, como um cofre, uma caixa de depósito de segurança ou um armário.

  • Certifique-se de que os documentos importantes são protegidas por palavra-para que apenas utilizadores autorizados podem abri-los. Armazene palavras-passe numa localização segura, separada. Se não se lembrar uma palavra-passe, não é possível recuperar o conteúdo de um documento protegido por palavra-passe.

  • Não distribua documentos em formato electrónico. Em vez disso, imprima-os. Não utilize elementos de identificação, tais como tipos de letra característicos, marcas de água, logótipos ou papel especial, a menos que tenha a (por exemplo, para uma apresentação).

  • Mensagens de correio electrónico não anónimo. Enviar correio electrónico um documento se estiver preocupado sobre a sua identidade ser anexada de alguma forma ao documento.

  • Não envie um documento através da Internet utilizando o protocolo HTTP ou protocolo de transferência de ficheiros (FTP). Informações enviadas através destes protocolos são enviadas em "texto simples", isto significa que é tecnicamente possível (embora improvável) interceptá-las.

regressar ao início

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×