Sintomas
Assuma que utiliza um Grupo De Disponibilidade Sempre Disponível que tem duas réplicas secundárias configuradas para o modo de compromisso sincronizado. Quando altera o modo de disponibilidade para uma das réplicas secundárias do modo de compromisso sincronizado para o modo de compromisso assíncronos, o estado de sincronização da base de dados de disponibilidade nessa réplica secundária pode ainda ser reportado como SINCRONIZADO em vez de SINCRONIZAR na réplica primária. Isto causa atrasos na transação na réplica primária.
Causa
Este problema ocorre porque a réplica primária aguarda a mensagem de progresso de ambas as réplicas secundárias para atualizar o LSN de compromisso. Isto ocorre mesmo que uma das réplicas secundárias esteja configurada para o modo assíncronos. Como a réplica assíncronia envia a mensagem de progresso raramente, atrasa a atualização do LSN comprometedor na réplica primária. Isto, por sua vez, atrasa a atualização das transações dos utilizadores.
Resolução
Este problema é corrigido nas seguintes atualizações para o SQL Server:
Atualização Cumulativa 10 para SQL Server 2017
Atualização Cumulativa 3 para SQL Server 2016 Service Pack 2
Atualização Cumulativa 10 para SQL Server 2016 Service Pack 1
Sobre as construções do SQL Server
Cada nova construção para SQL Server contém todos os hotfixes e correções de segurança que estavam na construção anterior. Recomendamos que instale a mais recente construção para a sua versão do SQL Server:
Estado
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Referências
Saiba mais sobre a terminologia que a Microsoft utiliza para descrever atualizações de software.