Sintomas
Assuma que a piscina de identificador de parente global (RID) numa floresta muito grande que contém milhões de objetos está esgotada. Nesta situação, não é possível criar diretores de segurança em qualquer controlador de domínio que também tenha esgotado a sua piscina de RID local. Por exemplo, não é possível criar utilizadores, computadores ou grupos. Nota Quando a piscina RID estiver esgotada, não recebe avisos e não são registados registos no controlador de domínio. Este hotfix adiciona a capacidade de desbloquear a 31ª parte para expandir o tamanho da piscina global rid para 2 biliões de objetos. O suporte à expansão do tamanho do pool global rid para 2 mil milhões de objetos está incluído no lançamento do RTM do Windows Server 2012, 2012 R2, 2016, 2019 e versões posteriores.
Causa
Esta questão ocorre porque apenas 30 bits de RID estão disponíveis.
Resolução
Para resolver este problema, instale a última atualização mensal que é lançada após (setembro de 2016, KB3185278) no controlador de domínio, e depois desbloqueie o 32º bit de RID. Para tal, siga estes passos:
-
No controlador de domínio, clique em Iniciar,clique em Executar,digite ldp.exee, em seguida, clique em OK.
-
No menu 'Ligação', clique em Connect, e depois ligue-se localmente utilizando uma conta de administrador da empresa.
-
Clique em modificar no menu Browse.
-
Alterar o atributo sidComcompatibilidadeVersion a 1 adicionando a seguinte entrada à caixa de atribuição de entrada de edição:[Adicionar] sidCompatibilidade: 1
-
Pressione Entrare, em seguida, clique em Executar.
Notas
-
Quando desbloqueia a 32.000 rid, o limite do tamanho da piscina RID expande-se para dois biliões.
-
Para configurar o limite do tamanho da piscina RID, edite o valor do tamanho do bloco RID no controlador de domínio sob a seguinte chave de registo:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\RID Values\
Informação de hotfixo
Um hotfix suportado está disponível na Microsoft. No entanto, este hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique este hotfix apenas nos sistemas que estão a experimentar o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se não for severamente afetado por este problema, recomendamos que aguarde a próxima atualização de software que contenha este hotfix. Se o hotfix estiver disponível para download, existe uma secção de "Hotfix download disponível" no topo deste artigo da Knowledge Base. Se esta secção não aparecer, contacte o Serviço de Apoio ao Cliente da Microsoft para obter o hotfix. Nota Se ocorrerem problemas adicionais ou se for necessário algum problema, poderá ter de criar um pedido de serviço separado. Os custos habituais de apoio aplicar-se-ão a questões e questões de apoio adicionais que não se qualificam para este hotfix específico. Para obter uma lista completa dos números de telefone do Microsoft Customer Service e Support ou para criar um pedido de serviço separado, visite o seguinte website da Microsoft:
http://support.microsoft.com/contactus/?ws=support Nota O formulário "Hotfix download disponível" apresenta os idiomas para os quais o hotfix está disponível. Se não vê a sua língua, é porque não está disponível um hotfix para esse idioma.
Informação do registo
Para aplicar o hotfix neste pacote, não é preciso fazer alterações no registo.
Requisito de reinício
Tem de reiniciar o computador depois de aplicar este hotfix.
Informações sobre substituição de correções
Este hotfix não substitui um hotfix previamente lançado.
Estado
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".