Sintomas
Suponha que utiliza o cmdlet New-OWAVirtualDirectory ou New-ECPVirtualdirectory para recriar o diretório virtual "owa" ou "ECP" num servidor de caixa de correio Microsoft Exchange Server 2013 ou Microsoft Exchange Server 2016. Nesta situação, quando os utilizadores tentam aceder ao Outlook Web App, ao Outlook na Web ou ao Centro de Administração do Exchange (EAC), recebem um código de erro "Http 404".
Causa
Este problema ocorre porque está definido um método de autenticação incorreto para os diretórios virtuais "owa" e "ECP". Quando executa o cmdlet New-OWAVirtualDirectory ou New-ECPVirtualdirectory para criar o diretório virtual "owa" ou "ECP", o cmdlet ativa incorretamente a autenticação de Formulários e a autenticação Básica em vez da autenticação do Windows.
Solução
Para contornar este problema, siga estes passos.
Para o diretório virtual "owa"
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Abra a Shell de Gestão do Exchange (EMS) e, em seguida, execute o seguinte cmdlet para alterar o método de autenticação do diretório virtual "owa" para a autenticação do Windows:
set-Owavirtualdirectory -identity "E15MBX\owa (Exchange Back End)" -WindowsAuthentication $True -Basicauthentication $false -Formsauthentication $false
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Execute o seguinte comando nos servidores Acesso de Cliente e Caixa de Correio para reiniciar os Serviços de Informação Internet (IIS):
iisreset /noforce
Para o diretório virtual "ECP"
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Comece Windows PowerShell.
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Escreva os seguintes comandos e, em seguida, prima Enter após cada linha:
Add-PSSnapin *exchange*Set-EcpVirtualDirectory -Identity "E15MBX\ecp (Exchange Back End)" -WindowsAuthentication $true -FormsAuthentication $false
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Execute o seguinte comando nos servidores Acesso de Cliente e Caixa de Correio para reiniciar os Serviços de Informação Internet (IIS):
iisreset /noforce