Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Deteta os seguintes problemas relacionados com o Serviço SDK OpsMgr no Microsoft System Center Operations Manager 2007.

Problema 1

O MonitoringHost.exe de dados no servidor de gestão de raiz do Systems Center Operations Manager 2007 poderá consumir mais de 2 gigabytes (GB) de memória. Pode ver este sintoma no Gestor de Tarefas.

Problema 2

Um pacote de gestão no Systems Center Operations Manager 2007 converte os eventos do OpsMgr SDK Service em alertas. No entanto, quando importar novamente o pacote de gestão, os eventos que já foram processados são processados novamente.

Causa

O problema 1 ocorre porque o módulo de origem de dados do Serviço SDK OpsMgr não limita o número de itens de dados que são processados de cada vez. O módulo de origem de dados tenta ler todos os itens de dados pendentes da base de dados e processar os itens de dados num lote. O MonitoringHost.exe de dados pode parar inesperadamente em resposta a uma exceção não processada se tiver de processar demasiados itens de dados.

Resolução

Informações de hotfix

Está disponível uma hotfix suportada da Microsoft. No entanto, esta correção destina-se a corrigir apenas o problema descrito neste artigo. Aplique esta hotfix apenas aos sistemas que estão com este problema específico. Esta atualização poderá receber testes adicionais. Portanto, se não for afetado gravemente por este problema, recomendamos que aguarde pela próxima atualização de software que contém esta atualização.

Se a hotfix estiver disponível para transferência, existe uma secção "Transferência de ficheiros hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta secção não aparecer, contacte o Suporte e Suporte ao Cliente da Microsoft para obter a hotfix.

Nota Se ocorrerem problemas adicionais ou se for necessária uma remoção de problemas, poderá ter de criar um pedido de serviço separado. Os custos habituais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não são qualificáveis para esta hotfix específica. Para uma lista completa dos números de telefone do Suporte ao Cliente da Microsoft ou para criar um pedido de serviço separado, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: o formulário "Transferência de hotfix disponível" apresenta os idiomas para os quais a hotfix está disponível. Se não vir o seu idioma, significa que não está disponível uma hotfix para esse idioma.

Instruções de instalação da Hotfix

Aplique esta hotfix a todos os servidores que alomem a seguinte função de servidor:

  • Servidor de gestão do Operations Manager 2007

Para o fazer, copie o SystemCenterOperationsManager2007-RTM-KB943706-X86-X64-ENU.MSI ficheiro do pacote de ficheiros hotfix para uma pasta local ou para uma pasta partilhada. Em seguida, execute este ficheiro.

Nota Pode executar este ficheiro no Windows Explorer ou numa mensagem de comandos. O processo de instalação da hotfix reinicia o serviço Estado de Saúde do OpsMgr.

Os computadores do agente são atualizados automaticamente. No entanto, tem de aprovar a atualização na pasta "Gestão Pendente". Para tal, siga estes passos:

  1. No computador que tem a função de Servidor de Gestão, clique em Iniciar, aponte para Todos os Programas,aponte para System Center Operations Manager 2007 e, em seguida, clique em Consola de Operações.

  2. Selecione a vista Administração, expanda Administração, expanda Gestão de Dispositivos e, em seguida, clique em Gestão Pendente.

  3. Na pasta "Gestão Pendente", reveja e aprove os computadores do agente para aplicar esta hotfix.

Nota Se instalar o Operations Manager 2007 Agent em qualquer computador depois de aplicar esta gestão, certifique-se de que aprova a instalação na pasta "Gestão Pendente".

Pré-requisitos

Não são necessários pré-requisitos.

Requisitos de reinício

Não tem de reiniciar o computador depois de aplicar esta hotfix.

Informações sobre substituição de correções

Esta hotfix não substitui quaisquer outras hotfixes.

Informações de ficheiro

A versão inglesa desta correção tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros estão listadas no formato de Hora Universal Coordenada (UTC). Quando visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para encontrar a diferença entre UTC e a hora local, utilize o separador Zona Horário no item Data e Hora na Painel de Controlo.

System Center Operations Manager 2007, versões baseadas em x86

Nome de ficheiro

Versão de ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24-out-2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24-out-2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24-out-2007

09:34

x86

System Center Operations Manager 2007, versões baseadas em x64

Nome de ficheiro

Versão de ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24-out-2007

09:34

x86

Microsoft.enterprisemanagement.operationsmanager.dll

6.0.5000.31

2,166,784

24-out-2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24-out-2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24-out-2007

09:34

x86

Momperfsnapshothelper.exe

6.0.5000.0

47,104

24-out-2007

09:35

x64

Momperfsnapshothelperproxy.dll

6.0.5000.0

11,776

24-out-2007

09:35

x64

Estado

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia de atualizações de software, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft:

824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×