Symptoms
Consider the following scenario:
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You use the Microsoft Visual Studio 2008 ReportViewer control to display a report.
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You click Print from the ReportViewer control, and then you select a network printer to print the report.
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The network printer is used, or there is high network latency between the ReportViewer control and the printer.
In this scenario, the report may be delayed for several minutes before the network printer starts to print the report.
Note This issue may occur when you print reports from Microsoft Dynamics.
Cause
This problem occurs because the printing task from the control queries the page margins for every page instead of caching the margins after the first call. This causes the high network latency between the ReportViewer control and the printer.
Note The GetDeviceCaps function is used to retrieve the information about margins.
Resolution
Hotfix Information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.
Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Visual Studio 2008 Services Package 1 installed to apply this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Registry key information
You do not have to change the registry.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
32-bit version
File name |
File version |
File size |
Date |
Time |
Hashes |
---|---|---|---|---|---|
Dhtmlheader.html |
Not Applicable |
15,616 |
17-Apr-2010 |
01:02 |
Not Applicable |
Header.bmp |
Not Applicable |
7,306 |
17-Apr-2010 |
01:02 |
Not Applicable |
Hotfixinstaller.exe |
9.0.40215.0 |
321,888 |
17-Apr-2010 |
01:09 |
|
Parameterinfo.xml |
Not Applicable |
2,335 |
17-Apr-2010 |
01:02 |
Not Applicable |
Vs90sp1-kb981568.msp |
Not Applicable |
20,193,280 |
17-Apr-2010 |
01:28 |
Not Applicable |
Watermark.bmp |
Not Applicable |
96,000 |
17-Apr-2010 |
01:02 |
Not Applicable |
Eula.rtf |
Not Applicable |
100,363 |
17-Apr-2010 |
01:02 |
Not Applicable |
Hotfixinstallerui.dll |
9.0.40302.0 |
12,640 |
17-Apr-2010 |
01:09 |
MD5: 4CCA982FB35C7C3E5F00BF1545508D31 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about ReportViewer controls, visit the following Microsoft website:
ReportViewer Controls (Visual Studio)