Căutarea în Outlook pentru Mac returnează "Niciun rezultat" și elementele de activitate nu sunt afișate

Simptome

În Microsoft Outlook 2016 pentru Mac sau în Office pentru Mac 2011, primiți un mesaj "Niciun rezultat" atunci când încercați să căutați un mesaj de e-mail sau să aplicați un filtru la un folder, iar elementele de activitate nu sunt afișate în folderul Activități. În plus, atunci când căutați elemente de corespondență utilizând căutarea Spotlight nativă pentru Mac OS, căutarea dvs. nu reușește.

Cauză

Această problemă poate apărea din unul dintre următoarele motive:

Microsoft Outlook 2016 pentru Mac:

  • Indexarea căutării în Spotlight nu este completă.
  • Numele profilului conține caractere speciale, cum ar fi bara oblică (/).
  • Profilul sau unul dintre folderele sale părinte sunt adăugate la fila Confidențialitate din Spotlight.
  • Folderul Profiluri Outlook 15 nu este situat sub ~/Bibliotecă/Containere de grup/UBF8T346G9. Office/Outlook.
  • Indexul de căutare Spotlight este deteriorat.

Microsoft Outlook for Mac 2011:

  • Indexarea căutării în Spotlight nu este completă.
  • Numele de identitate conține caractere speciale, cum ar fi bara oblică (/).
  • Identitatea sau unul dintre folderele sale părinte sunt adăugate la fila Confidențialitate din Spotlight.
  • Folderul Microsoft User Data is is not located under the ~/Documents folder.
  • Indexul de căutare Spotlight este deteriorat.

Rezolvare

Pentru a rezolva această problemă, urmați acești pași:

  1. Rulați utilitarul OutlookSearchRepair .

  2. Dacă ați creat recent un nou profil Outlook în Outlook 2016 pentru Mac sau o identitate nouă în Outlook pentru Mac 2011, ați adăugat un cont nou sau dacă ați importat recent date noi dintr-o sursă, cum ar fi un fișier PST sau OLM, indexarea în prim plan poate să nu fie completă. În acest caz, Outlook pentru Mac afișează un mesaj "Niciun rezultat". Pentru a rezolva această problemă, așteptați să se termine indexarea, apoi căutați din nou.

  3. Asigurați-vă că numele profilului dvs. în Outlook 2016 pentru Mac sau numele de identitate din Outlook pentru Mac 2011 nu conține caractere speciale, cum ar fi bara oblică (/). 
    Pentru a vă vedea profilul sau numele de identitate:
    Outlook 2016 pentru Mac:

    1. Faceți clic pe Salt, Aplicații.
    2. Right-Click Microsoft Outlook și selectați Afișați conținutul pachetului.
    3. Extindeți Conținut, Suport partajat și deschideți Managerul de profiluri Outlook.

    Notă Puteți să creați un alias pentru Managerul de profiluri Outlook și să-l mutați pe desktop sau într-o altă locație convenabilă, dacă preferați.

    Outlook pentru Mac 2011:

    Pentru a vedea numele de identitate în utilitarul de baze de date Microsoft, țineți apăsată tasta Option, apoi faceți clic pe pictograma Outlook pentru Mac 2011.

  4. Dacă numele profilului sau identității conține un caracter special, urmați acești pași pentru a modifica numele:

    1. Deschideți folderul Profil Outlook 2016 pentru Mac sau folderul Identitate Outlook pentru Mac 2011.
      În Outlook 2016 pentru Mac, locația este:
      /Utilizatori/<Nume utilizator>/Bibliotecă/Containere de grup/UBF8T346G9. Profiluri Office/Outlook/Outlook 15/

      În Outlook pentru Mac 2011, locația este:
      Utilizatori/<Nume de utilizator>/Documente/Date utilizator Microsoft/Identități Office 2011/

    2. Redenumiți numele folderului Profil Outlook 2016 pentru Mac sau numele folderului Identitate Outlook pentru Mac 2011 care conține caractere speciale prin eliminarea caracterelor speciale.

    3. Confirmați că profilul sau numele de identitate a fost modificat, vizualizându-l în felul următor, în funcție de versiunea dvs. Outlook pentru Mac:

      În Outlook 2016 pentru Mac:

      1. Faceți clic pe Salt, Aplicații.
      2. Right-Click Microsoft Outlook și selectați Afișați conținutul pachetului.
      3. Extindeți Conținut, Suport partajat și deschideți Managerul de profiluri Outlook.

      Notă Puteți să creați un alias pentru Managerul de profiluri Outlook și să-l mutați pe desktop sau într-o altă locație convenabilă, dacă preferați.

      În Outlook pentru Mac 2011:

      Deschideți Microsoft Database Utility ținând apăsată tasta Option , apoi făcând clic pe pictograma Outlook pentru Mac 2011 .

    4. Dacă este necesar, selectați profilul sau identitatea al cărei nume a fost modificat, faceți clic pe pictograma roată dințată, apoi faceți clic pe Stabilire ca implicit.

  5. În Mac OS, verificați dacă profilul sau folderul Identitate Outlook sau unul dintre folderele sale părinte nu este adăugat la fila Confidențialitate din Spotlight. Dacă în această filă se afișează folderul Profiluri Outlook 2016 pentru Mac, folderul de identitate Outlook pentru Mac 2011 sau oricare dintre folderele părinte, Spotlight nu indexează această locație de folder. Eliminați aceste locații din fila Confidențialitate din Spotlight și așteptați un timp pentru ca aceste locații să termine indexarea.

  6. Asigurați-vă că profilul Outlook 2016 pentru Mac sau datele de identitate Outlook pentru Mac 2011 sunt stocate în locația implicită corectă.
    Outlook 2016 pentru Mac: Asigurați-vă că folderul Profiluri Outlook 15 este stocat sub ~/Bibliotecă/Containere de grup/UBF8T346G9. Folderul Office/Outlook.

    Outlook pentru Mac 2011: Asigurați-vă că folderul Date utilizator Microsoft este stocat sub folderul ~/Documente.

  7. Dacă problema este încă nerezolvată, este posibil ca indexul Spotlight să fie deteriorat. Pentru a reindexa indexul Reflector, urmați acești pași:

    1. Reporniți computerul Mac, astfel încât să repornească serviciile Spotlight.

    2. Navigați laTerminalulutilitare>de aplicații>Finder>.

    3. Tastați mdimport -L.

    4. Important: Dacă vedeți mai multe instanțe cu "Reflector Microsoft Outlook Importer.mdimporter", ștergeți aplicația Outlook pe care nu o utilizați, goliți-o din Coșul de gunoi, reporniți computerul Mac și reveniți la pasul 1.

    5. În Terminal, reindexați baza de date Outlook utilizând următoarea comandă și înlocuind substituentul <user_name> cu propriul nume de utilizator:

      mdimport -g "/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter" -d1 "/Users/<user_name>/Library/Group Containers/UBF8T346G9. Profiluri Office/Outlook/Outlook 15/<my_profile_name>" 

      Notă În această comandă, calea de după "-g" este calea implicită a instalării Outlook. Calea de după "-d1" este calea implicită a profilului dvs., unde <my_profile_name> este, implicit, "Profil principal". Va trebui să înlocuiți căile reale dacă v-ați redenumit profilul sau ați instalat Outlook în altă locație.

    6. Reindexarea va dura un timp. După ce se termină procesul, închideți și reporniți Outlook.

Dacă tot nu puteți căuta în Spotlight după ce urmați acești pași și dacă ați așteptat suficient timp pentru finalizarea indexării Spotlight, poate fi necesar să dezinstalați Office pentru Mac și să-l reinstalați. Pentru informații suplimentare privind acestea, faceți clic pe următorul număr de articol pentru a-l vedea în Baza de cunoștințe Microsoft:

2398768 Cum se elimină complet Office for Mac 2011

Mai multe informații

Atunci când căutați în Outlook 2016 pentru Mac sau în Outlook pentru Mac 2011 pe Mac OS X, rețineți următoarele:

  • Mac OS include Căutare în prim plan. Mac OS controlează indexarea hard diskului pentru Căutare în prim plan.
  • Ambele versiuni de Outlook pentru Mac se bazează pe Căutare în prim plan pentru a furniza rezultate de căutare pentru datele Outlook.
  • Filtrele din Outlook pentru Mac se bazează, de asemenea, pe Căutare în prim plan pentru a furniza rezultatele căutării.
  • Activitățile în Outlook pentru Mac sunt afișate utilizând filtre. Aceste filtre se bazează pe Căutare în prim plan.
  • Indexarea Reflector poate dura câteva minute atunci când sunt introduse date noi. De exemplu, acest lucru se poate întâmpla atunci când se primesc mesaje de e-mail noi.

Microsoft oferă informații de contact de la terți pentru a vă ajuta să găsiți asistență tehnică. Aceste informații de contact se pot modifica fără notificare prealabilă. Microsoft nu garantează acuratețea acestor informații de contact de la terți. 

Produsele unor terți prezentate în acest articol sunt fabricate de companii independente de Microsoft. Microsoft nu prezintă nicio garanție, implicită sau de altă natură, privind performanța sau fiabilitatea acestor produse.