Simptome
Luați în considerare următorul scenariu:
- Instalați Microsoft Customer Care Framework (CCF) 2009 pe un computer.
- Apelați metoda Microsoft.Ccf.Csr.WebSerices.ContactCenter/NonHostedApplication::GetNonHostedApplications pentru a regăsi lista de aplicații negăzduite care sunt definite în CCF 2009.
În acest scenariu, metoda GetNonHostedApplications returnează rezultate trunchiate.
Notă: Această problemă apare, de asemenea, în CCF 2008. Cu toate acestea, pachetul de remedieri rapide pentru CCF 2008 nu este disponibil în prezent.
Cauză
Această problemă apare deoarece rezultatele returnate de metoda GetNonHostedApplications depășesc 2033 de caractere.
Când metoda GetNonHostedApplications utilizează următoarea interogare pentru a regăsi lista de aplicații din baza de date CCFInfrastructure , comanda Raw returnează date în bloburi de 2033 de caractere:
Select * from NonHostedApplications for xml raw
Cu toate acestea, metoda GetNonHostedApplications elimină tot ce trece de prima linie de caractere 2033. Prin urmare, rezultatele sunt trunchiate.
Rezolvare
Informații despre remedierea rapidă
O remediere rapidă acceptată este acum disponibilă de la Microsoft. Cu toate acestea, ea este menită să corecteze doar problema descrisă în acest articol. Aplicați-o doar sistemelor care se confruntă cu această problemă specifică. Această remediere rapidă poate fi testată suplimentar. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să așteptați următoarea care conține această remediere rapidă.
Pentru a rezolva imediat această problemă, contactați Serviciile de asistență clienți Microsoft pentru a obține remedierea rapidă. Pentru o listă completă a numerelor de telefon ale Serviciilor de asistență pentru clienții Microsoft și informații despre costurile de asistență, vizitați următorul site web Microsoft:
http://support.microsoft.com/contactus/?ws=support Notă În cazuri speciale, costurile implicate de obicei pentru apelurile de asistență pot fi revocate dacă un specialist de la Asistență Microsoft stabilește că o anumită actualizare va rezolva problema. Costurile uzuale de suport se vor aplica pentru întrebări suplimentare de suport și pentru probleme ce nu fac obiectul actualizării în chestiune.
Cerințe preliminare
Pentru a aplica această remediere rapidă, trebuie să aveți instalat Microsoft Customer Care Framework (CCF) 2009 Service Pack 1 (SP1).
Cerința de repornire
Nu este necesar să reporniți computerul după ce aplicați această remediere rapidă dacă fișierele afectate nu sunt utilizate.
Informații despre înlocuirea remedierii rapide
Această remediere rapidă nu înlocuiește o remediere rapidă lansată anterior.
Informații despre fișiere
Versiunea în limba engleză a acestei remedieri rapide are atributele de fișier (sau atributele de fișier mai recente) listate în tabelul următor. Datele și orele pentru aceste fișiere sunt listate în UTC. Când vizualizați informațiile despre fișier, acestea sunt convertite la ora locală. Pentru a găsi diferența dintre UTC și ora locală, utilizați fila Fus orar din elementul Dată și oră din Panou de control.
| Nume fișier | Versiune de fișier | Dimensiune fișier | Dată | Oră | Platformă |
|---|---|---|---|---|---|
| Microsoft.ccf.csr.webservices.providers.dll | 4.1.10326.1 | 210,832 | 23-Nov-2010 | 16:13 | x86 |
Soluție
Pentru a rezolva această problemă, apelați metoda GetShortDetails într-un serviciu web AdminConsole\NonHostedAppWS .
Stare
Microsoft a confirmat că aceasta este o problemă în produsele Microsoft care sunt listate în secțiunea „Se aplică la”.