Setările Arhivă Document din casetele de dialog "Instalare Achiziție & Plăți" și "Configurare Vânzări & Creanțe" nu funcționează în versiunea nord-americană de Microsoft Dynamics NAV 2009 R2

Se aplică la
Dynamics NAV 2009

Acest articol se aplică la Microsoft Dynamics NAV pentru următoarele țări și setări regionale de limbă.

  • Engleză (Canada) (en-ca)
  • Engleză (Statele Unite ale Americii) (en-us)
  • Spaniolă (Mexic) (es-mx)
  • Franceză (Canada) (fr-ca)

Simptome

Setările Arhivă Document din casetele de dialog Achiziție & Configurare facturi și Vânzări & Configurare creanțe nu funcționează în versiunea nord-americană de Microsoft Dynamics NAV 2009 R2.
Indiferent dacă este bifată caseta de selectare Arhivă Ofertă și comenzi în casetele de dialog Achiziție & Configurare date sau Vânzări & Creanțe, câmpul Document Arhivă este completat cu o comandă sau o ofertă arhivată. 

Cauză

Această problemă apare deoarece sistemul nu ia în considerare setarea Document Arhivă. Sistemul ia în considerare doar dacă utilizatorul are permisiunile WRITE pentru a arhiva tabelele de antet.

Rezolvare

Informații despre remedierea rapidă

O remediere rapidă acceptată este acum disponibilă de la Microsoft. Însă, scopul său este doar să corecteze problema descrisă în acest articol. Aplicați-o doar sistemelor care se confruntă cu această problemă specifică. Această remediere rapidă poate fi testată suplimentar. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să așteptați următorul pachet Service Pack Microsoft Dynamics NAV sau următoarea versiune Microsoft Dynamics NAV care conține această remediere rapidă.

Notă În cazuri speciale, costurile implicate de obicei pentru apelurile de asistență pot fi revocate dacă un specialist în asistență tehnică pentru Microsoft Dynamics și produsele asociate stabilește că o anumită actualizare va rezolva problema. Costurile uzuale de suport se vor aplica pentru întrebări suplimentare de suport și pentru probleme ce nu fac obiectul actualizării în chestiune.

            
          

Informații despre instalare

Microsoft oferă exemple de programare numai în scop ilustrativ, fără nicio garanție explicită sau implicită. Aceasta include, dar nu se limitează la, garanțiile implicite de vandabilitate sau adecvare pentru un anumit scop. Acest articol presupune că sunteți familiarizat cu limbajul de programare prezentat și cu instrumentele utilizate pentru a crea și a depana proceduri. Inginerii de asistență Microsoft pot ajuta la explicarea funcționalității unei anumite proceduri, însă nu vor modifica aceste exemple pentru a furniza funcționalitate suplimentară și nu vor construi proceduri pentru a răspunde cerințelor dvs. specifice.

Notă Înainte de a instala această remediere rapidă, verificați dacă toți utilizatorii clientului Microsoft Navision sunt deconectați de la sistem. Printre aceștia se numără utilizatorii clienților Microsoft Navision Application Services (NAS). Ar trebui să fiți singurul utilizator client conectat atunci când implementați această remediere rapidă.

Pentru a implementa această remediere rapidă, trebuie să aveți o licență de dezvoltator.

Recomandăm ca contului de utilizator din fereastra Conectări Windows sau din fereastra Conectări bază de date să primească ID-ul de rol "SUPER". În cazul în care contului de utilizator nu i se poate atribui ID-ul de rol "SUPER", trebuie să verificați dacă acel cont de utilizator are următoarele permisiuni:

  • Permisiunea Modificare pentru obiectul pe care îl veți modifica.
  • Permisiunea de executare pentru obiectul cu ID obiect de sistem 5210 și pentru obiectul ID obiect de sistem 9015.

                
Notă: nu trebuie să aveți drepturi asupra depozitelor de date decât dacă trebuie să efectuați repararea datelor.

Modificări de cod

Notă: testați întotdeauna remedierile de cod într-un mediu controlat înainte de a aplica remedierile la computerele de producție.
Pentru a rezolva această problemă, urmați acești pași:

  1. Modificați codul din funcția SalesDocArchiveGranule din unitatea de cod ArchiveManagement (5063), după cum urmează:
    Cod existent

    PROCEDURE SalesDocArchiveGranule@6() : Boolean;
    VAR
    SalesHeaderArchive@1000 : Record 5107;
    BEGIN
    EXIT(SalesHeaderArchive.WRITEPERMISSION);
    END;
    

    Codul de înlocuire

    PROCEDURE SalesDocArchiveGranule@6() : Boolean;
    VAR
    SalesHeaderArchive@1000 : Record 5107;
    
    // Add the following line.
    SalesSetup@1001 : Record 311;
    
    BEGIN
    
    // Add the following lines.
    SalesSetup.GET;
    IF NOT SalesSetup."Archive Quotes and Orders" THEN
    EXIT(FALSE)
    ELSE
    // End of the lines.
    
    EXIT(SalesHeaderArchive.WRITEPERMISSION);
    END;
    
  2. Modificați codul din funcția PurchaseDocArchiveGranule din unitatea de cod ArchiveManagement (5063), după cum urmează:
    Cod existent

    PROCEDURE PurchaseDocArchiveGranule@5() : Boolean;
    VAR
    PurchaseHeaderArchive@1000 : Record 5109;
    BEGIN
    EXIT(PurchaseHeaderArchive.WRITEPERMISSION);
    END;
    

    Codul de înlocuire

    PROCEDURE PurchaseDocArchiveGranule@5() : Boolean;
    VAR
    PurchaseHeaderArchive@1000 : Record 5109;
    
    // Add the following line.
    PurchaseSetup@1001 : Record 312;
    
    BEGIN
    
    // Add the following lines.
    PurchaseSetup.GET;
    IF NOT PurchaseSetup."Archive Quotes and Orders" THEN
    EXIT(FALSE)
    ELSE
    // End of the lines.
    
    EXIT(PurchaseHeaderArchive.WRITEPERMISSION);
    END;
    

Cerințe preliminare

Trebuie să aveți versiunea nord-americană de Microsoft Dynamics NAV 2009 R2 instalată pentru a aplica această remediere rapidă.

Eliminarea informațiilor

Nu puteți elimina această remediere rapidă.

Stare

Microsoft a confirmat că aceasta este o problemă în produsele Microsoft care sunt listate în secțiunea „Se aplică la”.

Notă: Acesta este un articol "PUBLICARE RAPIDĂ" creat direct din cadrul organizației de asistență Microsoft. Informațiile din acest document sunt furnizate ca atare ca răspuns la problemele apărute. Ca urmare a vitezei de punere la dispoziție, materialele pot include erori tipografice și pot fi revizuite în orice moment fără preaviz. Consultați Condițiile de utilizare pentru alte considerente.