Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Acest articol se aplică la Microsoft Dynamics NAV pentru următoarele țări și setări regionale de limbă.

  • Germană (Germania) (de-de)

  • Austriac (Austria) (at-at)

  • Franceză (Elveția) (fr-CH)

  • Germană (Elveția) (de-CH)

  • Italiană (Elveția) (it-CH)

Simptome

Atunci când derulează "Postat fizic. Stoc. Raport dif. ", raportul nu afișează diferențe. Raportul are coloana linii așteptate, coloana linii de înregistrare și coloana linii de urmărire. Coloana din dreapta este întotdeauna goală. Această problemă apare în următoarele produse:

  • Versiunea în limba germană a Microsoft Dynamics NAV 2009 R2

  • Versiunea austriacă a Microsoft Dynamics NAV 2009 R2

  • Versiunea Elvețiană a Microsoft Dynamics NAV 2009 R2

  • Versiunea în limba germană a Microsoft Dynamics NAV 2009 Service Pack 1

  • Versiunea austriacă a Microsoft Dynamics NAV 2009 Service Pack 1

  • Versiunea Elvețiană a Microsoft Dynamics Service Pack 1

Cauză

Această problemă apare deoarece variabila TempPhysInvtDiffListBuffer2 a raportului este o variabilă locală, iar variabila nu este atribuită niciodată de oriunde din raport. În plus, variabila nu este o variabilă temporară. Prin urmare, variabila indică spre actualul "fizic. Stoc. DIF. Tampon listă "tabel care este întotdeauna gol.

Rezolvare

Informații despre remedieri rapide

O remediere rapidă acceptată este acum disponibilă de la Microsoft. Cu toate acestea, este destinat doar să corecteze problema descrisă în acest articol. Aplicați-o doar pentru sistemele care întâmpină această problemă specifică. Această remediere rapidă poate primi teste suplimentare. Prin urmare, dacă nu sunteți grav afectat de această problemă, vă recomandăm să așteptați următorul pachet Service Pack Microsoft Dynamics NAV 2009 sau următoarea versiune Microsoft Dynamics NAV care conține această remediere rapidă.

Notă în cazuri speciale, tarifele care sunt suportate de obicei pentru apelurile de asistență pot fi anulate dacă un profesionist de asistență tehnică pentru Microsoft Dynamics și produsele asociate determină faptul că o anumită actualizare va rezolva problema. Costurile uzuale de suport se vor aplica pentru întrebări suplimentare de suport și pentru probleme ce nu fac obiectul actualizării în chestiune.


Informații despre instalare

Microsoft furnizează exemple de programare doar pentru ilustrație, fără garanție explicită sau implicită. Acestea includ, dar nu se limitează la garanþiile implicite de vandabilitate sau adecvare la un anumit scop. Acest articol presupune că sunteți familiarizat cu limbajul de programare care este în curs de demonstrare și cu instrumentele utilizate pentru a crea și a depana proceduri. Inginerii de asistență Microsoft vă pot ajuta să explicați funcționalitatea unei anumite proceduri. Cu toate acestea, aceștia nu vor modifica aceste exemple pentru a oferi funcționalități suplimentare sau pentru a construi proceduri pentru a îndeplini cerințele specifice.

Notă înainte să instalați această remediere rapidă, asigurați-vă că toți utilizatorii de client Microsoft Navision sunt conectați la sistem. Aceasta include utilizatori clienți Microsoft Navision Application Services (NAS). Ar trebui să fiți singurul utilizator client care s-a conectat atunci când implementați această remediere rapidă.

Pentru a implementa această remediere rapidă, trebuie să aveți o licență pentru dezvoltatori.

Vă recomandăm ca contul de utilizator din fereastra Conectări Windows sau din fereastra Conectări bază de date să i se atribuie ID-ul de rol "SUPER". Dacă contul de utilizator nu poate fi atribuit ID-ul de rol "SUPER", trebuie să verificați dacă contul de utilizator are următoarele permisiuni:

  • Permisiunile de modificare pentru obiectul pe care îl veți modifica.

  • Permisiunea de executare pentru obiectul System Object ID 5210 și pentru obiectul System Object ID 9015.



Notă Nu trebuie să aveți drepturi pentru magazinele de date decât dacă trebuie să efectuați reparații de date.

Modificările codului

Notă întotdeauna remedieri cod test într-un mediu controlat înainte de a aplica remedierile la computerele de producție.
Pentru a rezolva această problemă, urmați acești pași:

  1. Modificați variabila TempPhysInvtDiffListBuffer2 din funcția CreateDiffListBuffer de la o variabilă locală la o variabilă globală a postului fizic. Stoc. DIF comandă. raport (5005351) după cum urmează:

    TempPhysInvtDiffListBuffer2@1140019 : TEMPORARY Record 5005363;

    tempphysinvtdifflistbuffer2@1140019

  2. Modificați codul din funcția FindOrCreateDiffListBuffer din raportul fizic înregistrat. Stoc. DIF comandă. raport (5005351) după cum urmează:
    codul existent

      TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;
    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

    Cod de înlocuire

    ...
    TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;

    // Add the following lines.
    TempPhysInvtDiffListBuffer2 := TempPhysInvtDiffListBuffer;
    TempPhysInvtDiffListBuffer2.INSERT;
    // End of the lines.

    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

Cerinţe preliminare

Trebuie să aveți unul dintre următoarele produse instalate pentru a aplica această remediere rapidă:

  • Versiunea în limba germană a Microsoft Dynamics NAV 2009 R2

  • Versiunea austriacă a Microsoft Dynamics NAV 2009 R2

  • Versiunea Elvețiană a Microsoft Dynamics NAV 2009 R2

  • Versiunea în limba germană a Microsoft Dynamics NAV 2009 Service Pack 1

  • Versiunea austriacă a Microsoft Dynamics NAV 2009 Service Pack 1

  • Versiunea Elvețiană a Microsoft Dynamics Service Pack 1

Informații despre eliminare

Nu puteți elimina această remediere rapidă.

Stare

Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.

Notă Acesta este un articol "publicare rapidă" creat direct din cadrul Organizației de asistență Microsoft. Informațiile conținute în acest document sunt furnizate ca răspuns la problemele emergente. Ca rezultat al vitezei de a-l face disponibil, materialele pot include greșeli tipografice și pot fi revizuite în orice moment, fără notificare. Consultați Termenii de utilizare pentru alte considerații.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×