Acest articol se aplică la Microsoft Dynamics NAV pentru toate țările și toate limbi regionale.
Simptome
Atunci când copiați o valoare celulă dintr-o foaie de lucru Excel la Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), două caractere speciale sunt adăugate la finalul valorii. Aceste caractere speciale sunt dreptunghi semne ca linie de flux de caractere.
Notă Dacă executați Microsoft Dynamics NAV și Microsoft Excel pe un computer cu Windows 7, aceste două caractere nu sunt vizibile. Dacă executați Microsoft Dynamics NAV și Microsoft Excel pe un computer bazat pe Windows Server 2003, caracterele sunt vizibile.
Aceste caracteristici sunt adăugate la câmpurile în Microsoft Dynamics NAV. De aceea, trebuie să ștergeți caractere speciale manual.
Cauza
Această problemă apare deoarece transportul reveni caractere (CR) (ASCII 13) sau linie flux (LF) caractere (ASCII 10) se adaugă la o valoare celulă este copiat dintr-o foaie de lucru Excel la o aplicație. Clientul personalizat pe roluri (RTC) utilizează control text, bazat pe controlul de text standard .NET. Dacă controlul text .NET are proprietatea Multiline setată la "Nu", atunci când lipiți un control text care conține caracterul CR sau caracterul LF, numai textul înainte de caractere este copiat. Dacă controlul text are proprietatea Multiline setat la "True", "linie nouă" caractere pot fi utilizate. Pentru mai multe informații, vizitați următorul site Web Microsoft:
Proprietatea TextBoxBase.Multiline
Într-un client clasic, Microsoft Dynamics NAV trebuie să implementeze prelucrare specială pentru Lipire metoda de controale de editare text. "Linie nouă" caractere trebuie să fie eliminate de la sfârșitul liniei.
Rezolvare
Informații despre remedierea rapidă
O remediere rapidă compatibilă este disponibilă de la Microsoft. Există o secțiune "remediere Descărcare disponibilă" în partea de sus a acestui articol din baza de cunoștințe. Dacă întâlniți o problemă de descărcarea, instalarea acestei remedieri rapide sau alte întrebări de asistență tehnică, contactați partenerul sau, dacă s-au asociat unui plan de suport direct cu Microsoft, posibilitatea să contactați asistența tehnică pentru Microsoft Dynamics și creați o nouă solicitare de suport. Pentru aceasta, vizitați următorul site Web Microsoft:
https://mbs.microsoft.com/support/newst art.aspxDe asemenea, puteți contacta suport tehnic pentru Microsoft Dynamics prin telefon, utilizați aceste linkuri pentru țara anumite numere de telefon. Pentru aceasta, vizitați unul dintre următoarele site-uri Web Microsoft:
Parteneri
https://mbs.microsoft.com/customersource/support/information/SupportIn formation/global_support_contacts_eng.htmÎn cazuri speciale, costurile implicate de obicei pentru asistență apeluri pot fi anulate dacă un specialist în asistență tehnică pentru Microsoft Dynamics și produse asociate stabilește că o anumită actualizare va rezolva problema. Se vor aplica costurile uzuale de asistență pentru orice întrebări suplimentare de asistenţă şi pentru probleme ce nu fac obiectul actualizării în cauză.
Cum se obține remedierea rapidă Microsoft Dynamics NAV sau actualizați fișierele
După ce solicita o remediere rapidă Microsoft Dynamics NAV, un hyperlink va fi trimis într-un e-mail.
Mesajul de poștă electronică va conține un hyperlink și o parolă. Puteţi utiliza hyperlink pentru a descărca remedierea rapidă Microsoft Dynamics NAV sau fișierele de actualizare. Când faceţi clic pe hyperlinkul, se deschide caseta de dialog Descărcare fișier – avertisment de securitate . Apoi, vi se solicită să se execute, pentru a salva sau a anula descărcarea.
Dacă faceți clic pe executare, fișierele începe descărcarea și procesul de extragere. Trebuie să specificați un folder pentru fișiere noi, și apoi tastați parola.
Dacă faceți clic pe Salvare, trebuie să specificați o cale pentru a salva fişierul comprimat. Când deschideți fișierul pe care l-ați salvat, vi se solicită să specificați calea pentru fișierele. Apoi, trebuie să furnizați parola furnizate în poșta electronică.
Dacă faceți clic pe Revocare, se oprește procesul de descărcare.
Cum se instalează o remediere rapidă Microsoft Dynamics NAV sau un fișier de actualizare
Microsoft Dynamics NAV platformă remedierile rapide și actualizări sunt făcute disponibile ca fișiere singur. Pentru a instala o remediere rapidă Microsoft Dynamics NAV sau o actualizare, trebuie să înlocuiți fișierele de instalare Microsoft Dynamics NAV existente cu remedierea rapidă sau fișierele de actualizare. Pentru aceasta, urmați acești pași.
Pasul 1: Înlocuiţi fişierul de instalare a clientului Microsoft Dynamics NAV
În instalarea clientului Microsoft Dynamics NAV, înlocuiți următoarele fișiere utilizând remedierea rapidă sau fişierul de actualizare.
Nume de fișier |
Versiune fișier |
Dimensiune fișier |
Data |
Ora |
Platformă |
---|---|---|---|---|---|
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Fin.exe |
5.0.32009.0 |
10,747,904 |
09-Dec-2010 |
19:31 |
x86 |
Finhlink.exe |
5.0.32009.0 |
339,968 |
09-Dec-2010 |
19:44 |
x86 |
Finsql.exe |
5.0.32009.0 |
10,809,344 |
09-Dec-2010 |
20:17 |
x86 |
Nc_netb.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcp.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcps.dll |
5.0.32009.0 |
147,456 |
09-Dec-2010 |
19:55 |
x86 |
Ndbcs.dll |
5.0.32009.0 |
1,286,144 |
09-Dec-2010 |
20:20 |
x86 |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Pentru a înlocui fișierele existente Microsoft Dynamics NAV, urmați acești pași:
-
Închideți Microsoft Dynamics NAV.
-
Găsiți directorul de instalare Microsoft Dynamics NAV Client. Clientul Microsoft Dynamics NAV este instalat de obicei în următorul Director:
C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
-
Copiați fișierele pe care l-ați descărcat.
-
Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV Client.
-
Când vi se solicită, faceți clic pe Da pentru a suprascrie fișierele din directorul de instalare.
Pasul 2: Înlocuiţi fişierul de instalare Microsoft Dynamics NAV Application Server
Dacă aveți Microsoft Dynamics NAV Server de aplicație instalată în instalarea Microsoft Dynamics NAV Application Server, înlocuiți următoarele fișiere utilizând remedierea rapidă sau fișierul de actualizare.
Nume de fișier |
Versiune fișier |
Dimensiune fișier |
Data |
Ora |
Platformă |
---|---|---|---|---|---|
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Nas.exe |
5.0.32009.0 |
1,859,584 |
09-Dec-2010 |
19:41 |
x86 |
Nassql.exe |
5.0.32009.0 |
1,916,928 |
09-Dec-2010 |
20:19 |
x86 |
Ndbcs.dll |
5.0.32009.0 |
1,286,144 |
09-Dec-2010 |
20:20 |
x86 |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Pentru a înlocui fişierele, urmați acești pași.
-
Stop Microsoft Dynamics NAV Application Server.
-
Găsiți directorul de instalare Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server este instalat de obicei în următorul Director:
C:\Program Files\Microsoft Dynamics NAV\Application Server\
-
Copiați fișierele pe care l-ați descărcat.
-
Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV Application Server.
-
Când vi se solicită, faceți clic pe Da pentru a suprascrie fișierele din directorul de instalare.
-
Porniți Microsoft Dynamics NAV Application Server.
Pasul 3: Înlocuiţi fişierul de instalare Microsoft Dynamics NAV ODBC driver
Dacă aveți instalat driverul de Microsoft Dynamics NAV ODBC, înlocuiți următoarele fișiere în Microsoft Dynamics NAV ODBC instalarea driverului.
Nume de fișier |
Versiune fișier |
Dimensiune fișier |
Data |
Ora |
Platformă |
---|---|---|---|---|---|
Cfront.dll |
5.0.32009.0 |
1,294,336 |
09-Dec-2010 |
19:55 |
x86 |
Dbm.dll |
5.0.32009.0 |
434,176 |
09-Dec-2010 |
19:53 |
x86 |
Nc_netb.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcp.dll |
5.0.32009.0 |
102,400 |
09-Dec-2010 |
19:54 |
x86 |
Nc_tcps.dll |
5.0.32009.0 |
147,456 |
09-Dec-2010 |
19:55 |
x86 |
Nodbc.dll |
5.0.32009.0 |
2,650,112 |
09-Dec-2010 |
19:35 |
x86 |
Nodbc.xml |
Nu se aplică |
1,209 |
07-Apr-2008 |
01:09 |
Nu se aplică |
Nodbccfg.cfg |
5.0.32009.0 |
614,400 |
09-Dec-2010 |
19:36 |
Nu se aplică |
Nodbccfg.xml |
Nu se aplică |
2,472 |
07-Apr-2008 |
01:09 |
Nu se aplică |
Slave.exe |
5.0.32009.0 |
151,552 |
09-Dec-2010 |
19:44 |
x86 |
Pentru a înlocui fişierele, urmați acești pași.
-
Găsiți directorul de instalare Microsoft Dynamics NAV ODBC driver. Microsoft Dynamics NAV ODBC driverul este instalat, de obicei în următorul Director:
C:\Program Files\Common Files\Dynamics NAV\NODBC\
-
Copiați fișierele pe care l-ați descărcat.
-
Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV ODBC driver.
-
Când vi se solicită, faceți clic pe Da pentru a suprascrie fișierele din directorul de instalare.
Cerințe preliminare
Trebuie să aveți Microsoft Dynamics NAV 5.0 Service Pack 1 instalat pentru a aplica această remediere rapidă.
Soluție
Pentru a evita, editați celule și marca celula ca "Numai Text."
Stare
Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea "Se aplică la".
Mai multe informații
Pentru mai multe informaţii, faceţi clic pe următorul număr de articol pentru a vedea articolul în baza de cunoştinţe Microsoft:
824684 Descrierea terminologiei standard care este utilizat pentru a descrie actualizările de software Microsoft
Notă Acesta este un articol "rapid publicat" creat direct în cadrul organizației de asistență Microsoft. Informațiile conținute în acest document sunt furnizate ca răspuns la problemele care apar. Ca rezultat al vitezei în a-l face disponibil, materialele pot include erori tipografice și pot fi revizuite în orice moment, fără notificare. Consultați Termenii de utilizare pentru alte considerații.