Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Să presupunem că utilizați clientul Microsoft Dynamics CRM 2011 pentru Microsoft Office Outlook și că redirecționarea folderului este activată pentru client. Atunci când încercați să urmăriți un element sau să difuzați funcția Sincronizați cu CRM în această situație, primiți un mesaj de eroare asemănător cu următorul:

[2011-09-07 11:11:08.517] Proces: OUTLOOK | Organizație: 00000000-0000-0000-0000-000000000000 | Subiect: 24 | Categorie: excepție | Utilizator: 00000000-0000-0000-0000-000000000000 | Level: eroare | CrmException.. ctorat CrmException.. ctor (mesaj șir, excepție innerException, Int32 errorCode, Boolean isFlowControlException) la CrmException.. ctor (mesaj șir, excepție innerException) la CrmSqlCeConnection. <deschide>b__2 (SqlCeException ex) la ExceptionFilter. TryFilter (Body Action, predicat ' 1 Filter, Action ' 1 catchClause) at IdMappingTable. MarkAllItemsNotVisited () >CRM excepție: mesaj: SQL CE Database File este utilizat de un alt proces, ErrorCode:-2147220970, InnerException: există o încălcare a partajării fișierelor. Este posibil ca un alt proces să utilizeze fișierul. [ \\<server>\C$\<user>\Microsoft\MSCRM\Client\OutlookSyncCache.sdf ].

Cauză

Această problemă se produce din cauza unei limitări în Microsoft SQL Server 2000 Windows CE Edition 3,5 (SQL Server CE 3,5). 

Rezolvare

Notă După ce s-a aplicat pachetul de actualizare 15 Microsoft Dynamics CRM pentru Outlook, acesta va face upgrade automat la SQL CE 4,0. Prin urmare, rezoluția de mai jos este necesară doar pentru setul de actualizări 14 și mai mic. Pentru a executa Microsoft Dynamics CRM 2011 atunci când folderul date aplicație se află într-o partajare la distanță, urmați acești pași:

  1. Instalați SQL Server CE 4,0. Pentru a face acest lucru, vizitați următorul site Web Microsoft:

    http://www.microsoft.com/download/en/details.aspx?id=17876Note

    • Acest pas necesită permisiuni ridicate.

    • În SQL Server CE 4,0, clienții 64 de biți nu trebuie să instaleze versiunea 32-bit.

  2. Adăugați următorul cod XML sub elementul de configurare în fișierul CrmClient {14B13B7A-CA08-40bd-AC60-8C45367E807C}. config care se află în folderul Program Files\MSCRM\Client:

    <runtime> <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">   <dependentAssembly>      <assemblyIdentity name="System.Data.SqlServerCe" publicKeyToken="89845dcd8080cc91" culture="neutral" />      <bindingRedirect oldVersion="3.5.1.0"      newVersion="4.0.0.0"/>   </dependentAssembly> </assemblyBinding></runtime>

    Note

    • Acest pas necesită permisiuni ridicate.

    • Asigurați-vă că adăugați acest cod înainte de a </Configuration> etichetă.

  3. În plus, există un al doilea fișier de configurare pe care îl apelează Expertul de configurare. Fișierul este denumit Microsoft. CRM. Application. Outlook. ConfigWizard. exe. config și fișierul se află în folderul C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard:

    <configuration>  <startup>    <supportedRuntime version="v4.0.30319" />  </startup>  <runtime>    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">      <probing privatePath="..\bin"/>      <dependentAssembly>        <assemblyIdentity name="System.Data.SqlServerCe"        publicKeyToken="89845dcd8080cc91"        culture="neutral" />        <bindingRedirect oldVersion="3.5.1.0"        newVersion="4.0.0.0"/>      </dependentAssembly>    </assemblyBinding>  </runtime>  <system.net>    <defaultProxy useDefaultCredentials="true" />  </system.net></configuration>
  4. Ștergeți toate fișierele SDF în folderele % localappdata% și % AppData% . Pentru mai multe informații, consultați secțiunea "lista de baze de date în CRM".Notă Fișierele SDF care au fost create în SQL Server CE 3,5 sunt incompatibile cu SQL Server CE 4,0.

Avertisment

După ce faceți upgrade de la SQL Server CE 3,5 la SQL Server CE 4,0, este posibil să vă confruntați cu o scădere a performanței prima dată când rulați Microsoft Dynamics CRM. Acest comportament se produce deoarece Microsoft Dynamics CRM trebuie să creeze din nou toate cache-ul. Unele memorii cache sunt afectate de dimensiunea inboxului.

Pașii de verificare

Pentru a verifica dacă ați aplicat corect rezoluția, urmați acești pași:

  1. Porniți Outlook după ce efectuați toți pașii de mai sus din secțiunea "Rezolvare".

  2. Asigurați-vă că insertul Microsoft Dynamics CRM pornește corect.

  3. Porniți instrumentul proces Explorer. Pentru a descărca procesul Explorer, vizitați următorul site Web Microsoft:

    http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

  4. Găsiți procesul Outlook. exe , apoi faceți dublu clic pe acesta.

  5. Selectați fila asamblări .net , apoi extindeți AppDomain: SharedDomain dacă nu este extinsă deja.

  6. Găsiți System. data. SqlServerCe în listă. Asigurați-vă că calea conține următoarea versiune de SQL Server CE: C:\windows\assembly\ GAC_MSIL \System.Data.SqlServerCe\4.0.Notă Dacă calea conține SQL Server CE 3.5.1.0, redirecționarea asamblării nu va funcționa.

Listă de baze de date în CRM

  • %LocalAppData%\Microsoft\MSCRM\Client

    • CrmCache. sdfNotă acest fișier conține cache-ul de platformă non-metadate.

    • {GUID} [True | false]. sdfNotă acest fișier conține stocare internă MAPI Store.

    Notă Pot exista mai multe fișiere de acest tip pentru utilizare offline și online.

  • %AppData%\Microsoft\MSCRM\Client

    • EmailCache. sdfNotă acest fișier conține mapări între elementele CRM și MAPI.

    • OutlookSyncCache. sdf Notă acest fișier conține starea internă pentru sincronizare.

Pentru a utiliza redirecționarea folderelor în Microsoft Dynamics CRM, trebuie să utilizați căi UNC (convenție universală de denumire).

Stare

Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.

Mai multe informații

Pentru mai multe informații despre terminologia actualizării software-ului, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

824684 Descrierea terminologiei standard care este utilizată pentru a descrie actualizările de software MicrosoftPentru mai multe informații despre Microsoft Business Solutions CRM software-ul de remediere rapidă și actualizare pachet terminologie, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

887283 Pachetul de remediere rapidă și actualizare a pachetelor de denumire pentru Microsoft Business Solutions CRM

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×