Simptome
Să presupunem că utilizați serviciul de raportare Microsoft SQL Server 2016 pentru a crea un abonament și configurați-l pentru a genera un raport ca atașare PDF. După ce se execută abonamentul, primiți atașarea de e-mail. Cu toate acestea, atașarea nu este recunoscută ca fișier PDF de către câțiva clienți de e-mail.
Cauză
Această problemă apare în raportarea serviciului 2016, deoarece tipul de conținut MIME din mesajul de e-mail este setat la tipul de aplicație/octet-flux în locul tipului de aplicație/PDF .
Rezolvare
Această remediere pentru această problemă este inclusă în actualizarea cumulativă 3 pentru SQL Server 2016 Service Pack 1.
Fiecare compilare nouă pentru SQL Server 2016 conține toate remedierile rapide și toate remedierile de securitate care au fost incluse în compilarea anterioară. Vă recomandăm să instalați cea mai recentă versiune pentru SQL Server 2016.
Stare
Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.
Referințe
Aflați despre terminologia pe care o utilizează Microsoft pentru a descrie actualizările de software.