Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Primiți unul dintre următoarele mesaje de eroare atunci când lucrați cu rapoarte în Portalul de business, în funcție de ceea ce utilizați: Microsoft Dynamics GP 9.0 sau Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Atunci când faceți clic pe Gestionare catalograpoarte, primiți următorul mesaj de eroare:

Eroare server în aplicația "/".
-------------------------------------------------------------------------------- valoare



a fost fie prea mare, fie prea mică pentru un int16.


Descriere: A apărut o excepție netratată în timpul executării solicitării web curente. Examinați urmărirea stivei pentru mai multe informații despre eroare și locul din care provine codul.



Detalii excepție: System.OverflowException: Valoarea a fost fie prea mare, fie prea mică pentru un int16.



Eroare sursă:



A fost generată o excepție netratată în timpul executării solicitării web curente. Informațiile cu privire la originea și locația excepțiilor pot fi identificate utilizând trasarea stivei de excepții de mai jos.



Urmărire stivă:




[DepășireExceptare: Valoarea a fost fie prea mare, fie prea mică pentru o valoare Int16.] System.Int16.Parse(șiruri, Stil NumberStyles, furnizor IFormatProvider) +129 Microsoft.BusinessPortal.ReportsPages.VS.ReportRolesAssignments.FillRoles() +186 Microsoft.BusinessPortal.ReportsPages.VS.ReportRolesAssignments.RoleRptID_TextChanged(Object sender, EventArgs e) +32 System.Web.UI.WebControls.TextBox.OnTextChanged(EventArgs e) +108 System.Web.UI.WebControls.TextBox.Sysfoi. Web.UI.IPostBackDataHandler.RaisePostDataChangedEvent() +26 System.Web.UI.Page.RaiseChangedEvents() +115 System.Web.UI.Page.ProcessRequestMain() +1099 -------------------------------------------------------------------------------- Informații despre








versiune: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET Versiunea:1.1.4322.2032

Microsoft Dynamics SL

Atunci când remiteți un raport, primiți următorul mesaj de eroare:

SubmitReportRequest nu a reușit. Valoarea a fost fie prea mare, fie prea mică pentru un int16.

Cauză

Această problemă apare din unul dintre motivele următoare, în funcție de utilizarea Microsoft Dynamics GP 9.0 sau Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Câmpul DEX_ROW_ID din tabelul ReportCatalog are o valoare mai mare decât valoarea maximă permisă de 32767.

Microsoft Dynamics SL

Tabelul ReportRequest utilizat de Report Scheduler include câmpul APPSrvRequest ID. Câmpul AppSrvRequest ID are o valoare mai mare decât valoarea maximă permisă de 32767.

Rezolvare

Pentru a rezolva această problemă, urmați procedura corespunzătoare, în funcție de utilizarea Microsoft Dynamics GP 9.0 sau Microsoft Dynamics SL 6.5.

Microsoft Dynamics GP

Reinițializarea DEX_ROW_ID câmp. Pentru a face acest lucru, urmați acești pași:

  1. Urmați pasul corespunzător, în funcție de utilizarea sau Microsoft SQL Server SQL Server Desktop Engine (numit și MSDE 2000):

    • Dacă utilizați 2000 Microsoft SQL Server, porniți Analizorul SQL interogare. Pentru a face acest lucru, faceți clicpe Start ,indicați spre Programe , indicați spre Microsoft SQL Server, apoi faceți clic pe Analizor interogare.

    • Dacă utilizați Microsoft SQL Server 2005, porniți SQL Server Management Studio. Pentru a face acest lucru, facețiclic pe Start ,indicați spre Programe , indicați spre Microsoft SQL Server 2005, apoi faceți clic pe SQL ServerManagement Studio.

    • Dacă utilizați MSDE 2000, porniți Consola administratorului de asistență. Pentru a face acest lucru, faceți clicpe Start , indicați sprePrograme , indicați spre Consolă administrator Microsoft, apoi faceți clic pe Consolă administrator de asistență.

  2. Rulați următoarea ins declarație pentru baza de date a firmei.

    DBCC CHECKIDENT ('ReportCatalog', RESEED, 1)
  3. Goliți tabelul ReportCatalog utilizând analizorul SQL interogare sau un SQL Server Management Studio. Serviciul de integrare FRx va repopula tabelul cu valoarea corectă în DEX_ROW_ID date. Pentru a face acest lucru, rulați următoarea declarație în baza de date a firmei.

    DELETE AppSrvRequest

Microsoft Dynamics SL

Resetați câmpul APPSrvRequest ID. Pentru a face acest lucru, urmați acești pași:

  1. Urmați pasul corespunzător, în funcție de utilizarea sau Microsoft SQL Server SQL Server Desktop Engine (numit și MSDE 2000):

    • Dacă utilizați 2000 Microsoft SQL Server, porniți Analizorul SQL interogare. Pentru a face acest lucru, faceți clicpe Start ,indicați spre Programe , indicați spre Microsoft SQL Server, apoi faceți clic pe Analizor interogare.

    • Dacă utilizați Microsoft SQL Server 2005, porniți SQL Server Management Studio. Pentru a face acest lucru, facețiclic pe Start ,indicați spre Programe , indicați spre Microsoft SQL Server 2005, apoi faceți clic pe SQL Server Management Studio.

    • Dacă utilizați MSDE 2000, porniți Consola administratorului de asistență. Pentru a face acest lucru, faceți clicpe Start , indicați sprePrograme , indicați spre Consolă administrator Microsoft, apoi faceți clic pe Consolă administrator de asistență.

  2. Rulați următoarea ins declarație pentru baza de date de sistem.

    Delete from AppsrvRequest
    Delete from Scheduler
    DBCC CHECKIDENT('AppSrvRequest',RESEED, 0)

    Notă Dacă urmați acești pași se șterg toate solicitările planificate. Trebuie să creați din nou solicitările planificate.

  3. Goliți tabelul ReportCatalog utilizând analizorul SQL interogare sau un SQL Server Management Studio. Serviciul de integrare FRx va repopula tabelul cu valoarea corectă în câmpul ID AppSrvRequest. Pentru a face acest lucru, rulați următoarea declarație în baza de date a firmei.

    DELETE ReportCatalog

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×