Se aplică la
Dynamics CRM 4.0

Simptome

Atunci când încercați să imprimați un raport în Microsoft Dynamics CRM 4,0, primiți următorul mesaj de eroare:

Nu se poate încărca controlul imprimare client.

Această problemă apare dacă instalați actualizarea pentru SQL Server 2005 Service Pack 2 general Distribution Release (GDR). Pentru mai multe informații despre actualizarea pentru SQL Server 2005 Service Pack 2 GDR, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

954606 MS08-052: Descrierea actualizării de securitate pentru GDI+ pentru SQL Server 2005 Service Pack 2 GDR: 9 septembrie 2008

Cauză

Această problemă apare deoarece actualizarea pentru SQL Server 2005 Service Pack 2 GDR actualizează numărul de versiune al clasei RSClientPrint. Prin urmare, controlul ReportViewer trebuie, de asemenea, să fie actualizat.

Rezolvare

Pentru a rezolva această problemă, utilizați una dintre următoarele metode:

  • Instalare raport Viewer redistributed 2005 Service Pack 1. Pentru a obține vizualizator raport redistributed 2005 Service Pack 1, vizitați următorul site Web Microsoft:

    http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&displaylang=en

  • Instalați pachetul de actualizare cumulativă 9 pentru SQL Server 2005 Service Pack 2. Pentru mai multe informații despre pachetul de actualizare cumulativă 9 pentru SQL Server 2005 Service Pack 2, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

    953752 Pachetul de actualizare cumulativă 9 pentru SQL Server 2005 Service Pack 2   Dacă primiți în continuare mesajul de eroare menționat în secțiunea simptome după ce instalați pachetul de actualizare cumulativă 9, ștergeți clasa RSClientPrint . Pentru a face acest lucru, urmați acești pași:

    1. Porniți Windows Internet Explorer.

    2. În meniul Instrumente, faceți clic pe Opțiuni Internet.

    3. Urmați Pasul corespunzător:

      • În Windows Internet Explorer 7, faceți clic pe Setări în zona istoric navigare , apoi faceți clic pe Vizualizare obiecte.

      • În Microsoft Internet Explorer 6, faceți clic pe Setări în zona fișiere Internet temporare , apoi faceți clic pe Vizualizare obiecte.

    4. Faceți clic dreapta pe clasa RSClientPrint, apoi faceți clic pe Eliminare.

Referințe

Pentru mai multe informații, vizitați următorul site Web Microsoft:

http://blogs.msdn.com/mariae/

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.