Acest articol se aplică la Microsoft Dynamics NAV 5.0 pentru toate țările și toate limbi regionale.
Simptome
Atunci când deschideți un Microsoft Dynamics NAV 4. x bazei de date în Microsoft Dynamics NAV 5. x, primiți un mesaj de eroare asemănător cu următorul mesaj de eroare:
Nu aveți permisiunea de a modifica tabelul TableName .
Notă Substituentul TableName reprezintă numele de tabel.
Această problemă apare dacă următoarele condiții sunt adevărate:-
Proprietatea grupat pe cheie primară se modifică pentru a Da pentru toate tabelele.
-
Baza de date se face upgrade la Microsoft Dynamics NAV 5.0.
Cauza
Această problemă apare deoarece baza de date conține obiecte pentru care licența curent nu are permisiunile.
Soluție
Pentru a rezolva această problemă, urmați acești pași:
-
Copierea de rezervă a Microsoft Dynamics NAV 4. x bazei de date.
-
Creați o bază de date nouă în Microsoft Dynamics NAV 5. x.
-
Restaurare backup.
Rezolvare
Un hotfix acceptat este acum disponibil de la Microsoft. Remedierea rapidă corectează problema descrisă în acest articol. Aplicați remedierea rapidă numai pentru sistemele care întâmpină această problemă anume.
Pentru a rezolva imediat problema, contactaţi asistenţa tehnică pentru Microsoft Dynamics și produse asociate pentru a obține remedierea rapidă. Puteți face log on la site-ul Microsoft Dynamics și creați o nouă solicitare de suport. Pentru aceasta, vizitați următorul site Web Microsoft:https://mbs.microsoft.com/support/newstart.aspxDe asemenea, posibilitatea să contactați asistența tehnică pentru Microsoft Dynamics și produse asociate prin telefon la (888) 477-7877. Notă În cazuri speciale, costurile implicate de obicei pentru asistență apeluri pot fi anulate dacă un specialist în asistență tehnică pentru Microsoft Dynamics și produse asociate stabilește că o anumită actualizare va rezolva problema. Se vor aplica costurile uzuale de asistență pentru orice întrebări suplimentare de asistență și pentru probleme ce nu fac obiectul actualizării în cauză.
Cerințe preliminare
Trebuie să aveți Microsoft Dynamics NAV 4.0 instalat pentru a aplica această remediere rapidă.
Eliminare informaţii
Nu se poate elimina această remediere rapidă.
Cerinţă de repornire
Nu trebuie să reporniți computerul după aplicarea acestei remedieri rapide.
Cum se obține remedierea rapidă Microsoft Dynamics NAV sau actualizați fișierele
După ce solicita o remediere rapidă Microsoft Dynamics NAV sau un fișier de actualizare de la asistență tehnică pentru Microsoft Dynamics, va fi trimis un hyperlink pentru a vă într-un e-mail.
Mesajul de poștă electronică va conține un hyperlink și o parolă. Puteţi utiliza hyperlink pentru a descărca remedierea rapidă Microsoft Dynamics NAV sau fișierele de actualizare. Când faceţi clic pe hyperlinkul, se deschide caseta de dialog Descărcare fișier – avertisment de securitate . Apoi, vi se solicită să se execute, pentru a salva sau a anula descărcarea. Dacă faceți clic pe executare, fișierele începe descărcarea și procesul de extragere. Trebuie să specificați un folder pentru fișiere noi, și apoi tastați parola. Dacă faceți clic pe Salvare, trebuie să specificați o cale pentru a salva fişierul comprimat. Când deschideți fișierul pe care l-ați salvat, vi se solicită să specificați calea pentru fișierele. Apoi, trebuie să furnizați parola furnizate în poșta electronică. Dacă faceți clic pe Revocare, se oprește procesul de descărcare.Cum se instalează o remediere rapidă Microsoft Dynamics NAV sau un fișier de actualizare
Microsoft Dynamics NAV platformă remedierile rapide și actualizări sunt făcute disponibile ca fișiere singur. Pentru a instala o remediere rapidă Microsoft Dynamics NAV sau o actualizare, trebuie să înlocuiți fișierele de instalare Microsoft Dynamics NAV existente cu remedierea rapidă sau fișierele de actualizare. Pentru aceasta, urmați acești pași. Dacă aveți Microsoft Dynamics NAV Application Server instalat, trebuie să înlocuiți următoarele fișiere în Microsoft Dynamics NAV Application Server de instalare.
Nume de fișier |
Versiune fișier |
Dimensiune fișier |
Data |
Ora |
Platformă |
---|---|---|---|---|---|
Fin.exe |
5.0.24632.0 |
10,737,104 |
23-May-2007 |
01:30 |
x86 |
Finsql.exe |
5.0.24632.0 |
10,794,448 |
23-May-2007 |
01:30 |
x86 |
Pentru a înlocui fişierele, urmați acești pași:
-
Nu toate Microsoft Dynamics NAV activitate.
-
Găsiți directorul de instalare a driverului Microsoft Dynamics NAV conectivitate ODBC (Open Database). Microsoft Dynamics NAV ODBC driverul este instalat, de obicei în următorul Director:
C:\Program Files\Common Files\Navision\NODBC\
-
Copiați fișierele pe care l-ați descărcat.
-
Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV ODBC driver.
-
Faceți clic pe Da pentru a suprascrie fișierele din directorul.
Stare
Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea "Se aplică la".
Mai multe informații
Pentru mai multe informaţii, faceţi clic pe următorul număr de articol pentru a vedea articolul în baza de cunoştinţe Microsoft:
824684 Descrierea terminologiei standard care este utilizat pentru a descrie Microsoft