Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Când terminați instalarea portalului de business în Microsoft Dynamics GP sau în Microsoft Dynamics SL și porniți apoi Portalul de business, primiți următorul mesaj de eroare în diverse părți web care sunt afișate:

Eroare server în aplicația "/". Acces refuzat la "Microsoft Dynamics". Nu s-a reușit pornirea monitorizării modificărilor la fișier. Descriere: A apărut o excepție netratată în timpul executării solicitării web curente. Examinați urmărirea stivei pentru mai multe informații despre eroare și locul din care provine codul. Detalii excepție: System.Web.HttpException: Acces refuzat la "Microsoft Dynamics". Nu s-a reușit pornirea monitorizării modificărilor la fișier.

Cauză

Microsoft ASP.NET necesită următoarele permisiuni pentru contul de ASP.NET de rețea și pentru contul de serviciu de rețea. Aceste permisiuni sunt necesare în folderul rădăcină al site-ului web și în fiecare folder din directorul virtual:

  • Citiți

  • Execută

  • Listă

ASP.NET necesită aceste permisiuni pentru a accesa fișierele și a monitoriza modificările fișierelor.

Rezolvare

Pentru a rezolva această problemă, utilizați una dintre metodele următoare.

Metoda 1

  1. Acordți permisiunile necesare contului ASP.NET proces nou. Pentru a face acest lucru, urmați acești pași:

    1. În Windows Explorer, găsiți folderul de instalare pentru aplicație. Sau găsiți folderul pentru directorul virtual. Următoarea este locația implicită a directorului virtual Portal firmă:

      C:\Program Files\Microsoft Dynamics\Business Portal

    2. Faceți clic dreapta pe folder, apoi faceți clic pe Proprietăți.

    3. Pe fila Securitate, faceți clic pe Adăugare.

    4. În câmpul Introduceți numele obiectelor de selectat, tastați următoarele, apoi faceți clic pe OK:

      Notă ComputerName\ASPNET Înlocuiți substituentul ComputerName cu numele computerului care rulează Business Portal.

    5. În zona Permisiuni, activați următoarele opțiuni în lista Se permit, apoi faceți clic pe OK:

      • Citirea & Execute

      • List Folder Contents

      • Citiți

    6. Faceți clic pe Salvare pentru a închide fereastra, apoi reporniți Internet Information Services (IIS).

  2. Acordți permisiunile necesare pentru contul serviciu de rețea. Pentru a face acest lucru, urmați acești pași:

    1. În Windows Explorer, găsiți folderul de aplicații pentru site-ul web. Sau găsiți folderul pentru directorul virtual. Următoarea este locația implicită a directorului virtual Portal firmă:

      C:\Program Files\Microsoft Dynamics\Business Portal

    2. Faceți clic dreapta pe folder, apoi faceți clic pe Proprietăți.

    3. Pe fila Securitate, faceți clic pe Adăugare.

    4. În câmpul Introduceți numele obiectelor de selectat, tastați Serviciu rețea.

      Notă Acest cont de utilizator este un cont de utilizator local.

    5. În zona Permisiuni, activați următoarele opțiuni în lista Se permit, apoi faceți clic pe OK:

      • Citirea & Execute

      • List Folder Contents

      • Citiți

    6. Faceți clic pe Salvare pentru a închide fereastra, apoi reporniți IIS.

Metoda 2

Asigurați-vă că numele de foldere din calea site-ului web conțin mai puțin de nouă caractere.

Note

  • Pentru a determina numele folderelor din cale, urmați acești pași:

    1. În IIS Manager, faceți clic dreapta pe site-ul web pe care este instalat Portalul de business, apoi faceți clic pe Proprietăți.

    2. Faceți clic pe fila Director pornire, apoi notați numele de foldere ale căii din caseta Cale locală.

  • Dacă redenumiți un folder astfel încât numele folderului să conțină mai puțin de nouă caractere, trebuie să efectuați aceeași modificare în IIS pentru site-ul web. După ce efectuați modificarea, opriți-vă și porniți IIS.

Mai multe informații

Pentru mai multe informații, faceți clic pe următoarele numere de articol pentru a vizualiza articolele din Baza de cunoștințe Microsoft:

317955 Mesajul de eroare "Nu s-a reușit monitorizarea modificărilor directorului" atunci când navigați la o ASP.NET de telefon

316721 Mesajul de eroare "Nu s-a reușit monitorizarea modificărilor directorului" atunci când navigați ASP.NET pagină

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×