Se aplică la
Microsoft Dynamics AX 4.0 Microsoft Dynamics AX 3.0 Microsoft Dynamics NAV 5.0

Simptome

Atunci când porniți Microsoft FRx Report Server, primiți următorul mesaj de eroare:

Eroarea 3709 - Conexiunea nu se poate utiliza pentru a efectua această operațiune

Cauză

Această problemă apare din unul dintre următoarele motive.

Cauza 1

Stațiile de lucru nu au aceeași versiune de Microsoft FRx Designer sau Microsoft FRx Report Server. Consultați Rezoluția 1 din secțiunea "Rezoluție".

Cauza 2

Folderele Microsoft FRx necesare au permisiuni de utilizator incorecte. Consultați Rezoluția 2 din secțiunea "Rezoluție".

Cauza 3

Blocul component este deteriorat, setul de specificații este deteriorat sau fișierele .f32 sunt deteriorate. Consultați Rezoluția 3 din secțiunea "Rezoluție".

Cauza 4

Fișierul FRxQue32.mdb este deteriorat. Consultați Rezoluția 4 din secțiunea "Rezoluție".

Rezolvare

Soluţia 1

Pentru a rezolva această problemă, verificați versiunea de Microsoft FRx pe fiecare computer care are cod Microsoft FRx. Pentru aceasta, urmați pașii de mai jos.

Designer Microsoft FRx

  1. Faceți clic pe Start, pe Căutare, apoi tastați FRx32.exe.

  2. Faceți clic dreapta peFRx32.exe, apoi faceți clic pe Proprietăți.

  3. Faceți clic pe fila Versiune , apoi notați versiunea fișierului.

Server de rapoarte Microsoft FRx

  1. Faceți clic pe Start, pe Căutare, apoi tastați RptSvr32.exe.

  2. Faceți clic dreapta peRptSvr32.exe, apoi faceți clic pe Proprietăți.

  3. Faceți clic pe fila Versiune , apoi notați versiunea fișierului.

Aceste versiuni de fișiere trebuie să fie identice pe fiecare stație de lucru din rețea. Dacă versiunile de fișier nu sunt identice, trebuie să aplicați pachetul Service Pack corespunzător aplicației care nu are aceeași versiune de fișier.De asemenea, puteți actualiza la cel mai recent pachet Service Pack. Pentru mai multe informații, vizitați unul dintre următoarele site-uri web Microsoft, în funcție de locul în care sunteți partener sau client.Parteneri

https://mbs.microsoft.com/partnersource/products/GreatPlains/downloads/servicepackClienţii noştri

https://mbs.microsoft.com/customersource/support/downloads/servicepacks

Soluţia 2

Setarea permisiunilor corecte

Setați permisiunile corecte pentru toate folderele pe care Microsoft FRx trebuie să le acceseze. Pentru aceasta, urmați pașii de mai jos.

  1. Conectați-vă la computer ca administrator local sau ca administrator de domeniu.

  2. Faceți clic pe Start, pe Căutare, apoi pe Toate fișierele și folderele.

  3. Căutați următoarele foldere:

    • Folderul de cod FRx. În mod implicit, calea este C:\Program Files\FRx Software

    • Folderul IO_Data .

    • Folderul SysData .

    • Folderul Temp .

    • Folderul MSInfo .

    • Folderul System32 .

  4. Pentru fiecare folder listat în pasul 3, urmați acești pași:

    1. Faceți clic dreapta pe folder, apoi faceți clic pe Proprietăți.

    2. În caseta de dialog Proprietăți , faceți clic pe fila Securitate .

    3. Asigurați-vă că utilizatorul Administrator și toți utilizatorii Microsoft FRx au următoarele permisiuni:

      • Pentru folderul de cod FRx: Control total

      • Pentru folderul IO_Data : Control total

      • Pentru folderul SysData : Control total

      • Pentru folderul Temp : Control total

      • Pentru folderul MSInfo : Control total

      • Pentru folderul System32 : minimum "Citire & Executare"

    4. Dacă există utilizatori configurați în grupuri de securitate diferite, asigurați-vă că acei utilizatori au aceleași permisiuni ca grupurile din pasul 4c.

Soluţia 3

Pentru a rezolva această problemă, corectați blocul component, corectați setul de specificații sau corectați fișierele .f32. Pentru a face acest lucru, urmați acești pași:

  1. Dacă eroarea este limitată la un catalog, un rând, o coloană sau un singur arbore, creați din nou acel bloc component.

  2. Dacă eroarea apare pentru mai multe blocuri componente, creați un set nou de specificații care conține un nou fișier .f32. Pentru a face acest lucru, urmați acești pași:

    1. Porniți Microsoft FRx, faceți clic pe Firmă, apoi pe Seturi specificații.

    2. Selectați setul de specificații utilizat de firmă.

    3. Faceți clic pe Export, apoi selectați toate elementele de pe fiecare filă.

    4. Faceți clic din nou pe Export . Se creează un fișier .tdb.

    5. Pentru a crea un set nou de specificații, faceți clic pe Nou, apoi tastați un nume nou de fișier pentru fișierul .f32 în caseta Locație .

    6. Salvați noul set de specificații.

    7. Faceți clic pe Import, apoi selectați fișierul .tdb care a fost creat în pasul 2d anterior în această secțiune.

    8. Salvați setul de specificații.

    9. Faceți clic pe Firmă, pe Informații, apoi selectați noul set de specificații din lista Set specificații . Salvați înregistrarea firmei.

    10. Setați firma ca firmă implicită.

Rezoluție 4

Pentru a rezolva această problemă, înlocuiți fișierul FRxQue32.mdb. Pentru a face acest lucru, urmați acești pași:

  1. Oprire monitor coadă Microsoft FRx. Pentru a face acest lucru, faceți clic pe butonul Oprire/Închidere .

  2. Redenumiți fișierul FRxQue32.mdb în directorul coadă Microsoft FRx. De exemplu, redenumiți fișierul ca FRxQue32.old.

  3. Faceți o copie a fișierului FRxQue32.tpl, apoi redenumiți copia FRxQue32.mdb. Fișierul FRxQue32.tpl se află în directorul SysData.

  4. Faceți dublu clic pe fișierul RptSvr32.exe pentru a reporni Microsoft FRx Queue Monitor. Pentru a găsi fișierul RptSvr32.exe, urmați acești pași:

    1. Faceți clic dreapta pe Start, apoi faceți clic pe Explorați toți utilizatorii.

    2. Găsiți folderul de cod Microsoft FRx Report Server. În mod implicit, calea este după cum urmează:

      C:\Program Files\FRx Software\FRx 6.7 Report ServerRptSvr32.exe fișier se află în acest folder.

    Notă Este posibil să vă confruntați cu următoarea problemă:

    • Files care au o extensie de nume de fișier .ldb sau o extensie de nume de fișier .lck rămân în folderul Microsoft FRx SysData chiar și atunci când niciun utilizator nu este conectat la Microsoft FRx.

    Dacă întâmpinați această problemă, blocarea oportunistă poate deteriora baza de date Microsoft Jet. Această problemă poate apărea dacă serverul care găzduiește folderul Microsoft FRx SysData rulează oricare dintre următoarele programe:

    • Microsoft Windows Server 2003 sau Windows Server 2003 Terminal Server

    • Microsoft Windows 2000 Server sau Windows 2000 Server Terminal Services

    • Windows Server 2003 Terminal Server împreună cu Citrix

    Pentru a împiedica blocarea oportunistă să de corupă baza de date Microsoft Jet, instalați cel mai recent pachet Service Pack Windows Server. Totuși, dacă această problemă continuă să apară după ce instalați cel mai recent Windows Server pachet Service Pack, dezactivați blocarea oportunistă. Pentru mai multe informații despre dezactivarea blocării oportuniste, faceți clic pe următoarele numere de articol pentru a vizualiza articolele din Baza de cunoștințe Microsoft:

    296264 Configurarea blocării oportuniste în Windows

    129202 PC Ext: Explicarea blocării oportuniste în Windows NTProdusele de la terți despre care discută acest articol sunt fabricate de firme independente de Microsoft. Microsoft nu garantează în niciun fel, implicit sau în alt mod, funcționarea sau fiabilitatea acestor produse.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.