Simptome
Aveți un computer Windows Server 2008 sau Windows Server 2003 R2 care are Microsoft Services pentru rețea File System (MSNFS) instalat și care exportă partajări NFS NFS clienților. Când excesive solicitări I/O sunt generate de clienții NFS pe partajări NFS, pot apărea următoarele probleme:
-
Dacă utilizați capturii de rețea, se poate afla că dimensiunea ferestrei pentru o conexiune TCP este redus la 0, care este numit o condiție TCPZeroWindow.
-
Dacă încercați să accesați partajări NFS, veți găsi erorilor I/O pentru conexiune corespunzătoare care seamănă cu următorul:
Eroare de intrare/ieșire
-
Conexiunea NFS nu reporniți așa cum vă așteptați. În cele din urmă, toate NFS conexiuni la serverul merge în aceeași stare.
Cauza
Această problemă se produce deoarece driverul remote procedure call (RPC) reprezentare de date externe (Rpcxdr.sys) poate fi repornit fiabil conexiunile TCP atunci când există mai multe solicitări I/O.
Rezolvare
Informații despre remedierea rapidă pentru Windows Server 2003
O remediere rapidă compatibilă este disponibilă de la Microsoft. Cu toate acestea, această remediere rapidă este destinată pentru a corecta doar problema descrisă în acest articol. Aplicați această remediere rapidă numai pentru sistemele care întâmpină problema descrisă în acest articol. Această remediere rapidă poate să necesite testare suplimentară. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să aşteptaţi următoarea actualizare software care conţine această remediere rapidă.
Dacă remedierea rapidă este disponibilă pentru descărcare, există o secțiune "Descărcare remediere rapidă disponibilă" în partea de sus a acestui articol din baza de cunoștințe. Dacă nu apare această secţiune, contactaţi Microsoft Client Service și suport pentru a obţine remedierea rapidă. Notă Dacă se produc probleme suplimentare sau este necesară depanarea, poate fi necesar să creați o solicitare de asistenţă separată. Costurile de obicei pentru suport se vor aplica pentru sprijin suplimentar, întrebări și probleme care nu sunt specifice pentru această remediere rapidă . Pentru o listă completă de numere de telefon de asistență și relații Microsoft sau pentru a crea o solicitare de asistenţă separată, vizitați următorul site Web Microsoft:Notă Formularul "Descărcare remediere rapidă disponibilă" afişează limbile pentru care este disponibilă remedierea rapidă. Dacă nu vedeți limba dvs., înseamnă că o remediere rapidă nu este disponibilă pentru respectiva limbă.
Cerințe preliminare
Cerințe preliminare.
Cerinţă de repornire
Nu trebuie să reporniți computerul după aplicarea acestei remedieri rapide.
Informații despre înlocuirea remedierilor rapide
Această remediere rapidă nu înlocuiește nicio altă remediere rapidă.
Informații despre registry
Pentru a utiliza această remediere rapidă, nu trebuie să efectuați modificări în registry.
Informații despre fișier
Versiunea în limba engleză a acestei remedieri rapide are atributele de fişier (sau atribute de fişier mai recente) enumerate în următorul tabel. Datele şi orele acestor fişiere sunt exprimate în listă în ora universală (UTC). Când vizualizaţi informaţiile despre fișier, acesta este convertit la ora locală. Pentru a găsi diferenţa dintre UTC şi ora locală, utilizaţi fila Fusul orar în elementul de Data şi ora în Panoul de Control.