Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Este posibil să vă confruntați cu un comportament neașteptat atunci când Microsoft FRx încearcă să acceseze unul sau mai multe dintre următoarele fișiere bază de date FRx:

  • Frxsys32.mdb

  • Frxque32.mdb

  • Fișiere care au o extensie de nume de fișier .f32

De exemplu, este posibil să apară următoarele simptome:

  • Primiți unul dintre următoarele mesaje de eroare.

    Mesaj de eroare 1

    Eroare la momentul rulrii '-2147467259 (80004005)': Format de bază de date nerecunoscut.

    Mesaj de eroare 2

    Eroare la momentul rulrii "3343": Format bază de date nerecunoscut.

    Mesaj de eroare 3

    Eroarea 3709. Imposibil de utilizat conexiunea pentru a efectua această operațiune. Este închis sau nevalid în acest context.

  • Este posibil ca FRx Designer să nu pornească. Atunci când încercați să porniți FRx Designer, ecranul de pornire apare pentru scurt timp. Apoi dispare.

  • Atunci când generați un raport în Microsoft FRx Report Designer, primiți următorul mesaj de eroare:

    Motorul de baze de date Microsoft Jet nu poate găsi tabelul de intrare sau interogarea "Utilizatori activi". Asigurați-vă că există și că este ortografiat corect.

Atunci când vă confruntați cu aceste simptome, nu mai puteți utiliza Microsoft FRx. După ce efectuați o operațiune de compactare și reparare în baza de date, Microsoft FRx funcționează așa cum vă așteptați. Totuși, este posibil să primiți același mesaj de eroare din nou pentru o perioadă scurtă de timp mai târziu.

Cauză

Această problemă poate apărea dacă bazele de date Microsoft Jet care sunt utilizate de Microsoft FRx sunt deteriorate. Următoarele probleme pot provoca deteriorarea bazei de date:

  • Fișiere de sistem învechite

  • Pachete Service Pack Microsoft FRx nepotrivite

  • Probleme de conectivitate la rețea

  • Probleme cu setările de mediu

Rezolvare

Pentru a preveni această problemă, utilizați una sau mai multe dintre următoarele metode, după cum este necesar.

Metoda 1: Efectuați în mod regulat o operațiune de compactare și reparare în baza de date

  1. Porniți Microsoft FRx. Puteți porni Microsoft FRx pe o stație de lucru. Sau, dacă Microsoft FRx este instalat pe un server, puteți porni Microsoft FRx pe server.

  2. Faceți clic pe Fișier, indicați spre Bază de date compactă FRx, apoi faceți clic pe Baza de date set de specificații curente.

  3. Faceți clic pe Da, apoi pe OK când operațiunea se termină.

  4. Faceți clic pe Fișier, indicați spre Compactare bază de date FRx, apoi faceți clic pe Bază de date de sistem FRx.

  5. Faceți clic pe Da, apoi pe OK când operațiunea se termină.

  6. Faceți clic pe Fișier, indicați spre Bază de date compactă FRx, apoi faceți clic pe Bază de date listă de așteptare FRx.

    Notă Baza de date coadă FRx va fi disponibilă numai dacă este instalat serverul de rapoarte FRx.

  7. Faceți clic pe Da, apoi pe OK când operațiunea se termină.

Dacă primiți în continuare unul dintre mesajele de eroare menționate în secțiunea "Simptome", efectuați Metoda 2.

Metoda 2: Asigurați-vă că toate stațiile de lucru care au instalat FRx Designer sunt actualizate

Urmați acești pași pe fiecare stație de lucru care are FRx Designer instalat:

  1. Utilizați Microsoft Update pentru a instala cel mai recent pachet Service Pack Microsoft Windows. Pentru mai multe informații despre Microsoft Update, vizitați următorul site Web Microsoft:

    http://update.microsoft.com

  2. Obțineți și instalați cel mai recent pachet Service Pack Microsoft Jet. Pentru a obține pachete Service Pack Microsoft Jet, vizitați următorul site Web Microsoft:

    http://www.microsoft.com/downloads Pentru a găsi cel mai recent pachet Service Pack Microsoft Jet, faceți clic pe Toate descărcările în lista Căutare , tastați Actualizări Jet, apoi faceți clic pe Salt.

  3. Configurați excluderile din programele antivirus și antispyware pentru a împiedica aceste programe să citească folderul FRx SysData.

    Pentru informații despre cum să configurați excluderile, consultați instrucțiunile de configurare a programelor antivirus și antispyware.

    Notă Atunci când instalați Microsoft FRx, asigurați-vă că programele antivirus și antispyware sunt dezactivate. Acest lucru va împiedica coruperea sau blocarea fișierelor de instalare în timpul instalării.

Dacă primiți în continuare unul dintre mesajele de eroare menționate în secțiunea "Simptome", efectuați Metoda 3.

Metoda 3: Dezactivați blocarea oportunistă pe serverul care găzduiește folderul FRx SysData

Dacă vă confruntați cu următorul comportament, blocarea oportunistă poate cauza deteriorarea bazei de date Microsoft Jet:

  • După ce efectuați Metoda 1 și Metoda 2, continuați să primiți unul dintre mesajele de eroare menționate în secțiunea "Simptome".

  • Fișierele care au extensia de nume de fișier .ldb sau .lck rămân în folderul FRx SysData chiar și atunci când niciun utilizator nu este conectat la FRx.

Acest comportament poate apărea dacă serverul care găzduiește folderul FRx SysData rulează oricare dintre următoarele programe:

  • Microsoft Windows Server 2003 sau Windows Server 2003 Terminal Server

  • Microsoft Windows 2000 Server sau Windows 2000 Server Terminal Services

  • Citrix Server

Pentru a împiedica blocarea oportunistă să cauzeze deteriorarea bazei de date Microsoft Jet, instalați cel mai recent pachet Service Pack Windows Server. Totuși, dacă comportamentul menționat în această secțiune continuă să apară după ce instalați cel mai recent pachet Service Pack Windows Server, dezactivați blocarea oportunistă. Pentru mai multe informații despre dezactivarea blocării oportuniste, faceți clic pe următorul număr de articol pentru a vizualiza articolul în Baza de cunoștințe Microsoft:

296264 Configurarea blocării oportuniste în Windows

Produsele de la terți pe care le prezintă acest articol sunt fabricate de companii independente de Microsoft. Microsoft nu garantează în niciun fel, implicit sau în alt mod, funcționarea sau fiabilitatea acestor produse.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×