Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Acest articol se aplică la Microsoft Dynamics NAV pentru toate țările și toate limbi regionale.

Simptome

Atunci când autorizează un card de credit în Microsoft Dynamics NAV 2009 R2, informații de bază de validare este trimisă către Serviciul Microsoft Dynamics NAV Online și apoi Redirecționat către furnizorul de plată. În această situație, dacă informațiile de validare insuficient plată este trimisă pentru procesul de autorizare, primiți un mesaj de eroare care afirmă nu toate informațiile necesare sunt furnizate cu tranzacția.
De exemplu, este posibil să primiți următorul mesaj de eroare:

Autorizare tranzacții cu cantitatea de # nu a reușit.
Cod de eroare = 22062;
Mesaj = tranzacția a fost refuzat de către furnizorul de plată.


Cauza

Această problemă apare deoarece informațiile de validare care este făcută pentru procesul de autorizare carte de credit este insuficient. Pentru unele furnizori de plată, trebuie să configurați soluția Microsoft Dynamics Online pentru a furniza informații suplimentare de validare. De exemplu, furnizori de plată în Statele Unite necesită să specificați starea deținător de card de credit.

Mai multe informații

Când un card de credit este autorizat în Microsoft Dynamics NAV 2009 R2, informații de bază de validare este trimisă către Serviciul Microsoft Dynamics Online și apoi Redirecționat către furnizorul de plată corespunzătoare. Informații de bază include carte de credit deţinător numele, adresa, țara și cod poștal. Cu toate acestea, cerințele de validare diferă funcție de furnizorul de plată, de tipul de card de credit și cerințele Băncii carte de credit – emitentă.
Înainte să executați procesul de autorizare carte de credit, asigurați-vă că informațiile de bază, cum ar fi numele, adresa, cod poștal, și așa mai departe, este introdus pe cartea de vizită deținătorului cărții de credit. Pentru unele furnizori de plată, trebuie să configuraţi soluția Microsoft Dynamics Online pentru a furniza informații suplimentare de validare. De exemplu, trebuie să specificați starea deținător de card pentru furnizorii de plată în Statele Unite.

Rezolvare

Informații despre remedierea rapidă

Un hotfix acceptat este acum disponibil de la Microsoft. Cu toate acestea, acesta este destinat numai corectării problemei descrise în acest articol. Aplicați-o numai pe sistemele care întâmpină această problemă anume. Această remediere rapidă poate să necesite testare suplimentară. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să așteptați următorul pachet service pack Microsoft Dynamics NAV sau versiunea Microsoft Dynamics NAV următoare, care conține această remediere rapidă.

Notă În cazuri speciale, costurile implicate de obicei pentru asistență apeluri pot fi anulate dacă un specialist în asistență tehnică pentru Microsoft Dynamics și produse asociate stabilește că o anumită actualizare va rezolva problema. Se vor aplica costurile uzuale de asistenţă pentru întrebări suplimentare de asistență și pentru probleme ce nu fac obiectul actualizării în cauză.



Informaţii despre instalare

Microsoft furnizează exemple de programare scop ilustrativ, fără nicio garanţie explicită sau implicită. Aceasta include, dar nu se limitează la, garanţiile implicite de vandabilitate sau de potrivire pentru un anumit scop. Acest articol presupune că sunteţi familiarizat cu limbajul de programare care este prezentat şi cu instrumentele utilizate pentru a crea şi a depana proceduri. Specialiștii în asistență Microsoft pot ajuta la explicarea funcționalității unei anumite proceduri, dar nu vor modifica aceste exemple pentru a furniza funcționalitate suplimentară sau pentru a construi proceduri pentru a răspunde cerințelor dvs. specifice.

Notă Înainte de a instala această remediere rapidă, Verificați că toate Microsoft Navision client utilizatorii au făcut Log off sistemul. Aceasta include utilizatorii de client Microsoft Navision Application Services (NAS). Ar trebui să fie singurul client utilizatorului care este conectat când implementați această remediere rapidă.

Pentru a implementa această remediere rapidă, trebuie să aveți o licență de dezvoltare.

Vă recomandăm că contul de utilizator în fereastra Conectări Windows sau în fereastra Conectări bază de date se atribuie "SUPER" rolul ID-ul. În cazul în care contul de utilizator nu poate fi atribuit ID-ul "SUPER" rolul, trebuie să verificați că contul de utilizator are următoarele permisiuni:

  • Modify permisiunea pentru obiectul care se va schimba.

  • Permisiunea de executare pentru obiectul de sistem obiect ID 5210 și pentru obiectul de sistem obiect ID 9015 .



Notă Nu trebuie să aveți drepturi de la magazine de date decât dacă trebuie să efectuați o reparare de date.

Modificări de cod

Notă Întotdeauna test cod remediază într-un mediu controlat înainte de a aplica remedieri pentru computerele de producție.
Pentru a rezolva această problemă, urmați acești pași:

  1. Asigurați-vă că domeniul County (92) există în tabelul de Contact (5050) și formularul cartea de vizită (5050).

  2. Modificați codul din funcția CreateCreditCardObject în DO Mgt. de integrare plată codeunit (826) după cum urmează:
    Cod existent

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";
    ...

    Cod de înlocuire

    ...CreditCardInfo.StreetAddress := Contact.Address;
    CreditCardInfo.PostalCode := Contact."Post Code";
    CreditCardInfo.City := Contact.City;
    CreditCardInfo.CountryOrRegion := Contact."Country/Region Code";

    // Add the following line.
    CreditCardInfo.StateOrProvince := Contact.County;
    ...

Cerințe preliminare

Trebuie să aveți Microsoft Dynamics NAV 2009 R2 instalat pentru a aplica această remediere rapidă.

Eliminare informaţii

Nu se poate elimina această remediere rapidă.

Stare

Microsoft a confirmat că aceasta este o problemă cu produsele Microsoft enumerate în secţiunea „Se aplică la".

Notă Acesta este un articol "rapid publicat" creat direct în cadrul organizației de asistență Microsoft. Informațiile conținute în acest document sunt furnizate ca răspuns la problemele care apar. Ca rezultat al vitezei în a-l face disponibil, materialele pot include erori tipografice și pot fi revizuite în orice moment, fără notificare. Consultați Termenii de utilizare pentru alte considerații.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×