Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Să luăm în considerare următorul scenariu:

  • Aveți un server de imprimare bazate pe Windows Server 2008.

  • Acest server de imprimare are mulți clienți imprimantă cu Windows Vista.

În acest scenariu, utilizarea memoriei de serviciul Print Spooler creşte în mod semnificativ în timp. De exemplu, această problemă apare când câteva mii de imprimantă clienții trimite lor lucrări de imprimare pentru serverul de imprimare. În cele din urmă, serverul de imprimare devine nu răspunde și trebuie să reporniți serverul să rezolvați această problemă. În funcție de încărcare imprimare, această problemă poate apărea după ce sistemul a funcționat pentru o zi sau mai multe săptămâni.

În plus, când un utilizator încearcă să imprimați documente de pe un computer Windows Vista, activitate de imprimare aleator nu reușește și utilizatorul primește următorul mesaj de eroare:

Windows nu se poate conecta la imprimantă. Serviciul print spooler server nu se execută. Reporniți serviciul spooler pe server sau reporniți computerul server

Cauza

Această problemă se produce din cauza unui pierderi de memorie în serviciul Print Spooler. Serviciul Print Spooler păstrează o coadă de notificare nelimitat client. În plus, serviciul Print Spooler memoriile cache pentru o imprimantă structura mod dezvoltare pentru fiecare identificator de client care este deschis. În combinație, aceste două funcţionalităţi consumă multă memorie, atunci când mulți clienți imprimantă accesa acest server de imprimare.

În plus, cu Windows Vista imprimantă clienții utilizează apeluri asincrone de procedură la distanță (RPC-uri) pentru a regăsi notificări de modificare imprimantă. De aceea, multe asincron RPC-uri sunt programate la multe imprimantă clienții utilizează serverul de imprimare. După numărul total de RPC-uri trimiși atinge limita de 6000, clientul utilizatorul primește mesajul de eroare menționat în secțiunea "simptome".

Rezolvare

Informații despre remedierea rapidă

O remediere rapidă compatibilă este disponibilă de la Microsoft. Cu toate acestea, această remediere rapidă este destinată pentru a corecta doar problema descrisă în acest articol. Aplicați această remediere rapidă numai pentru sistemele care întâmpină această problemă anume. Această remediere rapidă poate să necesite testare suplimentară. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să aşteptaţi următoarea actualizare software care conţine această remediere rapidă.

Dacă remedierea rapidă este disponibilă pentru descărcare, există o secțiune "Descărcare remediere rapidă disponibilă" în partea de sus a acestui articol din baza de cunoștințe. Dacă nu apare această secţiune, contactaţi Microsoft Client Service și suport pentru a obţine remedierea rapidă.

Notă Dacă se produc probleme suplimentare sau este necesară depanarea, poate fi necesar să creați o solicitare de asistenţă separată. Costurile de obicei pentru suport se vor aplica pentru sprijin suplimentar, întrebări și probleme care nu sunt specifice pentru această remediere rapidă . Pentru o listă completă de numere de telefon de asistență și relații Microsoft sau pentru a crea o solicitare de asistenţă separată, vizitați următorul site Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNotă Formularul "Descărcare remediere rapidă disponibilă" afişează limbile pentru care este disponibilă remedierea rapidă. Dacă nu vedeți limba dvs., înseamnă că o remediere rapidă nu este disponibilă pentru respectiva limbă.

Remedieri rapide importante pentru Windows Vista și Windows Server 2008 sunt incluse în aceleași pachete. Cu toate acestea, doar unul dintre aceste produse poate fi listat în pagina "Solicitare remediere rapidă". Pentru a solicita pachetul de remediere rapidă care se aplică pentru Windows Vista și Windows Server 2008, selectați produsul listat pe pagină.

Cerințe preliminare

Nu sunt necesare condiţii preliminare.

Cerinţă de repornire

Trebuie să reporniți computerul după aplicarea acestei remedieri rapide.

Informații despre înlocuirea remedierilor rapide

Această remediere rapidă nu înlocuiește nicio altă remediere rapidă.

Informații despre fișier

Versiunea în limba engleză a acestei remedieri rapide are atributele de fişier (sau atribute de fişier mai recente) enumerate în următorul tabel. Datele şi orele acestor fişiere sunt exprimate în listă în ora universală (UTC). Când vizualizaţi informaţiile despre fișier, acesta este convertit la ora locală. Pentru a găsi diferenţa dintre UTC şi ora locală, utilizaţi fila Fusul orar în elementul de Data şi ora în Panoul de Control.

Windows Server 2008, versiunile x86

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

Spoolsv.exe

6.0.6001.22200

126,976

11-Jun-2008

03:41

x86

Windows Server 2008, versiuni Itanium

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Ramură de servicii

Localspl.dll

6.0.6001.22200

1,617,920

11-Jun-2008

05:36

IA-64

Nu este disponibil

Spoolss.dll

6.0.6001.22200

446,464

11-Jun-2008

05:39

IA-64

Nu este disponibil

Spoolsv.exe

6.0.6001.22200

437,248

11-Jun-2008

04:19

IA-64

Nu este disponibil

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Windows Server 2008, versiunile x64

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Ramură de servicii

Localspl.dll

6.0.6001.22200

788,480

11-Jun-2008

05:50

x64

Nu este disponibil

Spoolss.dll

6.0.6001.22200

241,664

11-Jun-2008

05:50

x64

Nu este disponibil

Spoolsv.exe

6.0.6001.22200

268,800

11-Jun-2008

04:26

x64

Nu este disponibil

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Stare

Microsoft a confirmat că aceasta este o problemă cu produsele Microsoft enumerate în secţiunea „Se aplică la".

Mai multe informații

Pentru mai multe informaţii despre terminologia privind actualizarea software-ului, faceţi clic pe următorul număr de articol pentru a vedea articolul în Baza de cunoştinţe Microsoft:

824684 Descrierea terminologiei standard care este utilizat pentru a descrie actualizările de software Microsoft

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×