Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Întâmpinați următoarele probleme legate de serviciul SDK OpsMgr în Microsoft System Center Operations Manager 2007.

Problemă 1

Procesul de MonitoringHost.exe de pe serverul de gestionare rădăcină Systems Center Operations Manager 2007 poate consuma mai mult de 2 gigabyți (GB) de memorie. Puteți vedea acest simptom în Managerul de activități.

Problemă 2

Un pachet de gestionare din Systems Center Operations Manager 2007 face conversia evenimentelor serviciului SDK OpsMgr în avertizări. Cu toate acestea, atunci când importați din nou pachetul de gestionare, evenimentele care au fost deja procesate sunt procesate din nou.

Cauză

Problema 1 apare deoarece modulul sursă de date al serviciului OpsMgr SDK nu limitează numărul de elemente de date care sunt procesate la un moment dat. Modulul sursă de date încearcă să citească toate elementele de date în așteptare din baza de date și să proceseze elementele de date dintr-un grup. Procesul de MonitoringHost.exe se poate opri în mod neașteptat ca răspuns la o excepție netratată dacă trebuie procesate prea multe elemente de date.

Rezolvare

Informații despre remedierea rapidă

O remediere rapidă acceptată este disponibilă de la Microsoft. Totuși, această remediere rapidă este destinată să corecteze doar problema descrisă în acest articol. Aplicați această remediere rapidă doar la sistemele care se confruntă cu această problemă specifică. Este posibil ca această remediere rapidă să primească testări suplimentare. Prin urmare, dacă nu sunteți grav afectat de această problemă, vă recomandăm să așteptați următoarea actualizare de software care conține această remediere rapidă.

Dacă remedierea rapidă este disponibilă pentru descărcare, există o secțiune "Descărcarea remedierii rapide este disponibilă" în partea de sus a acestui articol din Baza de cunoștințe. Dacă această secțiune nu apare, contactați Serviciul pentru clienți și asistența Microsoft pentru a obține remedierea rapidă.

Notă Dacă apar probleme suplimentare sau dacă este necesară o depanare, poate fi necesar să creați o solicitare de serviciu separată. Costurile uzuale de asistență se vor aplica la întrebări și probleme suplimentare de asistență care nu se califică pentru această remediere rapidă specifică. Pentru o listă completă a numerelor de telefon ale Serviciului pentru clienți și asistență Microsoft sau pentru a crea o solicitare de serviciu separată, vizitați următorul site Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNotă Formularul "Descărcarea remedierii rapide este disponibilă" afișează limbile pentru care este disponibilă remedierea rapidă. Dacă nu vedeți limba, cauza este că nu este disponibilă o remediere rapidă pentru limba respectivă.

Instrucțiuni de instalare a remedierii rapide

Aplicați această remediere rapidă la fiecare server care găzduiește următorul rol de server:

  • Operations Manager 2007 management server

Pentru a face acest lucru, copiați fișierul SystemCenterOperationsManager2007-RTM-KB943706-X86-X64-ENU.MSI din pachetul de remedieri rapide într-un folder local sau într-un folder partajat. Apoi rulați acest fișier.

Notă Puteți rula acest fișier în Windows Explorer sau într-o linie de comandă. Procesul de instalare a remedierii rapide repornește serviciul OpsMgr Health.

Computerele agentului sunt actualizate automat. Totuși, trebuie să aprobați actualizarea în folderul "Gestionare în așteptare". Pentru a face acest lucru, urmați acești pași:

  1. Pe computerul care rulează rolul Server de gestionare, faceți clic pe Start, indicați spre Toate programele, indicați spre System Center Operations Manager 2007, apoi faceți clic pe Consolă de operațiuni.

  2. Selectați vizualizarea Administrare, extindeți Administrare, extindeți Management dispozitive, apoi faceți clic pe Gestionare în așteptare.

  3. În folderul "Gestionare în așteptare", revizuiți și aprobați computerele agentului pentru a aplica această remediere rapidă.

Notă Dacă instalați Operations Manager 2007 Agent pe orice computer după ce aplicați această remediere rapidă, asigurați-vă că aprobați instalarea în folderul "Gestionare în așteptare".

Cerinţe preliminare

Nu sunt necesare cerințe preliminare.

Cerință repornire

Nu trebuie să reporniți computerul după ce aplicați această remediere rapidă.

Informații despre înlocuirea remedierii rapide

Această remediere rapidă nu înlocuiește alte remedieri rapide.

Informații despre fișier

Versiunea în limba engleză a acestei remedieri rapide are atributele de fișier (sau atributele de fișier mai recente) care sunt listate în tabelul următor. Datele și orele pentru aceste fișiere sunt listate în Timpul universal (UTC). Când vizualizați informațiile despre fișier, acestea sunt convertite la ora locală. Pentru a găsi diferența dintre UTC și ora locală, utilizați fila Fus orar din elementul Dată și oră din Panou de control.

System Center Operations Manager 2007, versiuni bazate pe x86

Nume fișier

Versiune fișier

Dimensiune fișier

Data

Timp

Platforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24-Oct-2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24-Oct-2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24-Oct-2007

09:34

x86

System Center Operations Manager 2007, versiuni bazate pe x64

Nume fișier

Versiune fișier

Dimensiune fișier

Data

Timp

Platforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24-Oct-2007

09:34

x86

Microsoft.enterprisemanagement.operationsmanager.dll

6.0.5000.31

2,166,784

24-Oct-2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24-Oct-2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24-Oct-2007

09:34

x86

Momperfsnapshothelper.exe

6.0.5000.0

47,104

24-Oct-2007

09:35

x64

Momperfsnapshothelperproxy.dll

6.0.5000.0

11,776

24-Oct-2007

09:35

x64

Stare

Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.

Mai multe informații

Pentru mai multe informații despre terminologia actualizărilor de software, faceți clic pe următorul număr de articol pentru a vizualiza articolul în Baza de cunoștințe Microsoft:

824684 Descrierea terminologiei standard care este utilizată pentru a descrie actualizările de software Microsoft

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×