Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Când executați un site web care execută canal de publicitate pe un server care execută Microsoft Commerce Server 2007 sau Microsoft Commerce Server 2009, primiți un mesaj de eroare asemănător cu următorul:

HttpContext.Current este null din Commerce.CSFLoadHistory.1

În plus, în Jurnalul de aplicații se înregistrează un eveniment care seamănă cu următorul:

Cauză

Această problemă apare deoarece componentele LoadHistory, SaveHistory și IISAppendToLog verifica ASP.NET context. Cu toate acestea, nu este necesar pentru aceste componente pentru a verifica ASP.NET context și în unele scenarii, aceasta poate provoca probleme. Canal de publicitate include aceste trei componente. De aceea, această problemă se produce.

Rezolvare

Pentru a rezolva această problemă, aplicați această remediere rapidă la serverul care execută Commerce Server 2007 sau Commerce Server 2009.

Mai multe informații despre această remediere rapidă

Informații despre remedierea rapidă

O remediere rapidă compatibilă este disponibilă de la Microsoft. Cu toate acestea, scopul său este de a corecta numai problema descrisă în acest articol. Aplicați această remediere rapidă numai pentru sistemele care întâmpină problema descrisă în acest articol. Această remediere rapidă poate să necesite testare suplimentară. De aceea, dacă nu sunteți grav afectat de această problemă, vă recomandăm să aşteptaţi următoarea actualizare software care conţine această remediere rapidă. Dacă remedierea rapidă este disponibilă pentru descărcare, există o secțiune "Descărcare remediere rapidă disponibilă" în partea de sus a acestui articol din baza de cunoștințe. Dacă nu apare această secţiune, contactaţi Microsoft Client Service și suport pentru a obţine remedierea rapidă. Notă Dacă se produc probleme suplimentare sau este necesară depanarea, poate fi necesar să creați o solicitare de asistenţă separată. Costurile de obicei pentru suport se vor aplica pentru sprijin suplimentar, întrebări și probleme care nu sunt specifice pentru această remediere rapidă . Pentru o listă completă cu numerele de telefon ale clienților servicii și asistență Microsoft sau pentru a crea o solicitare de asistenţă separată, vizitați următorul site Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNotă Formularul "Descărcare remediere rapidă disponibilă" afişează limbile pentru care este disponibilă remedierea rapidă. Dacă nu vedeți limba dvs., înseamnă că o remediere rapidă nu este disponibilă pentru respectiva limbă.

Cerinţe preliminare

Trebuie să aveți unul dintre următoarele instalat pentru a aplica această remediere rapidă:

  • Microsoft Commerce Server 2007 Service Pack 2 (SP2)

  • Microsoft Commerce Server 2009

Informații despre repornire

Nu trebuie să reporniți computerul după aplicarea acestei remedieri rapide. Cu toate acestea, trebuie să reporniți Internet Information Services (IIS) după aplicarea acestei remedieri rapide. Pentru a reporni IIS, într-un prompt de comandă, tastați următoarea comandă şi apoi apăsaţi ENTER:

iisreset /restartNotă Această comandă se oprește și apoi repornește toate serviciile IIS care se execută.

Informații despre fișier

Versiunea în limba engleză a acestei remedieri rapide are atributele de fişier (sau atribute de fişier mai recente) enumerate în următorul tabel. Datele şi orele acestor fişiere sunt exprimate în listă în ora universală (UTC). Când vizualizaţi informaţiile despre fișier, acesta este convertit la ora locală. Pentru a găsi diferenţa dintre UTC şi ora locală, utilizaţi fila Fusul orar în elementul de Data şi ora în Panoul de Control.

Pentru toate versiunile bazate pe x86 Commerce Server 2007

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Pentru toate versiunile bazate pe x64 Commerce Server 2007

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Aspintrinsics.dll

6.0.4109.47

16,656

24-Aug-2010

13:46

x86

Csfcomp.dll

6.0.4109.47

281,352

24-Aug-2010

13:48

x86

Csfcomp.dll

6.0.4109.47

485,128

24-Aug-2010

13:48

x64

Pentru toate versiunile bazate pe x86 Commerce Server 2009

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Pentru toate versiunile bazate pe x64 Commerce Server 2009

Nume de fișier

Versiune fișier

Dimensiune fișier

Data

Ora

Platformă

Aspintrinsics.dll

6.0.4171.28

16,656

31-Aug-2010

13:14

x86

Cs2009hotfixhelper.exe

6.0.4171.28

13080

31-Aug-2010

13:14

x86

Csfcomp.dll

6.0.4171.28

281,352

31-Aug-2010

13:16

x86

Csfcomp.dll

6.0.4171.28

485,128

31-Aug-2010

13:16

x64

Stare

Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×