Simptome

Utilizați mai multe fluxuri de lucru în Microsoft Dynamics CRM 4,0. Tabelele AsyncOperationBase și WorkflowLogBase cresc foarte mari și apar probleme de performanță.

Cauză

Această problemă apare deoarece, când sunt trase regulile fluxului de lucru, se creează o instanță de flux de lucru și o înregistrare de flux de lucru în tabelele AsyncOperationBase și WorkflowLogBase din baza de date MSCRM. Cu toate acestea, când instanța fluxului de lucru este finalizată, înregistrarea fluxului de lucru rămâne în baza de date. Prin urmare, tabelele AsyncOperationBase și WorkflowLogBase continuă să crească. În cele din urmă, performanța scade. Notă proprietatea AsyncOperationType pentru aceste înregistrări este setată la 10.

Rezolvare

Această problemă este remediată în cel mai recent pachet de actualizare cumulativă pentru Microsoft Dynamics CRM 4,0. Pentru mai multe informații, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

949256 Actualizări și remedieri rapide Microsoft Dynamics CRM 4,0 important această secțiune, metodă sau activitate conține pașii care vă arată cum să modificați registry. Totuși, dacă modificați incorect sistemul registry, pot apărea probleme serioase. De aceea, asiguraţi-vă că urmaţi aceşti paşi cu atenţie. Pentru o protecție mai bună, înainte de a face modificări, realizați o copie de rezervă a sistemului registry. După aceea, sistemul registry poate fi restaurat dacă apare o problemă. Pentru informații suplimentare despre copierea de rezervă și restaurarea sistemului registry, faceți clic pe următorul număr de articol din Baza de cunoștințe Microsoft:

322756 Cum să faceți backup și să restaurați registry în Windows după ce instalați remedierea rapidă, pentru ca noi să activați această remediere rapidă pentru dvs., accesați secțiunea "Remediere automată". Dacă preferați să activați remedierea rapidă, accesați secțiunea "Remediere personală".

Remediere automată

Pentru a activa remedierea rapidă în mod automat, faceți clic pe butonul Fix it sau pe linkul. Apoi faceți clic pe rulare în caseta de dialog Descărcare fișier și urmați pașii din expertul Fix it .

Note

  • Este posibil ca acest expert să fie disponibil numai în limba engleză. Cu toate acestea, remedierea automată funcționează și cu Windows în alte limbi.

  • Dacă nu vă aflați pe computerul care are problema, salvați soluția fix it pe o unitate flash sau pe un CD, apoi rulează-l pe computerul care are problema.

Apoi, accesați secțiunea "s-a remediat problema?".

Remediere personală

Pentru a activa această remediere rapidă, urmați acești pași:

  1. Faceți clic pe Start, pe rulare, tastați regedit, apoi faceți clic pe OK.

  2. În Registry Editor, găsiți următoarea subcheie:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Determinați dacă există o intrare de registry DWORD denumită AsyncRemoveCompletedWorkflows. Valoarea datelor din intrarea de registry AsyncRemoveCompletedWorkflows trebuie să fie 1.

  4. Dacă intrarea de registry AsyncRemoveCompletedWorkflows nu există, adăugați intrarea. Pentru a face acest lucru, urmați acești pași:

    1. Faceți clic dreapta pe MSCRM, indicați spre nou, faceți clic pe valoare DWORD, apoi tastați AsyncRemoveCompletedWorkflows în casetanume .

    2. Faceți dublu clic pe AsyncRemoveCompletedWorkflows, apoi tastați 1 în caseta Value data .

    3. Faceți clic pe Start, pe rulare, tastați iisreset, apoi faceți clic pe OK. Notă Dacă valoarea din caseta Valoare date pentru valoarea DWORD AsyncRemoveCompletedWorkflows revine la 0, Microsoft Dynamics CRM va continua să păstreze înregistrările fluxului de lucru în baza de date, chiar dacă activitățile sunt finalizate.

Notă Această remediere rapidă este doar proactiv. Prin urmare, atunci când este instalată și activată remedierea rapidă, doar înregistrările flux de lucru noi sunt șterse automat. Dacă tabelele AsyncOperationBase și WorkflowLogBase sunt deja mari din cauza acestor înregistrări de flux de lucru, trebuie să efectuați o curățare a acestor tabele utilizând scriptul de curățire Microsoft SQL Server care este inclus în următorul articol din baza de cunoștințe Microsoft:

968520 Performanța este lentă dacă tabelul AsyncOperationBase devine prea mare în Microsoft Dynamics CRM 4,0

S-a remediat problema?

  • Verificați dacă problema este remediată. Dacă problema este remediată, ați terminat cu această secțiune. Dacă problema nu este remediată, puteți contacta asistența.

  • Am aprecia feedbackul dumneavoastră. Pentru a oferi feedback sau pentru a raporta orice probleme cu această soluție, vă rugăm să lăsați un comentariu pe blogul "Remediere automată" sau să ne trimiteți un mesaj de e-mail .

Mai multe informații

Pentru mai multe informații despre terminologia actualizării software-ului, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

824684 Descrierea terminologiei standard care este utilizată pentru a descrie actualizările de software Microsoft pentru mai multe informații despre Microsoft Business Solutions CRM software-ul de remediere rapidă și pachetul de actualizare terminologie, faceți clic pe următorul număr de articol pentru a vedea articolul în baza de cunoștințe Microsoft:

887283 Pachetul de remediere rapidă și actualizare a pachetelor de denumire pentru Microsoft Business Solutions CRM

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.