Simptome
Să luăm în considerare următorul scenariu:
-
Utilizați Microsoft Exchange Troubleshooting Assistant (Extra.exe) pentru a depana un server Microsoft Exchange Server 2010.
-
Utilizați Asistentul de depanare pentru Exchange pentru a solicita urme și pentru a colecta informații de diagnosticare.
-
Componenta de urmărire ADProvider și eticheta de urmărire ClientThrottlingState sunt selectate din urmărire.
-
Executați o comandă în Exchange Management Shell (EMS) sau efectuați o operațiune în Exchange Management Console (EMC). De exemplu, executați comanda Get-Mailbox .
În acest scenariu, primiţi următorul mesaj de eroare în EMS sau într-o fereastră pop-up de la EMC:
Procesarea datelor de pe server la distanță nu a reușit cu următorul mesaj de eroare: clientul nu se poate conecta la destinație specificat în solicitarea. Verificați dacă serviciul pe destinație se execută și este de a accepta solicitările. Consultați jurnalele și documentație pentru WS-Management service execută pe destinație, cel mai frecvent IIS sau WinRM. Dacă destinația este serviciul WinRM, executaţi următoarea comandă pe destinație pentru a analiza și a configura serviciul WinRM: "winrm quickconfig". Pentru mai multe informații, consultați subiectul de ajutor about_Remote_Troubleshooting. + CategoryInfo: OperationStopped: (System.Manageme...pressionSyncJob:PSInvokeExpressionSyncJob) [], PSRemotingTransportException + FullyQualifiedErrorId: JobFailure
Cauză
Această problemă apare deoarece eticheta de urmărire ClientThrottlingState este activată. Când este activată această etichetă de urmărire când se execută o comandă PowerShell rezervor de aplicații se blochează și, apoi repornește.
Rezolvare
Pentru a rezolva această problemă, instalați pachetul de actualizare care este descrisă în următorul articol din baza de cunoștințe Microsoft:
982639 Descrierea setului de actualizări 4 pentru Exchange Server 2010
Soluție de evitare
Pentru a rezolva această problemă, dezactivați eticheta ADProvider și eticheta ClientThrottlingState. Sau lăsați etichete activat și apoi debifați tipul de urmărire de depanare . Pentru a face acest lucru, urmați acești pași:
-
Faceți clic pe Start, apoi pe Executare.
-
Tastați C:\Program Files\Microsoft\Exchange Server\V14\Bin\extra.exe în câmpul Open , și apoi faceți clic pe OK.
-
Du-te la ecranul de bun venit, și apoi faceți clic pe Selectați o activitate.
-
Control de urmărire, și apoi faceți clic pe OK.
-
Faceți clic pe Set etichete de urmărire manual.
-
Pe pagina următoare, faceți clic pe ADProvider sub fila componente la urmă și apoi debifați caseta de selectare ClientThrottlingState sub fila Urmărire . Sau, debifați caseta de selectare de depanare .
-
Faceți clic pe Start urmărireși apoi faceți clic pe Stop urmărire acum.
-
Faceți clic pe Ieșire.
Chiar și după ce stop urmărire și dezactivați eticheta, această problemă poate persista o perioadă de timp. Această problemă persistă dacă proprietatea Debug TraceLevel este conținută în eticheta ADProvider:ClientThrottlingState în fișierul EnabledTraces.Config . Dacă continuați să întâmpinați această problemă, redenumiți sau ștergeți fișierul EnabledTraces.Config pe unitatea de sistem (unitatea C).
Stare
Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea „Se aplică la”.