Использование функции слияния в Word для создания и печати стандартных писем, в которых используются данные с листа Excel

Применимо к: Microsoft Office Excel 2007

Аннотация


В этой статье рассказывается о том, как создавать и печатать стандартные письма, в которых используются данные с листа Excel с помощью функции слияния в Word.

При использовании функции слияния в Word происходит объединение основного документа со списком получателей, в результате чего создается комплект выходных документов.
  • В основном документе содержится текст, являющийся одинаковым для всех выходных документов. В документе может содержаться бланк, текст и инструкции в полях слияния для вставки текста (такого как имена и адреса получателей) для отдельных выходных документов.
  • Список получателей является базой данных с данными для объединения в выходных документах. Например, список получателей может быть представлен в виде файла базы данных Microsoft Access или листа Excel.

    Эта база данных обычно представляет собой список имен, адресов, номеров телефонов и личной информации других категорий.
  • Результатом слияния являются выходные документы. Текст всех выходных документов может быть одинаковым, но возможно форматирование отдельных документов.

Шаг 1. Настройка файла данных Excel

До запуска мастера слияния почты необходимо убедиться, что книга Excel структурирована соответствующим образом. Обратите внимание на следующие требования для таблицы данных.
  • В первой строке должны содержаться имена полей для каждого столбца, например: «Должность», «Приветствие», «Имя», «Отчество», «Фамилия», «Адрес 1» и «Адрес 2».
  • Все имена полей должны быть уникальными.
  • В каждой строке должны содержаться сведения об определенном элементе. Например, в списке рассылки в каждой строке может содержаться информация о конкретном получателе.
  • В таблице не должно быть пустых строк.
Создайте файл данных Excel и упорядочите его с помощью полей, которые необходимо использовать для письма, как показано в следующем примере файла данных.

Сохраните и закройте файл данных Excel после его создания.

Дополнительные сведения о создании списка адресов для слияния см. в следующей статье базы знаний Майкрософт:

294688 Разработка и создание списка адресов для слияния в Word 2002 и более поздних версиях Word

Шаг 2. Настройка основного документа

  1. В Microsoft Office Word 2003 или более ранней версии программы Word наведите указатель на пункт Письма и рассылки в меню Сервис, затем щелкните Мастер слияния.

    В Microsoft Office Word 2007 щелкните Начать слияние в группе Начать слияние на вкладке Рассылки, а затем щелкните Пошаговый мастер слияния.
  2. В списке Выбор типа документа выберите Письма.

    Активный документ становится основным документом. Основной документ содержит текст и графические элементы, которые будут одинаковыми для всех версий объединенного документа. Например, обратный адрес и приветствие в стандартном письме будут одинаковыми для всех версий.
  3. Нажмите кнопку Далее. Открытие документа.
  4. Выполните одно из следующих действий.
    • Начать с документа, который отображается в окне в настоящий момент. Для этого щелкните Использовать текущий документ.

      После этого можно будет ввести письмо в окне документа или подождать, пока мастер не предложит сделать это.
    • Начать с шаблона. Для этого выполните следующие действия.
      1. Щелкните Шаблон.
      2. Щелкните Выбор шаблона.
      3. На вкладке Слияние выберите шаблон, который требуется использовать в диалоговом окне Выбор шаблона, а затем нажмите кнопку .
    • Начать с существующим документом. Для этого выполните следующие действия.
      1. Щелкните Существующий документ.
      2. В поле Существующий документ выберите нужный документ и щелкните Открыть.
      3. Если документ отсутствует, щелкните Другие файлы, затем щелкните Открыть. Выберите нужный документ в диалоговом окне Открыть и нажмите кнопку Открыть.
  5. Нажмите кнопку Далее. Выбор получателей.

Шаг 3. Указание источника данных Excel

  1. В группе Выбор получателей щелкните Использование списка.
  2. Нажмите кнопку Обзор.
  3. В диалоговом окне Выбор источника данных выберите нужный лист Excel.

    По умолчанию в программе Word открывается папка «Мои источники данных».
  4. Нажмите кнопку Открыть.
  5. Если на листе Excel содержится информация на нескольких вкладках, выберите вкладку с нужными сведениями и нажмите кнопку .
  6. Все записи из источника данных отображаются в диалоговом окне Получатели слияния. Здесь вы можете уточнить список получателей, которые будут включены в слияние.

Шаг 4. Выбор получателей

  1. В диалоговом окне Получатели слияния выберите получателей, которых необходимо включить. Для этого воспользуйтесь одним из указанных ниже способов.
    • Укажите получателей с помощью флажков.

      Этот способ является наиболее предпочтительным вариантом, если ваш список короткий. Установите флажки для получателей, которых необходимо включить, и снимите флажки для получателей, которых необходимо исключить.

      Примечание. Если известно, что в слияние необходимо включить большую часть получателей в списке, щелкните Выбрать все, затем снимите флажки для определенных получателей. Аналогично, если необходимо включить только несколько записей в списке, щелкните Очистить все, затем выберите нужные записи.
    • Сортировка элементов списка.

      Этот способ используется в том случае, когда необходимо расположить элементы в алфавитном или цифровом порядке. Щелкните заголовок столбца элемента, по которому необходимо выполнить сортировку. Например, при необходимости отображения списка в алфавитном порядке с сортировкой по фамилии щелкните заголовок столбца Фамилия.
    • Фильтрация элементов списка.

      Этот способ используется в том случае, если в списке содержатся записи, для которых отображение или включение в слияние не требуется. После фильтрации списка можно включить или исключить записи, используя флажки, как описано в предыдущем разделе. Для фильтрации списка выполните следующие действия.
      1. Щелкните стрелку рядом с заголовком столбца элемента, по которому необходимо выполнить фильтрацию.
      2. Щелкните один из следующих параметров:
        • (Пустые): отображение всех записей, в которых соответствующее поле является пустым.
        • (Непустые): отображение всех записей, в которых соответствующее поле содержит информацию.
        • Если в источнике данных содержатся записи с идентичной информацией и в столбце содержится не более десяти уникальных значений, можно выполнить фильтрацию по определенной информации. Например, если для нескольких адресов в качестве страны указана Австралия, можно выполнить фильтрацию по значению Австралия.
    • В диалоговом окне Получатели слияния отображаются только назначенные записи. Чтобы снова отобразить все записи, щелкните (Все).
    Примечания.
    • Для расширенной сортировки и фильтрации щелкните стрелку рядом с именем какого-либо столбца, затем щелкните (Дополнительно). Для настройки запроса на сортировку или фильтрацию используйте вкладки Отбор записей и Сортировка записей.
    • Если установлено программное обеспечение для проверки адресов, щелкните Проверить в диалоговом окне Получатели слияния для проверки адресов получателей.
  2. Нажмите кнопку для возврата к мастеру слияния.

    Программа Word будет использовать получателей, назначенных для слияния.
  3. Нажмите кнопку Далее. Создание письма.

Шаг 5. Написание письма и добавление полей слияния

Если это еще не было сделано, введите в основной документ текст, который будет приведен на каждом бланке письма.

Вставка полей слияния

Вставьте поля слияния в те места, где требуется разместить имена, адреса и другую информацию из источника данных. Для вставки полей слияния выполните следующие действия.
  1. В основном документе щелкните то место, в которое необходимо вставить поле.
  2. Вставьте один из следующих параметров.
    • Адресный блок с именем, адресом и другой информацией.
      1. Щелкните Блок адреса.
      2. В диалоговом окне Вставка блока адреса выберите элементы адреса, которые необходимо включить, и нужные форматы, затем нажмите . Чтобы получить справку по параметру, щелкните вопросительный знак, а затем щелкните параметр.

      3. Чтобы получить справку по параметру, щелкните вопросительный знак, а затем щелкните параметр. Если появилось диалоговое окно Подбор полей, возможно, программе Word не удалось найти определенную информацию для блока адреса. Щелкните стрелку рядом с полем (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.
    • Строка приветствия:
      1. Щелкните Строка приветствия.
      2. Выберите формат строки приветствия, включающий приветствие, формат имени и соответствующие знаки препинания.
      3. Выберите текст, который будет отображаться в тех случаях, когда программе Word не удается интерпретировать имя получателя. Например, программа Word не сможет интерпретировать имя, если в источнике данных для получателя указано только название компании, а имя и фамилия отсутствуют.
      4. Нажмите кнопку ОК.
      5. Если появилось диалоговое окно Подбор полей, возможно, программе Word не удалось найти определенную информацию для строки приветствия. Щелкните стрелку рядом с полем (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.
    • Другие поля с информацией:
      1. Щелкните Другие элементы.
      2. Выполните одно из следующих действий.
        • Для выбора полей адресов, которые будут автоматически сопоставляться с соответствующими полями в источнике данных, даже в том случае, если имена полей источника данных не совпадают с именами ваших полей, щелкните Поля адреса.
        • Для выбора полей, которые всегда напрямую используют данные столбца базы данных, щелкните Поля базы данных.
      3. В диалоговом окне Поля выберите нужное поле.
      4. Щелкните Вставить, а затем Закрыть.
      5. Если появилось диалоговое окно Подбор полей, программе Word не удалось найти определенную информацию для вставки поля. Щелкните стрелку рядом с полем (отсутствует), затем выберите поле в источнике данных, соответствующем полю, необходимому для слияния.

        Примечание. При вставке поля из списка Поля базы данных и последующем переключении к источнику данных, в котором отсутствует столбец с таким же именем, Word не сможет вставить информацию этого поля в созданный документ.
    • Электронная почтовая марка.

      Для добавления электронной почтовой марки необходимо установить соответствующее программное обеспечение, приобретенное у стороннего поставщика в Интернете. Для использования электронной почтовой марки выполните следующие действия.
      1. Щелкните Почтовая марка.

        Если программное обеспечение для работы с электронными почтовыми марками не установлено, появляется запрос на его установку и предложение подключиться к следующему веб-узлу Microsoft Office:
        Печать электронных почтовых марок
        http://office.microsoft.com/services/service.aspx?sid=2.4
      2. Вставьте марку в соответствии с инструкциями программы.
    • Для добавления электронной почтовой марки необходимо установить соответствующее программное обеспечение, приобретенное у стороннего поставщика в Интернете. Для использования электронной почтовой марки выполните следующие действия. Почтовый штрихкод: Необходимо выбрать тип письма или конверта с поддержкой штрихкода POSTNET. Для использования почтового штрихкода выполните следующие действия.
      1. Щелкните Почтовый штрихкод.
      2. В диалоговом окне Вставка почтового штрихкода выберите соответствующие поля адреса.

        Примечание. Параметр Почтовый штрихкод отображается только при использовании программы Word на английском языке (США).
      3. Повторите шаг «а» и «б» для всех полей, которые необходимо вставить. ПРИМЕЧАНИЯ.
        • Нельзя ввести символы поля слияния (" ") или вставить их с помощью команды Символ в меню Вставка.
        • Если поля слияния заключены в фигурные скобки, например { MERGEFIELD City }, программа Word вместо значений отображает коды полей. Это не влияет на слияние, но при необходимости отображения результатов правой кнопкой мыши щелкните код поля, затем выберите Коды/значения полей в контекстном меню.
      Например, при использовании приведенной простой базы данных в вашем письме могут использоваться поля AddressBlock и GreetingLine, а первая страница будет выглядеть примерно так:
      26 февраля 2002 г.

      AddressBlock

      GreetingLine

      Введите сообщение.

      С уважением,

      Введите свое имя.

    Примечание. Для вставки полей слияния, работы с основным документом слияния и выполнения слияния можно использовать панель инструментов Слияние. Чтобы отобразить панель инструментов Слияние, в меню Сервис выберите Письма и рассылки, затем щелкните Показать панель инструментов слияния.


    На панели инструментов Слияние доступны дополнительные команды, отсутствующие в мастере слияния. Например, с помощью меню Вставить поле Word на панели инструментов Слияние можно вставлять поля Word для управления процессом слияния. Например, можно вставить поле IF, которое вставляет текст только в том случае, если в определенном поле слияния установлено указанное значение.

    Или можно щелкнуть Поиск ошибок для выполнения слияния и создания отчета об ошибках, содержащихся в основном документе.

Изменение формата объединенных данных

Для форматирования объединенных данных необходимо отформатировать поля в основном документе. Не форматируйте данные в источнике данных, поскольку это форматирование не сохраняется при слиянии данных в документе. Для изменения формата объединенных данных выполните следующие действия.
  1. В основном документе выберите поле с информацией, которую необходимо отформатировать, включая символы, в которые заключено поле слияния (<< >>).
  2. В Word 2003 и более ранних версиях щелкните Шрифт в меню Формат и установите нужные параметры.

    В Word 2007 щелкните нужный вариант в поле Шрифты темы в группе Шрифт на вкладке Главная.

Форматирование с помощью кодов полей

Для доступа к другим параметрам форматирования нажмите ALT+F9, чтобы отобразить коды полей, затем добавьте ключи в поля слияния. Ключ, используемый при работе с полями, является специальной инструкцией, которая приводит к выполнению определенного действия. В общем смысле ключ добавляется к полю для изменения результата.

Ниже приведены примеры использования ключей.
  • Для отображения числа 34987,89 как $34 987,89 добавьте ключ числового формата (\#).
  • Для печати имен клиентов в верхнем регистре добавьте ключ формата (\*).
  • Чтобы размер и шрифт объединенной информации совпадали с размером и шрифтом, которые установлены для поля слияния, добавьте ключ Charformat (\*).

Шаг 6. Сохранение документа

Завершив формирование основного документа и вставив все поля слияния, обязательно сохраните документ перед тем, как продолжить работу. Для этого выполните следующие действия.
  1. В программе Word 2003 и более ранних версиях щелкните Сохранить как в меню Файл.

    В программе Word 2007 нажмите кнопку Microsoft Office и щелкните Сохранить как.
  2. Укажите имя документа и нажмите кнопку Сохранить.
  3. Нажмите кнопку Далее. Просмотр писем.

Шаг 7. Просмотр писем и настройка списка получателей

При появлении области задач «Шаг 5. Слияние» мастера все поля слияния основного документа заменяются текстом первой записи списка получателей, чтобы можно было просмотреть первый выходной документ.

Например, при использовании образца базы данных, приведенного выше, после нажатия Далее. Просмотр писем, первая страница будет выглядеть примерно так:
26 февраля 2002 г.

Александр Демидов
ул. Морская, 124
Пенза, 140052

Уважаемый Александр Демидов!

Введите сообщение.

С уважением,

Введите свое имя.
Для просмотра других записей воспользуйтесь одним из указанных ниже способов.
  • Для просмотра элементов по порядку используйте кнопки со стрелками влево и вправо.
  • Для просмотра определенного элемента щелкните Найти получателя, затем в диалоговом окне Поиск элемента введите условие поиска.
При необходимости уточните список получателей. Для этого воспользуйтесь одним из указанных ниже способов.
  • Чтобы исключить определенного получателя из слияния, щелкните Исключить получателя.
  • Чтобы изменить список получателей, щелкните Изменить список получателей и внесите изменения в диалоговом окне Получатели слияния.

Шаг 8. Завершение слияния

Чтобы завершить слияние, воспользуйтесь одним из указанных ниже способов.

Персонализация отдельных писем

Для персонализации отдельных писем завершите слияние, а затем измените необходимую информацию в полученном объединенном документе. Для этого выполните следующие действия.
  1. Щелкните Изменить часть писем.
  2. В диалоговом окне Составные новые документы выберите записи, которые необходимо объединить.
  3. Нажмите кнопку ОК.

    Word создает и открывает новый объединенный документ. Основной документ также остается открытым, и в него можно вернуться при необходимости изменения всех документов.
  4. Найдите информацию, которую необходимо изменить, и внесите изменения.
  5. Напечатайте или сохраните документ так же, как и любой другой документ.

Печать писем

Для печати писем воспользуйтесь одним из указанных ниже способов.
  • Если элементы персонализированы и объединенный документ является активным, выполните следующие действия.
    1. В программе Word 2003 и более ранних версиях выберите пункт Печать в меню Файл.

      В программе Word 2007 нажмите кнопку Microsoft Office и щелкните Печать.
    2. Выберите нужные параметры.
  • При необходимости печати напрямую из мастера слияния выполните следующие действия.
    1. На шаге 6 мастера слияния (завершение слияния), щелкните Печать.
    2. В диалоговом окне Составные печатные документы воспользуйтесь одним из следующих способов и нажмите кнопку .
      • Для печати всех документов щелкните Все.
      • Для печати документа, отображаемого в окне документа, щелкните Текущая запись.
      • Для печати диапазона документов щелкните С и введите номера записей в поля С и До.
    3. В диалоговом окне Печать выберите нужные параметры.

Сохранение объединенных писем для последующего использования

При необходимости изменения объединенных писем и их сохранения для последующего использования письма можно вставить в один документ. Для этого выполните следующие действия.
  1. Щелкните Изменить часть писем.
  2. В диалоговом окне Составные новые документы воспользуйтесь одним из следующих способов и нажмите кнопку .
    • Для объединения всех документов щелкните Все.
    • Для слияния только документа, отображаемого в окне документа, щелкните Текущая запись.
    • Для объединения диапазона документов щелкните С и введите номера записей в поля С и До.
  3. Word открывает новый документ со всеми отдельными письмами. Затем можно сохранить документ для последующего использования так же, как и любой другой документ.

Ссылки


Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:

318117 Использование адресов в книге Excel для создания наклеек в Word

318115 Создание письма в Word 2002 с использованием информации из базы данных Access

318112 Использование адресов из базы данных Access 2002 для создания наклеек в Word 2002

294686 Использование слияния для создания списка, отсортированного по категории, в Word 2002 и более поздних версиях Word

290408 Часто задаваемые вопросы о слиянии в Word 2002

294688 Разработка и создание списка адресов для слияния в Word 2002 и более поздних версиях Word

294693 Использование слияния для создания каталога в Word 2002 и более поздних версиях Word

294683 Использование слияния для создания писем в Word 2002 и более поздних версиях Word