Мастер импорта организации занимает много времени для импорта в организации Microsoft Dynamics CRM 4.0

Применимо к: Dynamics CRM 4.0

Симптомы


При попытке импорта в организации Microsoft Dynamics CRM 4.0 с помощью диспетчера развертывания. Тем не менее мастер импорта организации занимает много времени для импорта в организации.

Причина


Эта проблема возникает, поскольку существует много ссылок пользователя системы, которые должны быть обновлены.

Решение


Важно. Этот раздел, метод или задача содержат действия, содержащие указания по изменению реестра. Однако, при некорректных изменениях реестра могут возникнуть серьезные проблемы. Поэтому выполняйте следующие действия внимательно. Для дополнительной защиты сделайте резервную копию реестра перед внесением изменений. В таком случае при возникновении неполадок можно будет восстановить реестр. Чтобы узнать дополнительные сведения о резервном копировании и восстановлении реестра, щелкните следующий номер статьи базы знаний Майкрософт:
322756 как резервное копирование и восстановление реестра Windows
Эта проблема решена в последней версии накопительный пакет обновления для Microsoft Dynamics CRM 4.0.
Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
949256 Microsoft Dynamics CRM 4.0 обновлений и исправлений


После установки данного исправления требуется помощь добавить параметр реестра OptimizeOrgImport REG_DWORD, перейдите к разделу «помощь в решении проблемы». Если необходимо добавить параметр реестра OptimizeOrgImport REG_DWORD самостоятельно, перейдите к разделу «Самостоятельное решение проблемы».

Помощь в решении проблемы



Чтобы добавить запись реестра OptimizeOrgImport REG_DWORD автоматически, щелкните устранить его . Затем нажмите кнопку Выполнить в диалоговом окне Загрузка файла и следуйте инструкциям мастера Fix it .




Примечания
  • Этот мастер может быть только на английском языке. Однако автоматическое исправление также работает для других языковых версий Windows.
  • Если вы не за компьютером, на котором выявлена проблема, сохраните файл с решением Fix it на флэш-накопитель или компакт-диск и запустите его на нужном компьютере.

Перейдите к разделу Устранена ли неполадка?.



Самостоятельное решение проблемы

После установки этого исправления необходимо добавить запись реестра OptimizeOrgImport REG_DWORD на сервере Microsoft Dynamics CRM 4.0. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
  2. Найдите и выделите следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Щелкните правой кнопкой мыши MSCRM, пункты
    Создать, а затем щелкните Значение DWORD.
  4. Имя данного значения DWORD как «OptimizeOrgImport»
  5. Щелкните правой кнопкой мыши OptimizeOrgImportи выберите команду Изменить.
  6. В поле значение введите
    1и нажмите кнопку ОК.
  7. В меню файл выберите команду
    Выход.
Примечание. Если вы хотите отключить это исправление, значение записи реестра OptimizeOrgImport значение 0.


"Устранена ли неполадка?"

  • Проверьте, устранена ли проблема. Если проблема устранена, дальше можно не читать. Если проблема не устранена, обратитесь в службу поддержки.
  • Мы ценим ваши отзывы. Чтобы отправить отзыв или сообщить о проблемах, связанных с этим решением, оставьте комментарий в блоге «помощь в решении проблемы» или отправьте нам сообщение по электронной почте .

Дополнительные сведения


При использовании параметра реестра OptimizeOrgImport и имеют значение для этой записи установлено значение 1, одну и ту же базу данных организации нельзя импортировать более одного раза. Если требуется импортировать несколько раз к одной базе данных организации, необходимо выполнить одно из следующих действий:
  • Значение OptimizeOrgImport = 0 и использовать обычный импортирование.
  • Удалить организацию, а затем импортируйте организацию еще раз.

Статус


Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".