Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Проблема

После загрузки обновлений с узла Windows Update на компьютер, работающий под управлением системы Windows Vista, могут возникнуть указанные ниже проблемы.

  • Появляется диалоговое окно с сообщением о том, что хост-процесс для служб Windows прекратил работу.

  • После перезагрузки компьютера появляется диалоговое окно Windows Update, которое содержит следующее сообщение:

    Некоторые обновления не были установлены.

    Не установлено обновлений: xx
    Возникли следующие ошибки:

    Code 800706BA

  • В журнале приложений регистрируется событие, подобное приведенному ниже.

Причина

Эта проблема возникает из-за повреждения файлов состояния фоновой интеллектуальной службы передачи (BITS) и приводит к прекращению работы хост-процесса для служб Windows. В результате становится невозможной передача файлов с помощью службы BITS.

Решение

Доступно обновление, устраняющее эту проблему. Средство восстановления службы BITS позволяет устранить проблему, вызванную повреждением файлов состояния службы BITS и приводящую к завершению работы хост-процесса для служб Windows. Эта проблема не позволяет использовать службу BITS для передачи файлов. Для устранения повреждений и возобновления передачи файлов с помощью службы BITS воспользуйтесь средством восстановления службы BITS. После запуска данного средства может потребоваться перезагрузка компьютера.

Сведения о загрузке

С веб-узла центра загрузки Microsoft можно загрузить следующий файл:

Windows Vista, 32-разрядные версии

Загрузить пакет 940520 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Windows Vista, 64-разрядные версии

Загрузить пакет 940520 (эта ссылка может указывать на содержимое полностью или частично на английском языке).

Дополнительные сведения о загрузке файлов с веб-узла поддержки Майкрософт см. в следующей статье базы знаний Майкрософт:

119591 Как загрузить файлы поддержки Microsoft из Интернета Корпорация Майкрософт проверила этот файл на наличие вирусов с помощью последних на момент его публикации версий антивирусного программного обеспечения. Файл хранится на защищенном сервере, что предотвращает его несанкционированное изменение.


Эту проблему также можно устранить вручную, воспользовавшись одним из указанных ниже способов.

Способ 1

  1. Включите параметр Показать скрытые файлы. Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , выберите пункт Панель управления, щелкните значок Свойства папки и откройте вкладку Вид.

    2. Установите соответствующую кнопку-переключатель в положение Показывать скрытые файлы и папки и нажмите кнопку ОК.

  2. Войдя в систему с правами администратора, найдите папку Programdata\Microsoft\Network\Downloader и удалите из нее все файлы, имя которых начинается на "Qmgr". Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , введите в поле Начать поиск строку \Programdata\Microsoft\network\downloader и нажмите клавишу ВВОД.

    2. В окне загрузчика выберите и удалите все файлы, имя которых начинается на "Qmgr". Например, удалите следующие файлы:

      • Qmgr0.dat

      • Qmgr1.dat

      Примечания

      • Если файлы не удаляются, перезагрузите компьютер в безопасном режиме без поддержки сети. Для этого воспользуйтесь способом 2 или 3.

      • Если файлы успешно удалены, сразу же посетите веб-узел Windows Update и установите последние обновления.

Способ 2

  1. Перезагрузите компьютер.

  2. Во время перезагрузки нажмите клавишу F8.

    Примечание. Клавишу F8 необходимо нажать до появления индикатора загрузки Windows Vista.

  3. С помощью клавиш со стрелками выберите в Дополнительные варианты загрузки пункт Безопасный режим и нажмите клавишу ВВОД.

  4. Включите параметр Показать скрытые файлы. Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , выберите пункт Панель управления, щелкните значок Свойства папки и откройте вкладку Вид.

    2. Установите соответствующую кнопку-переключатель в положение Показывать скрытые файлы и папки и нажмите кнопку ОК.

  5. Войдя в систему с правами администратора, найдите папку Programdata\Microsoft\Network\Downloader и удалите все файлы, имя которых начинается на "Qmgr". Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , введите в поле Начать поиск строку Programdata\Microsoft\network\downloader и нажмите клавишу ВВОД.

    2. В окне загрузчика выберите и удалите все файлы, имя которых начинается на "Qmgr". Например, удалите следующие файлы:

      • Qmgr0.dat

      • Qmgr1.dat

  6. Сразу же после этого посетите веб-узел Windows Update и установите последние обновления.

Способ 3

  1. Перезагрузите компьютер в безопасном режиме без сети. Для этого выполните указанные ниже действия.

    1. Закройте все открытые программы.


    2. Нажмите кнопку Пуск , введите в поле Начать поиск команду Run и нажмите клавишу ВВОД.


    3. Введите команду msconfig и нажмите кнопку ОК.



      При этом запустится программа настройки системы.

    4. На вкладке Загрузка установите флажки Безопасный режим и Минимальная и нажмите кнопку OK.

    5. Перезагрузите компьютер после появления соответствующего запроса.

  2. Включите параметр Показать скрытые файлы. Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , выберите пункт Панель управления, щелкните значок Свойства папки и откройте вкладку Вид.

    2. Установите соответствующую кнопку-переключатель в положение Показывать скрытые файлы и папки и нажмите кнопку ОК.

  3. Войдя в систему с правами администратора, найдите папку Programdata\Microsoft\Network\Downloader и удалите все файлы, имя которых начинается на "Qmgr". Для этого выполните указанные ниже действия.

    1. Нажмите кнопку Пуск , введите в поле Начать поиск строку \Programdata\Microsoft\network\downloader и нажмите клавишу ВВОД.

    2. В окне загрузчика выберите и удалите все файлы, имя которых начинается с Qmgr. Например, удалите следующие файлы:

      • Qmgr0.dat

      • Qmgr1.dat

  4. Перезагрузите компьютер в обычном режиме. Для этого выполните указанные ниже действия.

    1. Закройте все открытые программы.


    2. Нажмите кнопку Пуск , введите в поле Начать поиск команду Run и нажмите клавишу ВВОД.


    3. Введите команду msconfig и нажмите кнопку ОК. Будет запущена программа настройки системы.

    4. На вкладке Загрузка снимите флажок Безопасный режим и нажмите кнопку ОК, чтобы перезагрузить компьютер.

    5. При появлении соответствующего запроса перезагрузите компьютер.

  5. Сразу же после этого посетите веб-узел Windows Update и установите последние обновления.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Информация в данной статье применима к».

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×