Проблемы
Рассмотрим следующий сценарий.
-
Для устранения неполадок на сервере Microsoft Exchange Server 2010 используется Microsoft Exchange помощника по устранению неполадок (Extra.exe).
-
Можно использовать помощника по устранению неполадок Exchange для запроса трассировок и сбор диагностических сведений.
-
Компонент трассировки ADProvider и тег ClientThrottlingState трассировки выбранных в трассировку.
-
Выполнить команду в оболочке управления Exchange (EMS) или выполнить операцию в консоль управления Exchange (EMC). Например можно выполнить команду Get-Mailbox .
В этом случае появляется следующее сообщение об ошибке в EMS или во всплывающем окне с электромагнитной Совместимости:
Обработка данных с удаленного сервера не удалось выполнить следующее сообщение об ошибке: клиент не может подключиться к получателю, указанному в запросе. Убедитесь, что служба на назначения работает и принимает запросы. Службе WS-Management, работающих на место назначения, чаще всего IIS или WinRM, обратитесь к документации и журналы. Если целевой службы WinRM, выполните следующую команду на сервере назначения для анализа и настройки службы WinRM: «winrm quickconfig». Для получения дополнительных сведений обратитесь к разделу справки about_Remote_Troubleshooting. + CategoryInfo: OperationStopped: [] (System.Manageme...pressionSyncJob:PSInvokeExpressionSyncJob), PSRemotingTransportException + FullyQualifiedErrorId: JobFailure
Причина
Эта проблема возникает, поскольку включена трассировка тег ClientThrottlingState. При включении этого тега трассировки и при выполнении команды PowerShell пул приложений завершает работу и перезапускается затем.
Решение
Для решения этой проблемы установите накопительный пакет обновления, описанного в следующей статье базы знаний Майкрософт:
982639 Описание накопительного пакета обновления 4 для Exchange Server 2010
Обходное решение
Чтобы обойти эту проблему, отключите тег ADProvider и тег ClientThrottlingState. Не удаляйте теги включены или снимите тип трассировки отладки . Для этого выполните следующие действия:
-
В меню Пуск выберите пункт Выполнить.
-
В поле Открыть введите C:\Program Files\Microsoft\Exchange Server\V14\Bin\extra.exe , а затем нажмите кнопку ОК.
-
Нажмите кнопку Перейти в окно приветствияи нажмите кнопку выбрать задачу.
-
Щелкните Элемент управления трассировкии нажмите кнопку ОК.
-
Нажмите кнопку задать теги трассировки вручную.
-
На следующей странице вкладки компоненты для трассировки выберите пункт ADProvider и снимите флажок « ClientThrottlingState » на вкладке Теги трассировки . Или снимите флажок « Отладка ».
-
Нажмите кнопку Пуск трассировкии нажмите кнопку Остановить трассировку.
-
Нажмите кнопку Exit.
Даже после остановки трассировки и отключить тег, эта ошибка может повторяться в течение времени. Проблема не исчезнет, если свойство Debug TraceLevel содержится в теге ADProvider:ClientThrottlingState в файле EnabledTraces.Config . Если продолжают возникать проблемы, переименовать или удалить файл EnabledTraces.Config на системном диске (диск C).
Статус
Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".