Войти с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Select a different account.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой вы хотите войти.

Предположим, что вы хотите узнать, сколько времени сотруднику требуется на завершение работы в строке сборки или заказ на питание для обработки в пиковые часы. Существует несколько способов вычисления разницы между двумя значениями времени.

Представить результат в стандартном формате времени

Существует два подхода, которые можно использовать для того, чтобы представить результаты в стандартном формате времени (часы: минуты : секунды). Для поиска разницы между значениями времени используется оператор вычитания(-),а затем сделайте следующее:

Применив к ячейке пользовательский код формата, с помощью следующих элементов:

  1. Выделите ячейку.

  2. На вкладке Главная в группе Число щелкните стрелку рядом с полем Общие и выберите другие числовые форматы.

  3. В диалоговом окне Формат ячеек в списке Категория выберите настраиваемый формат, а затем в поле Тип выберите пользовательский формат.

Для форматирование времени используйте функцию ТЕКСТ. При использовании кодов формата времени количество часов не превышает 24, минуты никогда не превышают 60, а секунды никогда не превышают 60.

Пример таблицы 1. Представляем результат в стандартном формате времени

Скопируйте таблицу ниже на пустой лист и при необходимости измените ее.

A

B

1

Время начала

Время окончания

2

09.06.2007, 10:35

09.06.2007, 15:30

3

Формула

Описание (результат)

4

=B2-A2

Часы между двумя разами (4). К ячейке необходимо вручную применить пользовательский формат "а".

5

=B2-A2

Часы и минуты между двумя разами (4:55). К ячейке необходимо вручную применить пользовательский формат "ч:мм".

6

=B2-A2

Часы, минуты и секунды между двумя временами (4:55:00). К ячейке необходимо вручную применить пользовательский формат "ч:мм:сс".

7

=ТЕКСТ(B2-A2;"h")

Часы между двумя ячейками с форматом "ч" с помощью функции ТЕКСТ (4).

8

=ТЕКСТ(B2-A2;"ч:мм")

Часы и минуты между двумя ячейками с форматом "ч:мм" с помощью функции ТЕКСТ (4:55).

9

=ТЕКСТ(B2-A2;"ч:мм:сс")

Часы, минуты и секунды между двумя ячейками с форматом "ч:мм:сс" с помощью функции ТЕКСТ (4:55:00).

Примечание: Если использовать оба формата с функцией ТЕКСТ и применить к ячейке числовом формате, функция ТЕКСТ имеет приоритет над форматированием ячейки.

Дополнительные сведения об использовании этих функций см. в функциях ТЕКСТ и Отображение чисел в виде дат и времени.

Пример таблицы 2. Представляем результат на основе одной единицы времени

Для этого нужно использовать функцию INT или функции ЧАС,МИНУТЫ и СЕКУНДЫ,как показано в примере ниже.

Скопируйте таблицу ниже на пустой лист и при необходимости измените ее.

A

B

1

Время начала

Время окончания

2

09.06.2007, 10:35

09.06.2007, 15:30

3

Формула

Описание (результат)

4

=INT((B2-A2)*24)

Общее количество часов между двумя временами (4)

5

=(B2-A2)*1440

Общее количество минут между двумя числами времени (295)

6

=(B2-A2)*86400

Общее количество секунд между двумя числами времени (17700)

7

=ЧАС(B2-A2)

Разница в единицах времени между двумя значениями времени. Это значение не может превышать 24 (4).

8

=МИНУТЫ(B2-A2)

Разница в единицах времени между двумя значениями времени. Это значение не может превышать 60 (55).

9

=СЕКУНДЫ(B2-A2)

Разница в единицах секунды между двумя значениями времени. Это значение не может превышать 60 (0).

Дополнительные сведения об использовании этих функций см. в функциях INT,HOUR,MINUTEи SECOND.

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×