Исправление ошибки #ЗНАЧ! в функции СЦЕПИТЬ

Важно: В Excel 2016, Excel Mobile и Excel в Интернете функция С CONCATENATE была перемежана функцией СОВКА. Функция СЦЕПИТЬ пока еще доступна для обратной совместимости, однако рекомендуем использовать вместо нее функцию СЦЕП, так как ее возможности шире.

Одной из наиболее распространенных ситуаций возникновения ошибки #ЗНАЧ! при использовании функции СЦЕПИТЬ является попытка сформировать строку, которая включает в себя ссылку на ячейку с ошибкой, например #ЗНАЧ!.

В следующем примере мы хотим согнуть D2, E2 и F2, где e2 имеет #VALUE! ошибка "#ЗНАЧ!".

Ошибка #ЗНАЧ! в функции СЦЕПИТЬ

Ошибка в E2 вызывает отображение ошибки #VALUE! ошибка "#ЗНАЧ!". Для успешной работы ошибки необходимо заменить ее значением, кроме ошибки. Вы можете создать формулу для проверки на наличие ошибок в ссылке на ячейку и, если да, отобразить текстовую строку, в которой вместо ошибки отображается 0 (или вы можете заменить собственный текст на 0, но текст необходимо заверять в кавычках — "Ваш текст").

Следующая формула будет работать правильно:

=ЕСЛИ(ЕОШИБКА(E2);СЦЕПИТЬ(D2;" ";0;" ";F2))

Использование функций ЕСЛИ и ЕОШИБКА для сцепления строк в качестве обходного пути при возникновении ошибки #ЗНАЧ!

Как это работает? Функция ЕСЛИ использует функцию ЕСЛИМЕСЯК для определения на значение ошибки в E2 и при ее наступлении функция С CONCATENATE объединяет значения в D2, E2 и F2 (эта функция заменяет ошибку на 0) и отображает итоговую текстовую строку. Обратите внимание, что в формуле также используются пробелы (" "), чтобы разделять значения.

Исправление ошибки #VALUE! в функции СЦЕПИТЬ в Excel 2003 и более ранних версиях

Если ошибка #ЗНАЧ! возникает в Office Excel 2003 или более ранних версиях, необходимо отключить параметр "вычисления по правилам 1-2-3" в Excel. Выполните действия, описанные в #VALUE! при совмечении ячеек .

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ! #BUSY!

Функция СЦЕПИТЬ

Функция СЦЕП

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×