Операторы указывают тип вычисления, который требуется выполнить с элементами формулы, такими как сложения, вычитания, умножения или деления. В этой статье вы узнаете порядок по умолчанию, в котором операторы работают с элементами в вычислении. Вы также узнаете, как изменить этот порядок с помощью скобок.

Типы операторов

Приложение Microsoft Excel поддерживает четыре типа операторов: арифметические, текстовые, операторы сравнения и операторы ссылок.

Для выполнения основных математических операций, таких как сложения, вычитания или умножения или объединения чисел, и получения числовых результатов, используйте арифметические операторы в этой таблице.

Арифметический оператор

Значение

Пример

+ (знак «плюс»)

Сложение

=3+3

– (знак «минус»)

Вычитание
Отрицание

=3–1
=–1

* (звездочка)

Умножение

=3*3

/ (косая черта)

Деление

=3/3

% (знак процента)

Доля

=20 %

^ (крышка)

Возведение в степень

=2^3

С помощью операторов в таблице ниже можно сравнить два значения. При сравнении двух значений с помощью этих операторов результатом является логическое значение TRUE или FALSE.

Оператор сравнения

Значение

Пример

= (знак равенства)

Равно

=A1=B1

> (знак «больше»)

Больше

=A1>B1

< (знак «меньше»)

Меньше

=A1<B1

>= (знак «больше или равно»)

Больше или равно

=A1>=B1

<= (знак «меньше или равно»)

Меньше или равно

=A1<=B1

<> (знак «не равно»)

Не равно

=A1<>B1

Используйте амперсанд (&) для объединения или объединения одной или нескольких текстовых строк для создания одного фрагмента текста.

Текстовый оператор

Значение

Пример

& (амперсанд)

Соединяет или сцепляет два значения для получения одного непрерывного текстового значения.

="North"&"wind"

Объедините диапазоны ячеек для вычислений с этими операторами.

Оператор ссылки

Значение

Пример

: (двоеточие)

Оператор диапазона, который образует одну ссылку на все ячейки, находящиеся между первой и последней ячейками диапазона, включая эти ячейки.

=СУММ(B5:B15)

, (запятая)

Оператор Union, объединяющий несколько ссылок в одну ссылку.

=СУММ(B5:B15;D5:D15)

(пробел)

Оператор пересечения, который создает ссылку на ячейки, общие для двух ссылок.

=СУММ(B7:D7 C6:C8)

# (решетка)

Символ #используется в нескольких контекстах:

  • Используется как часть имени ошибки.

  • Используется, чтобы указать недостаточно места для отрисовки. В большинстве случаев столбец можно расширить до тех пор, пока содержимое не отобразится должным образом.

  • Оператор пролитого диапазона, который используется для ссылки на весь диапазон в формуле динамического массива.

  • #ЗНАЧ!

  • #####

  • =СУММ(A2#)

@ (по адресу)

Оператор ссылки, который используется для определения неявного пересечения в формуле. 

=@A1:A10

=СУММ(Таблица1[@[Январь]:[Декабрь]])

Порядок выполнения действий в формулах Excel

В некоторых случаях порядок выполнения вычисления может повлиять на возвращаемое значение формулы, поэтому важно понимать порядок и способ изменения порядка для получения ожидаемых результатов.

Формулы вычисляют значения в определенном порядке. Формула в Excel всегда начинается со знака равенства (=). Знак равенства сообщает Excel, что следующие символы составляют формулу. После этого знака равенства можно вычислить ряд элементов (операндов), разделенных операторами вычислений. Excel вычисляет формулу слева направо в соответствии с определенным порядком для каждого оператора в формуле.

Если в одной формуле используется несколько операторов, Microsoft Excel выполняет операции в порядке, указанном в приведенной ниже таблице. Если формула содержит операторы с одинаковым приоритетом — например, операторы деления и умножения, — они выполняются слева направо.

Оператор

Описание

: (двоеточие)

(один пробел)

, (запятая)

Операторы ссылок

Знак «минус»

%

Процент

^

Возведение в степень

* и /

Умножение и деление

+ и -

Сложение и вычитание

&

Объединение двух текстовых строк в одну

=
< >
<=
>=
<>

Сравнение

Чтобы изменить порядок вычисления формулы, заключите ее часть, которая должна быть выполнена первой, в скобки. Например, приведенная ниже формула возвращает значение 11, так как Excel вычисляет умножение перед добавлением. Формула сначала умножает 2 на 3, а затем добавляет 5 к результату.

=5+2*3

Напротив, если для изменения синтаксиса используются круглые скобки, Excel 5 и 2, а затем умножает результат на 3, чтобы получить 21.

=(5+2)*3

В приведенном ниже примере скобки, включаемые в первую часть формулы, принудит Excel сначала вычислить B4+25, а затем разделить результат на сумму значений в ячейках D5, E5 и F5.

=(B4+25)/СУММ(D5:F5)

Просмотрите это видео по порядку операторов в Excel, чтобы узнать больше.

Преобразование Excel значений в формулах

При вводе формулы Excel ожидает определенные типы значений для каждого оператора. Если ввести значение, отличное от ожидаемого, Excel может преобразовать это значение.

Формула

Производит

Описание

= "1"+"2"

3

При использовании знака "плюс" (+) Excel числа в формуле. Хотя кавычки означают, что "1" и "2" являются текстовыми значениями, Excel автоматически преобразует текстовые значения в числа.

= 1+"$4,00"

5

Если формула ожидает числа, Excel преобразует текст, если он имеет формат, который обычно принимается для числа.

= "1.06.2001"-"5/1/2001"

31

Excel интерпретирует текст как дату в формате мм/дд/дд/yyyy, преобразует даты в серийные числа, а затем вычисляет разницу между ними.

=SQRT ("8+1")

#ЗНАЧ!

Excel не удается преобразовать текст в число, так как текст "8+1" не может быть преобразован в число. Для преобразования текста в число и возврата результата 3 можно использовать "9" или "8"+"1" вместо "8+1".

= "A"&TRUE

ATRUE

Если текст ожидается, Excel преобразует числа и логические значения, такие как TRUE и FALSE, в текст.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×