Ошибка: #50004003 (исправление SQL)
Корпорация Майкрософт распространяет исправления Microsoft SQL Server 2008 в виде одного загружаемого файла. Поскольку исправления являются накопительными, каждый новый выпуск содержит все исправления и исправления для системы безопасности, которые были включены в предыдущий выпуск исправления SQL Server 2008.
Проблема
При попытке создать оповещение о событии инструментария управления Windows (WMI) с помощью
sp_add_alert
хранимой процедуры в экземпляре именованного кластера Microsoft SQL Server 2008, появляется следующее сообщение об ошибке:
Примечание
MSG 22022, уровень 16, состояние 1, строка 0
Ошибка SQLServerAgent: Ошибка WMI: 0x80041013.
MSG 14511, уровень 16, состояние 1, процедура sp_verify_alert, строка 300
Он @wmi\_query не может быть выполнен в предоставленном @wmi\_namespace . Убедитесь, что класс событий, выбранный в запросе, существует в пространстве имен и что в запросе правильный синтаксис.
Примечание
Эта проблема не возникает, если имя сети SQL кластера содержит ровно 15 символов.
Имя сети SQL также называется виртуальным именем SQL Server.
Причина
Эта проблема возникает из-за того, что поставщик событий WMI не может подключиться к ядру СУБД SQL Server.
Решение
Исправление для этой проблемы впервые выпущено в накопительном пакете обновления 3. Для получения дополнительных сведений о том, как получить этот накопительный пакет обновления для SQL Server 2008, откройте статью со следующим номером в базе знаний Майкрософт:
960484 Накопительный пакет обновления 3 для SQL Server 2008 г. Так как сборки являются накопительными, каждый новый выпуск исправления содержит все исправления и исправления для системы безопасности, которые были включены в предыдущий выпуск исправления SQL Server 2008 г. Рекомендуется рассмотреть возможность применения последнего выпуска исправления, содержащего это исправление. Для просмотра статьи в базе знаний Майкрософт щелкните следующий номер статьи:
956909 Сборки SQL Server 2008 г., выпущенные после выпуска SQL Server 2008 г.
Временное решение
Чтобы обойти эту проблему, установите экземпляр кластера по умолчанию вместо именованного экземпляра кластера. Или присвойте кластеру сетевое имя SQL, состоящее ровно из 15 символов.
Прежде чем пытаться изменить имя виртуального SQL Server, убедитесь, что вы ознакомились со следующими элементами:
- SQL Server не поддерживает переименование серверов, участвующих в репликации, если только вы не используете доставку журналов вместе с репликацией. Дополнительный сервер в области доставки журналов можно переименовать, если основной сервер безвозвратно утерян. Дополнительные сведения см. на следующем веб-сайте Microsoft Developer Network (MSDN):
https://msdn.microsoft.com/library/ms151224.aspx - При переименовании виртуального сервера, для которого настроено использование зеркального отображения базы данных, необходимо отключить зеркальное отображение баз данных перед операцией переименования, а затем заново настроить зеркальное отображение базы данных, указав новое имя виртуального сервера. Метаданные для зеркального отображения баз данных не обновляются автоматически в соответствии с новым именем виртуального сервера.
Дополнительные сведения о переименовании виртуального экземпляра SQL Server см. на следующем веб-сайте MSDN:
https://msdn.microsoft.com/library/ms178083.aspx
Состояние
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».
Дополнительные сведения
Для получения дополнительных сведений о том, какие файлы изменены, и о предварительных требованиях для применения накопительного пакета обновления, содержащего исправление, описанное в этой статье базы знаний Майкрософт, щелкните номер статьи со следующим номером в базе знаний Майкрософт:
960484 Накопительный пакет обновления 3 для SQL Server 2008 г.Сообщение об ошибке, упомянутое в разделе "Симптомы", является универсальным сообщением об ошибке WMI. Это сообщение об ошибке может также возникать при различных других условиях, не описанных в этой статье. В этих случаях решения, описанные в этой статье, не применяются. Дополнительные сведения об одном задокументированном случае см. на веб-сайте корпорации Майкрософт по следующему адресу:
https://connect.microsoft.com/sqlserver/feedback/viewfeedback.aspx?feedbackid=351556
Ссылки
Дополнительные сведения о списке сборок, доступных после выпуска SQL Server 2008, см. в следующей статье базы знаний Майкрософт:
956909 Сборки SQL Server 2008 г., выпущенные после выпуска SQL Server 2008 г.
Дополнительные сведения о модели добавочного обслуживания для SQL Server см. в следующей статье базы знаний Майкрософт:
935897 Команда SQL Server предоставляет модель добавочного обслуживания для предоставления исправлений для обнаруженных проблем
Дополнительные сведения о схеме именования для обновлений SQL Server см. в следующей статье базы знаний Майкрософт:
822499 Новая схема именования пакетов обновления программного обеспечения Microsoft SQL Server Дополнительные сведения о терминологии обновления программного обеспечения см. в следующей статье базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программного обеспечения Майкрософт