Проблема
Рассмотрим следующий сценарий.
- У вас есть экземпляр SQL Server 2022 с развернутой локальной группой доступности.
- Объекты уровня сервера (логины и задания) создаются в контексте содержащейся группы доступности.
В этом случае после установки накопительного пакета обновления в данном экземпляре SQL Server возникает одна из следующих ошибок.
Ошибка 1
При сбое задания агент SQL Server появляется следующее сообщение об ошибке:
Не удается запустить выполнение шага 2 (причина: JobOwner <JobOwner> не имеет разрешений на использование прокси-сервера <#> для подсистемы SSIS). Шаг не удался.
Вы увидите журнал записей ошибок агента SQL Server, сообщения об ошибках похожи на следующие:
<Метка> времени - ! [298] Ошибка SQLServer: 208, недопустимое имя объекта «syssubsystems». [SQLSTATE 42S02]
<Метка> времени - ! [517] Ошибка SQL номер 208, серьезность 16
На этом этапе syssubsystems таблица отсутствует в msdb базе данных содержащейся группы доступности и существует в базе данных уровня msdb экземпляра. Чтобы устранить эти ошибки и обеспечить успешное выполнение заданий, можно вручную скопировать таблицу уровня syssubsystems экземпляра в msdb базу данных вложенной группы доступности, подключившись к прослушивателю и создав таблицу со строками в таблице.
Ошибка 2
После создания изолированной группы доступности каждые пять секунд появляется следующее сообщение об ошибке:
Активированный срабатывание '[dbo]. [sp_syspolicy_events_reader]», запущенных в очереди «<AGName>_AG_SYNC_CONTAINED_msdb.dbo.syspolicy_event_queue» выводит следующее: «Невозможно выполнить в качестве субъекта базы данных, так как субъект «##MS_PolicyEventProcessingLogin##» не существует, этот тип субъекта невозможно олицетворить, или у вас нет разрешения».
Ошибка 3
После того как Database Mail перестанет работать, при попытке запустить sysmail хранимую процедуру появится сообщение об ошибке, похожее на следующее:
Объект '[dbo]. [sp_syspolicy_events_reader]' не существует в базе данных "master" или является недопустимым для этой операции.
Ошибка 4
Если после создания автономной группы доступности подключиться к прослушивателю изолированной группы доступности и создать субъект входа SQL Server, в среде SQL Server Management Studio (SSMS) появится следующая ошибка при подключении с помощью субъекта входа:
Ошибка подключения к <прослушивателю>
Не удалось получить данные для этого запроса. (Microsoft.SqlServer.Management.Sdk.Sfc)
Возникла ошибка при выполнении инструкции или пакета Transact-SQL. (Microsoft.SqlServer.ConnectionInfo)
В разрешении EXECUTE было отказано объекту "xp_msver", базе данных "mssqlsystemresource", схеме "sys". (Microsoft SQL Server, ошибка: 229)
Эта ошибка возникает из-за того, public что роли не предоставлено EXECUTE разрешение на расширенную xp_msver хранимую процедуру в master группы доступности (AG).
Решение
Эта проблема устранена в следующем накопительном пакете обновления для SQL Server:
Накопительный пакет обновления 4 для SQL Server 2022
Сведения о накопительных обновлениях для SQL Server
Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые были в предыдущей сборке. Рекомендуется установить последнюю сборку для вашей версии SQL Server.
Последний накопительный пакет обновления для SQL Server 2022
Состояние
Корпорация Майкрософт в настоящее время изучает эти проблемы. Эта статья будет обновляться по мере поиска дополнительных сведений и рекомендаций. Тем временем вы можете принять необходимые меры предосторожности перед установкой накопительного пакета обновления в установке, содержащей содержащую группу доступности:
- Создайте сценарии объектов уровня server и объектов агент SQL Server.
- Удалите содержащуюся группу доступности.
- Примените накопительный пакет обновления.
- Повторно создайте содержащую группу доступности.
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».
Ссылки
Узнайте о терминологии, используемой корпорацией Майкрософт для описания обновлений программного обеспечения.