Симптомы
После включения проверки подлинности библиотеки Azure AD (ADAL) пользователям не удается войти в программу Skype для бизнеса, и они получают следующее сообщение об ошибке:
Вы не получите вход. Она может быть ваш адрес или входа в систему учетных данных для входа, так что Пробуйте их. Если это не поможет, обратитесь в службу поддержки.
Причина
Эта проблема возникает, так как встроенная проверка подлинности Windows включена для URL-адреса ADAL Security Token Service (STS). Таким образом пользователи войти в Skype для бизнеса, используя учетные данные другого пользователя, чем для учетной записи, войти в операционную систему.
Решение
Чтобы устранить эту проблему, измените Internet Explorer параметры «Проверка подлинности пользователя» на соответствующих клиентских компьютерах «запрашивать имя пользователя и пароль» в зоне безопасности. Для этого воспользуйтесь одним из следующих способов.
Способ 1: Изменить параметр вручную
-
В обозревателе Internet Explorer нажмите кнопку Сервис, выберите пункт Свойства обозревателяи перейдите на вкладку Безопасность .
-
Выберите зону безопасности с URL-адресом STS. Как правило это в зону Местной интрасети .
-
Нажмите кнопку « другой » и прокрутите в конец списка параметров .
-
В разделе Проверка подлинности пользователя выберите параметр Запрашивать имя пользователя и пароль .
Способ 2: С помощью групповой политики
Push следующий раздел реестра на соответствующих клиентских компьютерах с помощью следующих объекта групповой политики:
-
Расположение: HKEY_LOCAL\MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1
-
Имя значения: 1A00
-
Тип: REG_DWORD
-
Значение: 0x10000
Значение 0x10000 представляет параметр «Запрашивать имя пользователя и пароль».
Дополнительные сведения
Когда разрешает URL-адрес ADAL STS на внутренний сервер ADFS и встроенная проверка подлинности Windows включена в веб-обозревателях, компьютеры, на которых многие пользователи войти в клиентских приложениях не проверка подлинности попыток входа в систему. Чтобы избежать этой проблемы, обозреватель должен быть явным образом настроен предлагала пользователям ввести свои учетные данные в конкретном обозревателе зоны безопасности. Например таким образом настроен киоске. Учетная запись, войти в операционную систему может отличаться от учетной записи пользователя, которая используется для входа в программу Skype для бизнеса клиента. В этом случае могут появиться ошибки, описанные в разделе «Проблема».
При наличии стенды, на которых пользователь, запускающий Skype для бизнеса клиента отличается (то есть имеет другой учетной записью) пользователя, вошедшего в систему, может потребоваться проверить метод включить параметр Запрашивать имя пользователя и пароль для этих компьютеров в групповой политике.
Ссылки
Использование современных проверки подлинности (ADAL) с Skype для бизнеса