Симптом
При попытке доступа к странице центра Project бизнес-портала в Microsoft Dynamics GP вы получаете следующее сообщение об ошибке:
У вас нет записи пользователя в личных данных. Обратитесь за помощью к администратору GP Microsoft Dynamics
Причина
Эта проблема имеет несколько причин:
-
Неправильный сотрудник связан с пользователем службы хранения личных данных (PDK).
-
Неправильный сотрудник связан с пользователем бизнес-портала.
-
После недавнего обновления, пакета обновления или создания тестовой базы данных в PDK40001 был изменен ИД компании.
Решение
1. Чтобы проверить, связан ли правильный ИД сотрудника с пользователем PDK, войдите в службу личных данных как sa. На вкладке Настройка нажмите кнопку Система и выберите пользователь. В окне Пользовательские настройки PDK введите ИД пользователя и компании для пользователя, который получил сообщение об ошибке. Проверьте правильность значения в поле "ИД сотрудника". Если он неправильный, удалите пользователя PDK и создайте его снова, используя правильный ИД сотрудника.
2. Чтобы проверить, связан ли правильный ИД сотрудника с пользователем бизнес-портала, заметьте ИД сотрудника, найденный в решении 1. Затем выполните следующие действия:
a. Войдите на портал Business Portal (BP) с пользователем, который имеет права администратора BP.
B. На домашней странице BP щелкните Действия сайта, а затем выберите Параметры.
Примечание. Если вы используете BP 5.1, для доступа к разделу Дополнительные роли перейдите в раздел Сайт Параметры для веб-сайта бизнес-портала верхнего уровня и щелкните Администрирование бизнес-портала.
C. В разделе Администрирование бизнес-портала щелкните Пользователи.
г. В списке пользователей найдите пользователя, у которого возникла проблема, и щелкните его.
д. В разделе Свойства пользователя перейдите на вкладку Роли.
е. В списке Ролей найдите строку с текстом Сотрудник — ИД сотрудника — "ваша компания".
Г. Совпадает ли значение в ИД сотрудника с разрешением 1? Это необходимо.
H. Если нет, нажмите кнопку Изменить, чтобы открыть окно Изменение портала и дополнительных ролей.
Я. В нижнем разделе с разделом "Роль/компания" найдите в нем "Сотрудник/ваша
компания". После того как сотрудники заполняют окно прокрутки, выберите ИД сотрудника, который был определен в решении 1.
K. Нажмите кнопку ОК и снова попробуйте пользователю BP попробовать свое время.
3. Убедитесь, что поле CMPNYNAM в PDK40001 является правильным CMPANYID. CMPANYID и CMPNYNAM должны отображаться в PDK40001 так же, как в SY01500.
Введите название компании на месте XXXXX.
выберите CMPANYID, CMPNYNAM, * из PDK40001, где CMPNYNAM = "XXXXX" выберите
CMPANYID, CMPNYNAM, * из SY01500, где CMPNYNAM = "XXXXX", Если они не совпадают, измените
CMPANYID в PDK40001, чтобы правильный код использовался с помощью инструмента запроса SQL.
Примечание. Создайте резервную копию перед запуском любых заявлений об обновлении базы данных.
Ниже приводится пример заявления об обновлении, который может использоваться: обновление
набора CMPANYID для PDK40001 = "YYYYY", где примечание CMPNYNAM = "XXXXX" введите название компании на месте XXXXX и ИД компании из
SY01500 для YYYYYYYY.