Проблемы
При выполнении потоков рабочего стола регулярно возникают следующие ошибки:
-
AgentNotReachable — запрошенный агент недоступен
-
UnresponsiveAgent — агент rpa не отвечает
Причина
Эти ошибки возникают, когда служба Power Automate, запущенная на компьютере, больше не может взаимодействовать с агентом в пользовательском сеансе, выполняющего поток. Они обычно вызваны неоптимальной производительностью компьютера, например высокой загрузкой ЦП, и могут временно блокировать обмен данными между службой и агентом.
Решение
Если у вас регулярно возникают такие ошибки, убедитесь, что компьютер соответствует минимальным требованиям.
Если у вас по-прежнему возникает эта проблема, попробуйте увеличить время ожидания, указанное службой power automate для связи с агентом. По умолчанию это значение равно 10 секундам. Для этого сделайте следующее:
-
Откройте реестр, чтобы: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Service
-
Добавьте новый DWORD (32-разрядная версия) и назовите его следующим образом: AgentPingTimeoutSeconds
-
Дважды щелкните значение, чтобы изменить его параметр. Прежде чем задать значение, нажмите переключатель "Decimal". Если вы используете прямое подключение к компьютеру (т. е. используете приложение среды выполнения компьютера для подключения компьютера к облаку), попробуйте увеличить значение до 30. Если вы используете локальный шлюз данных (не рекомендуется), измените значение на 15.
-
Перезапустите службу Power Automate, перейдя в диспетчер задач (CTRL-SHIFT-ESC), выбрав вкладку "Службы", выбрав "UIFlowService" в списке, щелкнув правой кнопкой мыши и выбрав перезапуск.