Симптомы
При попытке запустить Microsoft Dynamics SL, программа не запускается. Вместо этого появляется следующее сообщение об ошибке.
Системное сообщение 9827 - является несоответствие между идентификаторы имени входа SQL Server и их пароли, хранящиеся в базе данных системы Соломоновы. Попросите системного администратора выполнить обслуживание базы данных и обновление базы данных с помощью сценария обновления для синхронизации всех владельцев и безопасности.
Причина
Эта проблема возникает при выполнении одного из следующих условий:
-
Файл Capicom.dll не зарегистрирован. 1 в разделе «Решение» см.
-
Версия продукта и версия базы данных не совпадают. Эта проблема может возникнуть, если не были обновлены файлы программы Microsoft Dynamics SL для той же версии, что и база данных. Например при попытке использовать Пакет обновления 1 (SP1) для Соломоновы 6.0 программы для доступа к базе данных, созданный при использовании Microsoft Business Solutions - Соломоновы 6.0. 2 в разделе «Решение» см.
-
Пользователь SQL идентификаторы Master60SP и CD7359B5576446f85EB67E824B4770 не синхронизируются с Идентификатором пользователя образец базы данных системы Microsoft Соломоновы 6.0 Пакет обновления 1 (SP1). 3 в разделе «Решение» см.
-
Microsoft Dynamics SL баз данных были перемещены на новый сервер, но файл Solomon.ini по-прежнему указывает на старом сервере. 4 в разделе «Решение» см.
-
Базы данных Microsoft Dynamics SL находятся в однопользовательском режиме. 5 в разделе «Решение» см.
-
Протокол именованных каналов не первого протокола, указанного в Client Network Utility. Эта проблема возникает при входе в Пакет обновления 1 для Microsoft Dynamics SL 6.5. 6 в разделе «Решение» см.
-
Используется полное доменное имя (FQDN) сервера, на котором выполняется Microsoft SQL Server. 7 в разделе «Решение» см.
-
Политика паролей применяется счет код SQL CD7359B5576446f85EB67E824B4770. 8 в разделе «Решение» см.
-
Войти в систему с помощью учетной записи пользователя домена Windows, не связан с учетной записью пользователя Microsoft Dynamics SL. 9 в разделе «Решение» см.
-
Таблица домена содержит IP-адрес в поле «имя сервера», но файл Solomon.ini содержит фактическое имя сервера (с помощью символов). 10 в разделе «Решение» см.
Решение
Чтобы устранить эту проблему, используйте соответствующий метод.
Способ 1: Файл Capicom.dll зарегистрируйте вручную. Чтобы сделать это, выполните следующие действия.
Примечание Это разрешение не применяется к Microsoft Dynamics SL 2011
-
Найдите и откройте папку Windows\System32.
-
Файл Capicom.dll правой кнопкой мыши и выберите команду Открыть с помощью.
-
В диалоговом окне Windows щелкните выбрать программу из спискаи нажмите кнопку ОК.
-
Нажмите кнопку Обзорв диалоговом окне Открыть с помощью . Найдите и откройте папку Windows\System32.
-
Дважды щелкните файл Regsvr32.exe, а затем нажмите кнопку ОК. Появляется следующее сообщение:
RegSvr32 - выполнении операции DllRegisterServer в C:\windows\system32\capicom.dll.
-
Нажмите кнопку ОК.
Повторите эти действия на каждом компьютере, на котором появляется сообщение об ошибке, описанное в разделе «Проблема».
Способ 2: Убедитесь, что база данных и файлы программы тем же номером версии. Чтобы сделать это, выполните следующие действия.
-
Чтобы узнать версию базы данных, запустите следующий запрос в базе данных приложения в анализаторе запросов SQL.
SELECT S4Future01 FROM GLSetup
-
Чтобы найти файлы версии программы, выполните следующие действия.
-
Запустите Microsoft Dynamics SL.
-
В диалоговом окне входа в систему (98.000.00) дважды щелкните пустую область непосредственно над кнопкой Отмена . Появится диалоговое окно испытать .
-
Обратите внимание, версии и номера сборки ядра.
-
Найдите версию продукта и номер в списках, которые находятся в следующей статье базы знаний построения ядра:Дополнительные сведения о версии продукта и ядра построения, щелкните следующий номер статьи базы знаний Майкрософт:
Как определить версию, выпуск или ядра построения Соломоновы 850447
-
Убедитесь, что версия базы данных, записанного на шаге 1 соответствует версии продукта, записанное на шаге 2c.
-
При наличии неправильной версии Microsoft Dynamics SL установлен, установите правильную версию программы. Кроме того можно обновить базу данных до версии Microsoft Dynamics SL, которые установлены.
Способ 3: Удалить пользователя SQL идентификаторы Master60SP и CD7359B5576446f85EB67E824B4770, и Microsoft Dynamics SL повторно создать их. Чтобы сделать это, выполните следующие действия.
-
Запустите SQL Query Analyzer и выполните следующую инструкцию для всех баз данных Microsoft Dynamics SL.
sp_changedbowner sa
-
Запуск SQL Server Enterprise Manager.
-
Разверните узлы Microsoft SQL Servers.
-
Разверните Группу SQL Server.
-
Разверните экземпляр SQL Server.
-
Разверните узел Безопасность.
-
Дважды щелкните имена входа.
-
Щелкните правой кнопкой мыши Master60Sp (Master80 в 2011 году Dynamics SL), а затем нажмите кнопку Удалить.
-
Щелкните правой кнопкой мыши CD7359B5576446f85EB67E824B4770 (CD8359B5576446f85EB67E824B4770 в 2011 году Dynamics SL), а затем нажмите кнопку Удалить.
-
Закройте окно диспетчера предприятия.
-
Обслуживание базы данных используется для подключения к серверу, на котором выполняется Microsoft SQL Server. Чтобы сделать это, выполните следующие действия.
-
Откройте диалоговое окно Обслуживания базы данных (98.290.00) .
-
В поле Имя назначения SQL Server введите имя сервера.
-
Введите в поле Код входа sa.
-
В поле пароль введите пароль для администратора системы.
-
Нажмите кнопку подключения.
-
-
Перейдите на вкладку Обновить базы данных .
-
В поле Имя системы баз данных выберите базу данных системы.
-
В столбце « базы данных » выберите базу данных приложения.
-
В области Скриптов обновления выберите синхронизировать все владения и безопасности.
-
Нажмите кнопку Обновить базу данных.
-
Закройте диалоговое окно Обслуживания базы данных (98.290.00) .
-
Войдите в систему Microsoft Dynamics SL.
Способ 4: Переименуйте файл Solomon.ini, который находится на локальной рабочей станции. Чтобы сделать это, выполните следующие действия.
-
Поиск файла Solomon.ini на локальной рабочей станции. Этот файл обычно находится в одной из следующих папок:
-
C:\Windows
-
C:\Winnt
Важно. Не переименовывайте файл Solomon.ini, находящийся в папке файлов программы Microsoft Dynamics SL.
-
-
Щелкните правой кнопкой мыши файл и переименуйте его в Solomonini.bak.
-
Перезапустите Microsoft Dynamics SL.
Метод 5: Принимать из однопользовательского режима базы данных. Чтобы сделать это, выполните следующие действия.
-
Вход в SQL Server Enterprise Manager.
-
Разверните узел Серверы Microsoft SQL Server, разверните Группу SQL Server, разверните соответствующий сервер и затем разверните узел базы данных.
-
Щелкните правой кнопкой мыши соответствующую базу данных и выберите команду Свойства.
-
Откройте вкладку Параметры.
-
В области доступа снимите флажок ограничить доступ и нажмите кнопку ОК.
Примечание. Поместить в однопользовательском режиме, как часть процесса резервного копирования баз данных, которые затем автоматически изменяется на обычном режиме после завершения резервного копирования. При возникновении сбоя резервная копия базы данных может остаться в однопользовательском режиме. В этом случае необходимо вручную изменить режим обратно в обычный режим.
Метод 6: Сделайте именованных каналов первого протокола, указанного в Client Network Utility. Чтобы сделать это, выполните следующие действия.
-
В группе программ Microsoft SQL Server найдите и откройте в группе программ Microsoft SQL Server Client Network Utility.
-
На вкладке Общие найдите Именованных каналов в списке Включенные протоколы по порядку.
-
Если именованные каналы не первый протокол, указанный в включенные протоколы по порядку, выберите именованные каналы и затем нажмите стрелку вверх для перемещения именованные каналы в верхней части списка.
-
Нажмите кнопку ОК , чтобы принять изменения.
-
Перезапустите Microsoft Dynamics SL.
Метод 7: Добавление суффикса домена. Чтобы сделать это, выполните следующие действия.
-
Откройте диалоговое окно Дополнительные параметры TCP/IP . Чтобы сделать это, выполните следующие действия.
-
Войдите на компьютер с правами администратора.
-
Нажмите кнопку Пуск, выберите пункт Панель управленияи затем щелкните значок Сетевые подключения.
-
Щелкните правой кнопкой мыши подключение, которое требуется изменить и выберите команду Свойства.
-
В диалоговом окне Отмеченные компоненты используются этим подключением выберите пункт Протокол Интернета (TCP/IP)и нажмите кнопку Свойства.
-
Нажмите кнопку Дополнительно.
-
-
Перейдите на вкладку DNS .
-
Щелкните Дописывать следующие DNS-достаточнои нажмите кнопку Добавить.
-
Добавление суффикса домена. Для получения дополнительных сведений обратитесь к администратору сети.
Метод 8: Снимите флажок Включить политику паролей в среде SQL Server Management Studio. Для этого выполните следующие действия:
-
Войдите в среду SQL Server Management Studio.
-
В обозревателе объектов разверните узел Безопасностьи раскройте узел имена входа.
-
Щелкните правой кнопкой мыши CD7359B5576446f85EB67E824B4770и выберите команду Свойства.
-
Снимите флажок « требовать использование политики паролей » и нажмите кнопку ОК.
-
Выйдите из среды SQL Server Management Studio.
Примечание. Возможно, потребуется повторить действия по е для учетной записи SQL код Master60.
Метод 9: Свяжите учетную запись домена Windows с учетной записью пользователя Microsoft Dynamics SL. Чтобы сделать это, выполните следующие действия.
Примечание. Эти действия применимы только к Microsoft Dynamics SL 7.0 или более поздней версии, которые настроены на использование проверки подлинности Windows.
-
Войдите в Microsoft Dynamics SL пользователь sysadmin.
-
В области переходов щелкните ссылку Администрирование.
-
В области сведений диспетчера щелкните Обслуживание в разделе Безопасность .
-
В поле Код пользователя введите соответствующий идентификатор пользователя Microsoft Dynamics SL и затем нажмите клавишу TAB.
-
Введите соответствующий код учетной записи пользователя домена Windows в поле Имя пользователя Windows и нажмите кнопку Сохранить.
Примечание. Идентификатор учетной записи пользователя домена Windows необходимо ввести в следующем формате:Домен\код учетной записи пользователя домена Windows
Метод 10: Убедитесь, что поле ServerName в таблице домена содержит то же значение, как имя сервера, который определен в файле Solomon.ini. Чтобы сделать это, выполните следующие действия.
-
Вход в анализаторе запросов SQL или в SQL Server Management Studio.
-
В базе данных Microsoft Dynamics SL системы выполните следующую команду:
ВЫБЕРИТЕ имя сервера из домена
-
Откройте файл Solomon.ini в текстовом редакторе. В области [База данных System32] Обратите внимание на значение после Server =.
-
Если таблица домена содержит IP-адрес и файл Solomon.ini содержит имя сервера (с помощью символов), необходимо обновить таблицу доменов настоящее имя сервера. Чтобы сделать это, выполните следующую инструкцию в базе данных Microsoft Dynamics SL системы:
Обновление домена НАБОР имя_сервера = < Nameofserver >В этой команде «< Nameofserver >» — имя сервера, на котором указаны в файле Solomon.ini.
Способ 11: Настройка SQL Server для разрешения удаленных подключений.
Дополнительные сведения о разрешение удаленных подключений SQL Server щелкните следующий номер статьи базы знаний Майкрософт:
914277 как настроить SQL Server 2005 для удаленных подключений
Дополнительные сведения
Действия по воспроизведению проблемы
-
Нажмите кнопку Пуски выберите пункт Все программы.
-
Выберите Соломоновы решения Microsoft Businessи нажмите кнопку Соломоновы.
Появляется сообщение об ошибке, описанное в разделе «Проблема».